Bug 298363 - Random crashes
Summary: Random crashes
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-18 15:34 UTC by nanostrukturtechniker
Modified: 2012-04-18 16:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nanostrukturtechniker 2012-04-18 15:34:34 UTC
Application: kmail (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-23-generic x86_64
Distribution: Ubuntu precise (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

Just opening new mails while the backend collected new mails from the server.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc6574597c0 (LWP 3662))]

Thread 4 (Thread 0x7fc634ceb700 (LWP 3777)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fc64974ddec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fc64974df19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fc65227fe9a in start_thread (arg=0x7fc634ceb700) at pthread_create.c:308
#4  0x00007fc6547b04bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fc6343da700 (LWP 3778)):
#0  0x00007fc6547a4b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fc64d059ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc64d05a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc65513b426 in QEventDispatcherGlib::processEvents (this=0x7fc62c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fc65510ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc65510aed7 in QEventLoop::exec (this=0x7fc6343d9dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fc655009fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fc65500cfcb in QThreadPrivate::start (arg=0x2bd3500) at thread/qthread_unix.cpp:298
#8  0x00007fc65227fe9a in start_thread (arg=0x7fc6343da700) at pthread_create.c:308
#9  0x00007fc6547b04bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fc6314b2700 (LWP 3793)):
#0  0x00007fc6547a4b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fc64d059ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc64d05a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc65513b426 in QEventDispatcherGlib::processEvents (this=0x7fc5e00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fc65510ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc65510aed7 in QEventLoop::exec (this=0x7fc6314b1d90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fc655009fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fc6550ea9ff in QInotifyFileSystemWatcherEngine::run (this=0x30bec70) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fc65500cfcb in QThreadPrivate::start (arg=0x30bec70) at thread/qthread_unix.cpp:298
#9  0x00007fc65227fe9a in start_thread (arg=0x7fc6314b2700) at pthread_create.c:308
#10 0x00007fc6547b04bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc6574597c0 (LWP 3662)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x2de16c0, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007fc6537e5709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x2de16c0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007fc655125446 in QObject::event (this=0x2de16c0, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007fc65562e894 in notify_helper (e=0x7fc5cc007910, receiver=0x2de16c0, this=0x256d100) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x256d100, receiver=0x2de16c0, e=0x7fc5cc007910) at kernel/qapplication.cpp:4531
#11 0x00007fc655633713 in QApplication::notify (this=0x7fffca710470, receiver=0x2de16c0, e=0x7fc5cc007910) at kernel/qapplication.cpp:4420
#12 0x00007fc656e67b46 in KApplication::notify (this=0x7fffca710470, receiver=0x2de16c0, event=0x7fc5cc007910) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007fc65510be9c in QCoreApplication::notifyInternal (this=0x7fffca710470, receiver=0x2de16c0, event=0x7fc5cc007910) at kernel/qcoreapplication.cpp:876
#14 0x00007fc65510fc6a in sendEvent (event=0x7fc5cc007910, receiver=0x2de16c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x251b220) at kernel/qcoreapplication.cpp:1500
#16 0x00007fc65513af93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007fc64d059c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007fc64d05a060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007fc64d05a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fc65513b3bf in QEventDispatcherGlib::processEvents (this=0x251cb00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007fc6556d6d6e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007fc65510ac82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007fc65510aed7 in QEventLoop::exec (this=0x7fffca710350, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007fc65510ff67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000402bd3 in ?? ()
#27 0x00007fc6546df76d in __libc_start_main (main=0x4021a0, argc=3, ubp_av=0x7fffca7108c8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffca7108b8) at libc-start.c:226
#28 0x0000000000403095 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 298322, bug 296440, bug 296145, bug 295746, bug 295225.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-04-18 16:41:55 UTC

*** This bug has been marked as a duplicate of bug 286307 ***