Bug 298890 - K-Mail Crash Kubuntu 12.04
Summary: K-Mail Crash Kubuntu 12.04
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-27 08:23 UTC by Heiko Gimbel
Modified: 2012-04-27 12:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Gimbel 2012-04-27 08:23:30 UTC
Application: kmail (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I was reading E-mails. Deleeting several mails.
The Crash appears after some actions (opening,deleeting etc.).
Imap (GMX) is used for E-Mai Management

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4b23faa7c0 (LWP 3464))]

Thread 4 (Thread 0x7f4b0109e700 (LWP 3494)):
#0  0x00007f4b1edcfd84 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007f4b16299dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f4b16299f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f4b1edcbe9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#4  0x00007f4b212fc4bd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f4afbfff700 (LWP 3495)):
#0  0x00007f4b212f0b03 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f4b19ba5ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4b19ba6124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4b21c87426 in QEventDispatcherGlib::processEvents (this=0x7f4af40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f4b21c56c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f4b21c56ed7 in QEventLoop::exec (this=0x7f4afbffedc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f4b21b55fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f4b21b58fcb in QThreadPrivate::start (arg=0x1649fb0) at thread/qthread_unix.cpp:298
#8  0x00007f4b1edcbe9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#9  0x00007f4b212fc4bd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f4af940d700 (LWP 3537)):
#0  0x00007fff0d3ff98f in clock_gettime ()
#1  0x00007f4b18c2315d in clock_gettime () from /lib/x86_64-linux-gnu/librt.so.1
#2  0x00007f4b21bafbb4 in do_gettime (frac=0x7f4af940cb58, sec=0x7f4af940cb50) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f4b21c87b8d in QTimerInfoList::updateCurrentTime (this=0x7f4ab0002660) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f4b21c87ec3 in QTimerInfoList::timerWait (this=0x7f4ab0002660, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007f4b21c8697c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f4af940cc2c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f4b21c86a25 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f4b19ba571e in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f4b19ba5f1b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f4b19ba6124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f4b21c87426 in QEventDispatcherGlib::processEvents (this=0x7f4ab00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007f4b21c56c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f4b21c56ed7 in QEventLoop::exec (this=0x7f4af940cd90, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007f4b21b55fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007f4b21c369ff in QInotifyFileSystemWatcherEngine::run (this=0x1b27ff0) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007f4b21b58fcb in QThreadPrivate::start (arg=0x1b27ff0) at thread/qthread_unix.cpp:298
#17 0x00007f4b1edcbe9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#18 0x00007f4b212fc4bd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4b23faa7c0 (LWP 3464)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x3f2fb80, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f4b20331709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x3f2fb80, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f4b21c71446 in QObject::event (this=0x3f2fb80, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f4b2217a894 in notify_helper (e=0x7f4a98001b50, receiver=0x3f2fb80, this=0x10e2240) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x10e2240, receiver=0x3f2fb80, e=0x7f4a98001b50) at kernel/qapplication.cpp:4531
#11 0x00007f4b2217f713 in QApplication::notify (this=0x7fff0d3aaec0, receiver=0x3f2fb80, e=0x7f4a98001b50) at kernel/qapplication.cpp:4420
#12 0x00007f4b239b3b46 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#13 0x00007f4b21c57e9c in QCoreApplication::notifyInternal (this=0x7fff0d3aaec0, receiver=0x3f2fb80, event=0x7f4a98001b50) at kernel/qcoreapplication.cpp:876
#14 0x00007f4b21c5bc6a in sendEvent (event=0x7f4a98001b50, receiver=0x3f2fb80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1089220) at kernel/qcoreapplication.cpp:1500
#16 0x00007f4b21c86f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f4b19ba5c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f4b19ba6060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f4b19ba6124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f4b21c873bf in QEventDispatcherGlib::processEvents (this=0x108ab00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f4b22222d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f4b21c56c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f4b21c56ed7 in QEventLoop::exec (this=0x7fff0d3aada0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f4b21c5bf67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000402bd3 in ?? ()
#27 0x00007f4b2122b76d in __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
#28 0x0000000000403095 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 298869, bug 298363, bug 298322, bug 296440, bug 296145.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-04-27 12:14:22 UTC

*** This bug has been marked as a duplicate of bug 286307 ***