Bug 298608 - nemopuk crash
Summary: nemopuk crash
Status: RESOLVED DUPLICATE of bug 292950
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-22 15:34 UTC by blackmetalowiec
Modified: 2012-05-26 02:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description blackmetalowiec 2012-04-22 15:34:09 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-17-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I was printing some pdf file, then shutdown system, then crush and I can't shutdown

-- Backtrace:
Application: Tymczasowa usługa Nepomuka (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77b5710 (LWP 1717))]

Thread 8 (Thread 0xb5f17b70 (LWP 1797)):
#0  0x00193d50 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x053712f4 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x0217087f in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x02171637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x02171c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x007b5b37 in QEventDispatcherGlib::processEvents (this=0x9232db8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x007861dd in QEventLoop::processEvents (this=0xb5f172b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00786421 in QEventLoop::exec (this=0xb5f172b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0068990b in QThread::exec (this=0x9275670) at thread/qthread.cpp:498
#9  0x00766e2d in QInotifyFileSystemWatcherEngine::run (this=0x9275670) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0068c7b3 in QThreadPrivate::start (arg=0x9275670) at thread/qthread_unix.cpp:331
#11 0x00190d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x0536346e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 7 (Thread 0xb3712b70 (LWP 1876)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0x0078719e in QCoreApplication::notifyInternal (this=0xbf896c34, receiver=0x922cfd8, event=0xb3712094) at kernel/qcoreapplication.cpp:787
#9  0x007b51d8 in sendEvent (event=0xb3712094, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#10 socketNotifierSourceDispatch (source=0x9255aa0) at kernel/qeventdispatcher_glib.cpp:110
#11 0x0217125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#12 0x02171990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#13 0x02171c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#14 0x007b5ada in QEventDispatcherGlib::processEvents (this=0x9237788, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#15 0x007861dd in QEventLoop::processEvents (this=0xb3712290, flags=...) at kernel/qeventloop.cpp:149
#16 0x00786421 in QEventLoop::exec (this=0xb3712290, flags=...) at kernel/qeventloop.cpp:201
#17 0x0068990b in QThread::exec (this=0x957fdf8) at thread/qthread.cpp:498
#18 0x0298546c in ?? () from /usr/lib/libsopranoserver.so.1
#19 0x0068c7b3 in QThreadPrivate::start (arg=0x957fdf8) at thread/qthread_unix.cpp:331
#20 0x00190d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#21 0x0536346e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 6 (Thread 0xb2f11b70 (LWP 1877)):
#0  0x02170892 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x02171637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x02171c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x007b5b37 in QEventDispatcherGlib::processEvents (this=0x9277828, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x007861dd in QEventLoop::processEvents (this=0xb2f11290, flags=...) at kernel/qeventloop.cpp:149
#5  0x00786421 in QEventLoop::exec (this=0xb2f11290, flags=...) at kernel/qeventloop.cpp:201
#6  0x0068990b in QThread::exec (this=0x9463320) at thread/qthread.cpp:498
#7  0x0298546c in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x0068c7b3 in QThreadPrivate::start (arg=0x9463320) at thread/qthread_unix.cpp:331
#9  0x00190d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x0536346e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 5 (Thread 0xb2710b70 (LWP 1893)):
#0  0x00e16d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x006e37d5 in do_gettime (frac=0xb2710000, sec=0xb270fff8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x007b64b6 in QTimerInfoList::updateCurrentTime (this=0x9248b74) at kernel/qeventdispatcher_unix.cpp:339
#4  0x007b680a in QTimerInfoList::timerWait (this=0x9248b74, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x007b5053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb271010c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x007b50ed in timerSourcePrepare (source=0x9248b40, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0217088c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x02171637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x02171c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x007b5b37 in QEventDispatcherGlib::processEvents (this=0x925f0d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x007861dd in QEventLoop::processEvents (this=0xb2710290, flags=...) at kernel/qeventloop.cpp:149
#12 0x00786421 in QEventLoop::exec (this=0xb2710290, flags=...) at kernel/qeventloop.cpp:201
#13 0x0068990b in QThread::exec (this=0x92928f8) at thread/qthread.cpp:498
#14 0x0298546c in ?? () from /usr/lib/libsopranoserver.so.1
#15 0x0068c7b3 in QThreadPrivate::start (arg=0x92928f8) at thread/qthread_unix.cpp:331
#16 0x00190d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0536346e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 4 (Thread 0xb5716b70 (LWP 1904)):
#0  0x00e0a416 in __kernel_vsyscall ()
#1  0x053547ae in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0218034b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x02171896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x02171c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x007b5b37 in QEventDispatcherGlib::processEvents (this=0x9286b90, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x007861dd in QEventLoop::processEvents (this=0xb5716290, flags=...) at kernel/qeventloop.cpp:149
#7  0x00786421 in QEventLoop::exec (this=0xb5716290, flags=...) at kernel/qeventloop.cpp:201
#8  0x0068990b in QThread::exec (this=0x925e5c8) at thread/qthread.cpp:498
#9  0x0298546c in ?? () from /usr/lib/libsopranoserver.so.1
#10 0x0068c7b3 in QThreadPrivate::start (arg=0x925e5c8) at thread/qthread_unix.cpp:331
#11 0x00190d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x0536346e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xb1f0fb70 (LWP 1936)):
#0  0x007b64b9 in QTimerInfoList::updateCurrentTime (this=0x963a8b4) at kernel/qeventdispatcher_unix.cpp:339
#1  0x007b680a in QTimerInfoList::timerWait (this=0x963a8b4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#2  0x007b5053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb1f0f10c) at kernel/qeventdispatcher_glib.cpp:136
#3  0x007b50ed in timerSourcePrepare (source=0x963a880, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#4  0x0217088c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x02171637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0x02171c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0x007b5b37 in QEventDispatcherGlib::processEvents (this=0x924d300, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#8  0x007861dd in QEventLoop::processEvents (this=0xb1f0f290, flags=...) at kernel/qeventloop.cpp:149
#9  0x00786421 in QEventLoop::exec (this=0xb1f0f290, flags=...) at kernel/qeventloop.cpp:201
#10 0x0068990b in QThread::exec (this=0x959b0f0) at thread/qthread.cpp:498
#11 0x0298546c in ?? () from /usr/lib/libsopranoserver.so.1
#12 0x0068c7b3 in QThreadPrivate::start (arg=0x959b0f0) at thread/qthread_unix.cpp:331
#13 0x00190d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#14 0x0536346e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xb0dffb70 (LWP 2239)):
#0  0x00e0a416 in __kernel_vsyscall ()
#1  0x00194a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0537109c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x0068ccc0 in wait (time=4294967295, this=0x922fee0) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x922fe44, mutex=0x922fe40, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x006806e4 in QThreadPoolThread::run (this=0xb0e01f58) at concurrent/qthreadpool.cpp:140
#6  0x0068c7b3 in QThreadPrivate::start (arg=0xb0e01f58) at thread/qthread_unix.cpp:331
#7  0x00190d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x0536346e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77b5710 (LWP 1717)):
#0  0x00e0a416 in __kernel_vsyscall ()
#1  0x00194a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x0537109c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x0068ccc0 in wait (time=4294967295, this=0x9261930) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9226598, mutex=0x9226580, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x0068c475 in QThread::wait (this=0x957fdf8, time=4294967295) at thread/qthread_unix.cpp:745
#6  0x0298483a in ?? () from /usr/lib/libsopranoserver.so.1
#7  0x0298bf4a in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x02980a66 in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#9  0x028c1b30 in Nepomuk::Core::~Core (this=0x90ab970, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:46
#10 0x028c1c22 in Nepomuk::Core::~Core (this=0x90ab970, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:49
#11 0x0079b841 in QObjectPrivate::deleteChildren (this=0x91e9ab8) at kernel/qobject.cpp:1955
#12 0x007a0439 in QObject::~QObject (this=0x91ba118, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#13 0x00e81f98 in Nepomuk::Service::~Service (this=0x91ba118, __in_chrg=<optimized out>) at ../../nepomuk/core/nepomukservice.cpp:41
#14 0x028c09ba in ~Storage (this=0x91ba118, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:54
#15 Nepomuk::Storage::~Storage (this=0x91ba118, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:56
#16 0x0079b841 in QObjectPrivate::deleteChildren (this=0x91bb778) at kernel/qobject.cpp:1955
#17 0x007a0439 in QObject::~QObject (this=0x91e39f0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#18 0x0804b940 in Nepomuk::ServiceControl::~ServiceControl (this=0x91e39f0, __in_chrg=<optimized out>) at ../../../nepomuk/servicestub/servicecontrol.cpp:39
#19 0x0079b841 in QObjectPrivate::deleteChildren (this=0x90aa9f8) at kernel/qobject.cpp:1955
#20 0x007a0439 in QObject::~QObject (this=0xbf896c34, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#21 0x0078a648 in QCoreApplication::~QCoreApplication (this=0xbf896c34, __in_chrg=<optimized out>) at kernel/qcoreapplication.cpp:671
#22 0x01064973 in QApplication::~QApplication (this=0xbf896c34, __in_chrg=<optimized out>) at kernel/qapplication.cpp:1093
#23 0x00aae668 in KApplication::~KApplication (this=0xbf896c34, __in_chrg=<optimized out>) at ../../kdeui/kernel/kapplication.cpp:894
#24 0x0804aed1 in main (argc=) at ../../../nepomuk/servicestub/main.cpp:105

This bug may be a duplicate of or related to bug 281448.

Possible duplicates by query: bug 298353, bug 298217, bug 298151, bug 297443, bug 297065.

Reported using DrKonqi
Comment 1 Vishesh Handa 2012-05-26 02:08:06 UTC

*** This bug has been marked as a duplicate of bug 292950 ***