Bug 298217 - chrome hangs and KDE crashes when terminating process.
Summary: chrome hangs and KDE crashes when terminating process.
Status: RESOLVED DUPLICATE of bug 292950
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-16 02:18 UTC by Jan
Modified: 2012-05-26 02:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan 2012-04-16 02:18:06 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-17-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

chrome hangs and KDE crashes when terminating process.
Chrome will not start, killing process causes KDE to crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
	in ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S
[Current thread is 1 (Thread 0x7fbc25a7b780 (LWP 1814))]

Thread 6 (Thread 0x7fbc10089700 (LWP 2009)):
#0  0x00007fff2759a92c in clock_gettime ()
#1  0x00007fbc225b407b in __GI_clock_gettime (clock_id=1, tp=0x7fbc10088b40) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007fbc254cb074 in do_gettime (frac=0x7fbc10088b58, sec=0x7fbc10088b50) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fbc2558d6ed in QTimerInfoList::updateCurrentTime (this=0x7fbc080434f0) at kernel/qeventdispatcher_unix.cpp:339
#5  0x00007fbc2558da33 in QTimerInfoList::timerWait (this=0x7fbc080434f0, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#6  0x00007fbc2558c44c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fbc10088c3c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fbc2558c4f5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fbc222fdff2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fbc222fedfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fbc222ff429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fbc2558cf3e in QEventDispatcherGlib::processEvents (this=0x122f270, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#12 0x00007fbc25560cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fbc25560ef7 in QEventLoop::exec (this=0x7fbc10088dd0, flags=...) at kernel/qeventloop.cpp:201
#14 0x00007fbc2547827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#15 0x00007fbc25543cbf in QInotifyFileSystemWatcherEngine::run (this=0x122b100) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007fbc2547ad05 in QThreadPrivate::start (arg=0x122b100) at thread/qthread_unix.cpp:331
#17 0x00007fbc22de0efc in start_thread (arg=0x7fbc10089700) at pthread_create.c:304
#18 0x00007fbc230d959d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fbc0f888700 (LWP 28149)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fbc2547b1ab in wait (time=18446744073709551615, this=0x12b8fc0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x12b8ef0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fbc2546f81f in QThreadPoolThread::run (this=0x7fbc0801fce0) at concurrent/qthreadpool.cpp:140
#4  0x00007fbc2547ad05 in QThreadPrivate::start (arg=0x7fbc0801fce0) at thread/qthread_unix.cpp:331
#5  0x00007fbc22de0efc in start_thread (arg=0x7fbc0f888700) at pthread_create.c:304
#6  0x00007fbc230d959d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fbc06ffd700 (LWP 28150)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fbc25561afc in QCoreApplication::notifyInternal (this=0x7fff2744d600, receiver=0x1799450, event=0x7fbc06ffcb50) at kernel/qcoreapplication.cpp:787
#8  0x00007fbc2558c5b7 in sendEvent (event=0x7fbc06ffcb50, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#9  socketNotifierSourceDispatch (source=0x17cee50) at kernel/qeventdispatcher_glib.cpp:110
#10 0x00007fbc222fea5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fbc222ff258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007fbc222ff429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007fbc2558ced6 in QEventDispatcherGlib::processEvents (this=0x10e16f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#14 0x00007fbc25560cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#15 0x00007fbc25560ef7 in QEventLoop::exec (this=0x7fbc06ffcd60, flags=...) at kernel/qeventloop.cpp:201
#16 0x00007fbc2547827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#17 0x00007fbc162000ae in ?? () from /usr/lib/libsopranoserver.so.1
#18 0x00007fbc2547ad05 in QThreadPrivate::start (arg=0x7fbc0804ed80) at thread/qthread_unix.cpp:331
#19 0x00007fbc22de0efc in start_thread (arg=0x7fbc06ffd700) at pthread_create.c:304
#20 0x00007fbc230d959d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#21 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fbc067fc700 (LWP 28151)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fbc2547b1ab in wait (time=18446744073709551615, this=0x12b8fc0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x12b8ef0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fbc2546f81f in QThreadPoolThread::run (this=0x7fbc08012a60) at concurrent/qthreadpool.cpp:140
#4  0x00007fbc2547ad05 in QThreadPrivate::start (arg=0x7fbc08012a60) at thread/qthread_unix.cpp:331
#5  0x00007fbc22de0efc in start_thread (arg=0x7fbc067fc700) at pthread_create.c:304
#6  0x00007fbc230d959d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fbc05ffb700 (LWP 28152)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fbc2547b1ab in wait (time=18446744073709551615, this=0x12b8fc0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x12b8ef0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fbc2546f81f in QThreadPoolThread::run (this=0x7fbc08013c70) at concurrent/qthreadpool.cpp:140
#4  0x00007fbc2547ad05 in QThreadPrivate::start (arg=0x7fbc08013c70) at thread/qthread_unix.cpp:331
#5  0x00007fbc22de0efc in start_thread (arg=0x7fbc05ffb700) at pthread_create.c:304
#6  0x00007fbc230d959d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fbc25a7b780 (LWP 1814)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fbc2547b1ab in wait (time=18446744073709551615, this=0x7fbc08041820) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fbc08045460, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fbc2547aa4c in QThread::wait (this=<optimized out>, time=18446744073709551615) at thread/qthread_unix.cpp:745
#4  0x00007fbc161ff628 in ?? () from /usr/lib/libsopranoserver.so.1
#5  0x00007fbc16205c43 in ?? () from /usr/lib/libsopranoserver.so.1
#6  0x00007fbc161fbe7e in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#7  0x00007fbc16433c8c in Nepomuk::Core::~Core (this=0x11920e0, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:46
#8  0x00007fbc16433d39 in Nepomuk::Core::~Core (this=0x11920e0, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:49
#9  0x00007fbc25573d75 in QObjectPrivate::deleteChildren (this=0x1192000) at kernel/qobject.cpp:1955
#10 0x00007fbc25579349 in QObject::~QObject (this=0x11bc670, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#11 0x00007fbc16432ef3 in ~Storage (this=0x11bc670, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:54
#12 Nepomuk::Storage::~Storage (this=0x11bc670, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:56
#13 0x00007fbc25573d75 in QObjectPrivate::deleteChildren (this=0x116af50) at kernel/qobject.cpp:1955
#14 0x00007fbc25579349 in QObject::~QObject (this=0x11694a0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#15 0x0000000000404439 in Nepomuk::ServiceControl::~ServiceControl (this=0x11694a0, __in_chrg=<optimized out>) at ../../../nepomuk/servicestub/servicecontrol.cpp:39
#16 0x00007fbc25573d75 in QObjectPrivate::deleteChildren (this=0x1001d10) at kernel/qobject.cpp:1955
#17 0x00007fbc25579349 in QObject::~QObject (this=0x7fff2744d600, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#18 0x00007fbc238a3fd7 in QApplication::~QApplication (this=0x7fff2744d600, __in_chrg=<optimized out>) at kernel/qapplication.cpp:1093
#19 0x0000000000403a54 in main (argc=2, argv=0x7fff2744daa8) at ../../../nepomuk/servicestub/main.cpp:105

Possible duplicates by query: bug 298151, bug 297443, bug 297065, bug 296877, bug 296537.

Reported using DrKonqi
Comment 1 Vishesh Handa 2012-05-26 02:08:10 UTC

*** This bug has been marked as a duplicate of bug 292950 ***