Bug 281448 - Nepomuk crashes while shutting down
Summary: Nepomuk crashes while shutting down
Status: RESOLVED DUPLICATE of bug 257176
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
: 255595 257372 258346 267019 271109 274197 275245 277380 278250 278849 279679 280353 281094 281201 282086 282117 282312 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-06 05:29 UTC by Christian Braumann
Modified: 2011-09-19 12:46 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Braumann 2011-09-06 05:29:28 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.7.00 (4.7.0)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

I shut down KDE and switched off my PC. Then Nepomuk crashed.

-- Backtrace:
Application: Nepomuk-Dienst (nepomukservicestub), signal: Segmentation fault
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
	in ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S
[Current thread is 1 (Thread 0x7ffb3ddae780 (LWP 2190))]

Thread 9 (Thread 0x7ffb28a9c700 (LWP 2210)):
#0  0x00007ffb3b484f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ffb3a6b9104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffb3a6b9639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffb3d8cf446 in QEventDispatcherGlib::processEvents (this=0x139eae0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ffb3d8a3882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ffb3d8a3abc in QEventLoop::exec (this=0x7ffb28a9bdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ffb3d7ba924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007ffb3d885c2f in QInotifyFileSystemWatcherEngine::run (this=0x13ac9d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ffb3d7bd175 in QThreadPrivate::start (arg=0x13ac9d0) at thread/qthread_unix.cpp:320
#9  0x00007ffb3b194d8c in start_thread (arg=0x7ffb28a9c700) at pthread_create.c:304
#10 0x00007ffb3b49204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7ffb27299700 (LWP 2225)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007ffb3d8a449c in QCoreApplication::notifyInternal (this=0x7fffbfc67500, receiver=0x1380440, event=0x7ffb27298b50) at kernel/qcoreapplication.cpp:731
#8  0x00007ffb3d8ceda9 in sendEvent (source=0x13cf6c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#9  socketNotifierSourceDispatch (source=0x13cf6c0) at kernel/qeventdispatcher_glib.cpp:110
#10 0x00007ffb3a6b8bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007ffb3a6b93a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007ffb3a6b9639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007ffb3d8cf3ef in QEventDispatcherGlib::processEvents (this=0x13a26b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#14 0x00007ffb3d8a3882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#15 0x00007ffb3d8a3abc in QEventLoop::exec (this=0x7ffb27298d50, flags=...) at kernel/qeventloop.cpp:201
#16 0x00007ffb3d7ba924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#17 0x00007ffb2e7be2b1 in ?? () from /usr/lib/libsopranoserver.so.1
#18 0x00007ffb3d7bd175 in QThreadPrivate::start (arg=0x7ffb200014c0) at thread/qthread_unix.cpp:320
#19 0x00007ffb3b194d8c in start_thread (arg=0x7ffb27299700) at pthread_create.c:304
#20 0x00007ffb3b49204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#21 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7ffb26297700 (LWP 2235)):
#0  0x00007ffb3b1973c4 in __pthread_mutex_lock (mutex=0x14730c8) at pthread_mutex_lock.c:61
#1  0x00007ffb3a6b7869 in g_main_context_release () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffb3a6b913a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffb3a6b9639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ffb3d8cf446 in QEventDispatcherGlib::processEvents (this=0x137bc60, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007ffb3d8a3882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007ffb3d8a3abc in QEventLoop::exec (this=0x7ffb26296d50, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007ffb3d7ba924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007ffb2e7be2b1 in ?? () from /usr/lib/libsopranoserver.so.1
#9  0x00007ffb3d7bd175 in QThreadPrivate::start (arg=0x7ffb20000e60) at thread/qthread_unix.cpp:320
#10 0x00007ffb3b194d8c in start_thread (arg=0x7ffb26297700) at pthread_create.c:304
#11 0x00007ffb3b49204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7ffb25a96700 (LWP 2237)):
#0  0x00007ffb3a68dbb0 in g_ptr_array_set_size () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ffb3a6b7fb0 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffb3a6b8f9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffb3a6b9639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ffb3d8cf446 in QEventDispatcherGlib::processEvents (this=0x13fd440, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007ffb3d8a3882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007ffb3d8a3abc in QEventLoop::exec (this=0x7ffb25a95d50, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007ffb3d7ba924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007ffb2e7be2b1 in ?? () from /usr/lib/libsopranoserver.so.1
#9  0x00007ffb3d7bd175 in QThreadPrivate::start (arg=0x7ffb20000e10) at thread/qthread_unix.cpp:320
#10 0x00007ffb3b194d8c in start_thread (arg=0x7ffb25a96700) at pthread_create.c:304
#11 0x00007ffb3b49204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7ffb25295700 (LWP 2239)):
#0  0x00007ffb3b4a14d6 in pthread_mutex_unlock (mutex=0x13d6f18) at forward.c:184
#1  0x00007ffb3a6b884e in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffb3a6b9122 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffb3a6b9639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ffb3d8cf446 in QEventDispatcherGlib::processEvents (this=0x13f0600, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007ffb3d8a3882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007ffb3d8a3abc in QEventLoop::exec (this=0x7ffb25294d50, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007ffb3d7ba924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007ffb2e7be2b1 in ?? () from /usr/lib/libsopranoserver.so.1
#9  0x00007ffb3d7bd175 in QThreadPrivate::start (arg=0x7ffb20001cd0) at thread/qthread_unix.cpp:320
#10 0x00007ffb3b194d8c in start_thread (arg=0x7ffb25295700) at pthread_create.c:304
#11 0x00007ffb3b49204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7ffb2829b700 (LWP 2277)):
#0  0x00007ffb3b484f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ffb3a6b9104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffb3a6b9639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffb3d8cf446 in QEventDispatcherGlib::processEvents (this=0x11a0c20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ffb3d8a3882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ffb3d8a3abc in QEventLoop::exec (this=0x7ffb2829ad50, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ffb3d7ba924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007ffb2e7be2b1 in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007ffb3d7bd175 in QThreadPrivate::start (arg=0x7ffb200052d0) at thread/qthread_unix.cpp:320
#9  0x00007ffb3b194d8c in start_thread (arg=0x7ffb2829b700) at pthread_create.c:304
#10 0x00007ffb3b49204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7ffb24a94700 (LWP 2435)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ffb3d7bd82b in wait (this=<value optimized out>, mutex=0x140e220, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x140e220, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007ffb3d7b2218 in QThreadPoolThread::run (this=0x13f98c0) at concurrent/qthreadpool.cpp:140
#4  0x00007ffb3d7bd175 in QThreadPrivate::start (arg=0x13f98c0) at thread/qthread_unix.cpp:320
#5  0x00007ffb3b194d8c in start_thread (arg=0x7ffb24a94700) at pthread_create.c:304
#6  0x00007ffb3b49204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ffb1ffff700 (LWP 2449)):
#0  0x00007ffb3b1973c4 in __pthread_mutex_lock (mutex=0x13b5148) at pthread_mutex_lock.c:61
#1  0x00007ffb3a6b80d3 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffb3a6b8f9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffb3a6b9639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ffb3d8cf446 in QEventDispatcherGlib::processEvents (this=0x13eaa80, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007ffb3d8a3882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007ffb3d8a3abc in QEventLoop::exec (this=0x7ffb1fffed50, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007ffb3d7ba924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007ffb2e7be2b1 in ?? () from /usr/lib/libsopranoserver.so.1
#9  0x00007ffb3d7bd175 in QThreadPrivate::start (arg=0x13a9db0) at thread/qthread_unix.cpp:320
#10 0x00007ffb3b194d8c in start_thread (arg=0x7ffb1ffff700) at pthread_create.c:304
#11 0x00007ffb3b49204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ffb3ddae780 (LWP 2190)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ffb3d7bd82b in wait (this=<value optimized out>, mutex=0x7ffb20001800, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x7ffb20001800, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007ffb3d7bc910 in QThread::wait (this=<value optimized out>, time=18446744073709551615) at thread/qthread_unix.cpp:722
#4  0x00007ffb2e7bd8b8 in ?? () from /usr/lib/libsopranoserver.so.1
#5  0x00007ffb2e7c3b03 in ?? () from /usr/lib/libsopranoserver.so.1
#6  0x00007ffb2e7ba1c6 in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#7  0x00007ffb2ea257bb in Nepomuk::Core::~Core (this=0x126c230, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:45
#8  0x00007ffb2ea25839 in Nepomuk::Core::~Core (this=0x126c230, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#9  0x00007ffb3d8b6c14 in QObjectPrivate::deleteChildren (this=0x127fd30) at kernel/qobject.cpp:1964
#10 0x00007ffb3d8bb5f4 in QObject::~QObject (this=0x1282b40, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#11 0x00007ffb2ea24a13 in ~Storage (this=<value optimized out>, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:54
#12 Nepomuk::Storage::~Storage (this=<value optimized out>, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:56
#13 0x00007ffb3d8b6c14 in QObjectPrivate::deleteChildren (this=0x126bc40) at kernel/qobject.cpp:1964
#14 0x00007ffb3d8bb5f4 in QObject::~QObject (this=0x125fc80, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#15 0x00000000004045d9 in Nepomuk::ServiceControl::~ServiceControl (this=0x125fc80, __in_chrg=<value optimized out>) at ../../../nepomuk/servicestub/servicecontrol.cpp:39
#16 0x00007ffb3d8b6c14 in QObjectPrivate::deleteChildren (this=0x114cdd0) at kernel/qobject.cpp:1964
#17 0x00007ffb3d8bb5f4 in QObject::~QObject (this=0x7fffbfc67500, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#18 0x00007ffb3bc09122 in QApplication::~QApplication (this=0x7fffbfc67500, __in_chrg=<value optimized out>) at kernel/qapplication.cpp:1080
#19 0x0000000000403ea1 in main (argc=2, argv=<value optimized out>) at ../../../nepomuk/servicestub/main.cpp:102

This bug may be a duplicate of or related to bug 281201.

Possible duplicates by query: bug 281356, bug 281355, bug 281302, bug 281266, bug 281201.

Reported using DrKonqi
Comment 1 Sebastian Trueg 2011-09-19 10:07:11 UTC
*** Bug 282117 has been marked as a duplicate of this bug. ***
Comment 2 Sebastian Trueg 2011-09-19 10:44:04 UTC
*** Bug 282312 has been marked as a duplicate of this bug. ***
Comment 3 Sebastian Trueg 2011-09-19 10:44:45 UTC
*** Bug 281201 has been marked as a duplicate of this bug. ***
Comment 4 Sebastian Trueg 2011-09-19 10:45:01 UTC
*** Bug 281094 has been marked as a duplicate of this bug. ***
Comment 5 Sebastian Trueg 2011-09-19 10:45:16 UTC
*** Bug 280353 has been marked as a duplicate of this bug. ***
Comment 6 Sebastian Trueg 2011-09-19 10:45:35 UTC
*** Bug 279679 has been marked as a duplicate of this bug. ***
Comment 7 Sebastian Trueg 2011-09-19 11:35:13 UTC
*** Bug 278849 has been marked as a duplicate of this bug. ***
Comment 8 Sebastian Trueg 2011-09-19 11:35:38 UTC
*** Bug 278250 has been marked as a duplicate of this bug. ***
Comment 9 Sebastian Trueg 2011-09-19 11:35:55 UTC
*** Bug 277380 has been marked as a duplicate of this bug. ***
Comment 10 Sebastian Trueg 2011-09-19 11:36:11 UTC
*** Bug 275245 has been marked as a duplicate of this bug. ***
Comment 11 Sebastian Trueg 2011-09-19 11:36:26 UTC
*** Bug 274197 has been marked as a duplicate of this bug. ***
Comment 12 Sebastian Trueg 2011-09-19 11:36:41 UTC
*** Bug 271109 has been marked as a duplicate of this bug. ***
Comment 13 Sebastian Trueg 2011-09-19 11:37:26 UTC
*** Bug 267019 has been marked as a duplicate of this bug. ***
Comment 14 Sebastian Trueg 2011-09-19 11:38:31 UTC
*** Bug 258346 has been marked as a duplicate of this bug. ***
Comment 15 Sebastian Trueg 2011-09-19 11:39:26 UTC
*** Bug 257372 has been marked as a duplicate of this bug. ***
Comment 16 Sebastian Trueg 2011-09-19 12:17:48 UTC
*** Bug 255595 has been marked as a duplicate of this bug. ***
Comment 17 Sebastian Trueg 2011-09-19 12:21:02 UTC

*** This bug has been marked as a duplicate of bug 257176 ***
Comment 18 Sebastian Trueg 2011-09-19 12:46:52 UTC
*** Bug 282086 has been marked as a duplicate of this bug. ***