Bug 298151 - Nepomuk crashed at shutdown
Summary: Nepomuk crashed at shutdown
Status: RESOLVED DUPLICATE of bug 292950
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-14 21:19 UTC by richard virden
Modified: 2012-05-26 02:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description richard virden 2012-04-14 21:19:17 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.6.00 (4.6.0) "release 6" (Compiled from sources)
Qt Version: 4.7.1
Operating System: Linux 2.6.37.6-0.11-default i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
in kde, right click to pull down desktop menu. Crash occurred after clicking 'shutdown' after (apparently) shutdown sequence had begun. In this crash there are fewer threads than in the original of which this is a suggested duplicate.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0xb55f8710 (LWP 4698))]

Thread 3 (Thread 0xadfcbb70 (LWP 5535)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0xb7622fbe in QCoreApplication::notifyInternal (this=0xbfa33da8, receiver=0x8389f40, event=0xadfcb084) at kernel/qcoreapplication.cpp:732
#9  0xb76510e8 in sendEvent (source=0x83f0408) at kernel/qcoreapplication.h:215
#10 socketNotifierSourceDispatch (source=0x83f0408) at kernel/qeventdispatcher_glib.cpp:110
#11 0xb5ea1509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#12 0xb5ea1d10 in ?? () from /lib/libglib-2.0.so.0
#13 0xb5ea1fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#14 0xb765174b in QEventDispatcherGlib::processEvents (this=0x81de1d8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#15 0xb762229d in QEventLoop::processEvents (this=0xadfcb290, flags=...) at kernel/qeventloop.cpp:149
#16 0xb76224c9 in QEventLoop::exec (this=0xadfcb290, flags=...) at kernel/qeventloop.cpp:201
#17 0xb75237b9 in QThread::exec (this=0x8323ae8) at thread/qthread.cpp:490
#18 0xb28f8718 in Soprano::Server::ServerConnection::run (this=0x8323ae8) at /usr/src/debug/soprano-2.5.63/server/serverconnection.cpp:151
#19 0xb75263aa in QThreadPrivate::start (arg=0x8323ae8) at thread/qthread_unix.cpp:285
#20 0xb74abb05 in start_thread () from /lib/libpthread.so.0
#21 0xb6052d5e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xacfc9b70 (LWP 5894)):
#0  0xb74af474 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0xb5ea117b in g_main_context_check () from /lib/libglib-2.0.so.0
#2  0xb5ea1ac8 in ?? () from /lib/libglib-2.0.so.0
#3  0xb5ea1fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0xb7651797 in QEventDispatcherGlib::processEvents (this=0x81a2388, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0xb762229d in QEventLoop::processEvents (this=0xacfc9290, flags=...) at kernel/qeventloop.cpp:149
#6  0xb76224c9 in QEventLoop::exec (this=0xacfc9290, flags=...) at kernel/qeventloop.cpp:201
#7  0xb75237b9 in QThread::exec (this=0x82af780) at thread/qthread.cpp:490
#8  0xb28f8718 in Soprano::Server::ServerConnection::run (this=0x82af780) at /usr/src/debug/soprano-2.5.63/server/serverconnection.cpp:151
#9  0xb75263aa in QThreadPrivate::start (arg=0x82af780) at thread/qthread_unix.cpp:285
#10 0xb74abb05 in start_thread () from /lib/libpthread.so.0
#11 0xb6052d5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb55f8710 (LWP 4698)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb74b0105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb7526ab0 in wait (this=0x8363e88, mutex=0x8363e70, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  QWaitCondition::wait (this=0x8363e88, mutex=0x8363e70, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0xb7525ad5 in QThread::wait (this=0x8323ae8, time=4294967295) at thread/qthread_unix.cpp:683
#5  0xb28f83da in Soprano::Server::ServerConnection::~ServerConnection (this=0x8323ae8, __in_chrg=<value optimized out>) at /usr/src/debug/soprano-2.5.63/server/serverconnection.cpp:124
#6  0xb290048a in ~LocalServerConnection (this=0x8323ae8, __in_chrg=<value optimized out>) at /usr/src/debug/soprano-2.5.63/server/localserver.cpp:31
#7  (anonymous namespace)::LocalServerConnection::~LocalServerConnection (this=0x8323ae8, __in_chrg=<value optimized out>) at /usr/src/debug/soprano-2.5.63/server/localserver.cpp:31
#8  0xb28f2996 in qDeleteAll<QList<Soprano::Server::ServerConnection*>::const_iterator> (this=0x810bad0, __in_chrg=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#9  qDeleteAll<QList<Soprano::Server::ServerConnection*> > (this=0x810bad0, __in_chrg=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:330
#10 Soprano::Server::ServerCore::~ServerCore (this=0x810bad0, __in_chrg=<value optimized out>) at /usr/src/debug/soprano-2.5.63/server/servercore.cpp:76
#11 0xb2940dfc in ?? () from /usr/lib/kde4/nepomukstorage.so
#12 0xb2940ea2 in ?? () from /usr/lib/kde4/nepomukstorage.so
#13 0xb7636d04 in QObjectPrivate::deleteChildren (this=0x810b690) at kernel/qobject.cpp:1949
#14 0xb763bb8c in QObject::~QObject (this=0x80c5590, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#15 0xb6cbe7f8 in Nepomuk::Service::~Service (this=0x80c5590, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/nepomuk/core/nepomukservice.cpp:41
#16 0xb293fd8a in ?? () from /usr/lib/kde4/nepomukstorage.so
#17 0xb7636d04 in QObjectPrivate::deleteChildren (this=0x80ffac8) at kernel/qobject.cpp:1949
#18 0xb763bb8c in QObject::~QObject (this=0x80fcb10, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#19 0x0804bcc0 in _start ()

This bug may be a duplicate of or related to bug 295213.

Possible duplicates by query: bug 297443, bug 297065, bug 296877, bug 296537, bug 296511.

Reported using DrKonqi
Comment 1 Vishesh Handa 2012-05-26 02:08:26 UTC

*** This bug has been marked as a duplicate of bug 292950 ***