Bug 297443 - Dolphin crashed when trying to copy folder from samba share
Summary: Dolphin crashed when trying to copy folder from samba share
Status: RESOLVED WORKSFORME
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.8
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 299669 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-04 05:25 UTC by hyper_ch
Modified: 2021-01-13 04:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Crash report (11.68 KB, text/plain)
2014-09-10 14:58 UTC, NMD
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hyper_ch 2012-04-04 05:25:09 UTC
Application: dolphin (2.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-21-generic x86_64
Distribution: Ubuntu precise (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

I tried to copy a folder from a samba share to my desktop. For some reasons it didn't want to and then it just crashed.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe827b32780 (LWP 3278))]

Thread 3 (Thread 0x7fe813951700 (LWP 3290)):
#0  0x00007fe8273f8b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe81f3dfff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe81f3e0124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe82448f426 in QEventDispatcherGlib::processEvents (this=0x7fe80c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fe82445ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe82445eed7 in QEventLoop::exec (this=0x7fe813950dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fe82435dfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fe82443e9ff in QInotifyFileSystemWatcherEngine::run (this=0xede2f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe824360fcb in QThreadPrivate::start (arg=0xede2f0) at thread/qthread_unix.cpp:298
#9  0x00007fe81fca4e9a in start_thread (arg=0x7fe813951700) at pthread_create.c:308
#10 0x00007fe8274044bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fe812888700 (LWP 3291)):
#0  0x00007fe8273f8b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe81f3dfff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe81f3e0124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe82448f426 in QEventDispatcherGlib::processEvents (this=0x7fe8040008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fe82445ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe82445eed7 in QEventLoop::exec (this=0x7fe812887dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fe82435dfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fe82443e9ff in QInotifyFileSystemWatcherEngine::run (this=0x1225e50) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe824360fcb in QThreadPrivate::start (arg=0x1225e50) at thread/qthread_unix.cpp:298
#9  0x00007fe81fca4e9a in start_thread (arg=0x7fe812888700) at pthread_create.c:308
#10 0x00007fe8274044bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe827b32780 (LWP 3278)):
[KCrash Handler]
#6  __GI___libc_free (mem=0x100000000) at malloc.c:2968
#7  0x00007fe82447887d in QObject::~QObject (this=0x1497f80, __in_chrg=<optimized out>) at kernel/qobject.cpp:891
#8  0x00007fe8235b07dd in QWidget::~QWidget (this=0x1497f80, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1551
#9  0x00007fe82550e3de in ~ValueWidget (this=0x1497f80, __in_chrg=<optimized out>) at ../../kio/kfile/kfilemetadataprovider.cpp:85
#10 ValueWidget::~ValueWidget (this=0x1497f80, __in_chrg=<optimized out>) at ../../kio/kfile/kfilemetadataprovider.cpp:85
#11 0x00007fe8254d8317 in KFileMetaDataWidget::Private::deleteRows (this=0x1263020) at ../../kio/kfile/kfilemetadatawidget.cpp:184
#12 0x00007fe8254d8ab9 in KFileMetaDataWidget::Private::slotLoadingFinished (this=0x1263020) at ../../kio/kfile/kfilemetadatawidget.cpp:192
#13 0x00007fe824474281 in QMetaObject::activate (sender=0xf2e160, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#14 0x00007fe82550d13d in KFileMetaDataProvider::Private::slotLoadingFinished (this=0x13574c0) at ../../kio/kfile/kfilemetadataprovider.cpp:245
#15 0x00007fe824474281 in QMetaObject::activate (sender=0x1c3c640, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#16 0x00007fe82550b268 in KFileMetaDataReader::Private::slotLoadingFinished (this=0x19ba920, exitCode=<optimized out>, exitStatus=<optimized out>) at ../../kio/kfile/kfilemetadatareader.cpp:96
#17 0x00007fe824474281 in QMetaObject::activate (sender=0x1e52ed0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffbddb5470) at kernel/qobject.cpp:3547
#18 0x00007fe8243f567f in QProcess::finished (this=<optimized out>, _t1=0, _t2=QProcess::NormalExit) at .moc/release-shared/moc_qprocess.cpp:156
#19 0x00007fe8243fccf6 in QProcessPrivate::_q_processDied (this=0x1df5db0) at io/qprocess.cpp:1068
#20 0x00007fe8243fcd7e in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at .moc/release-shared/moc_qprocess.cpp:92
#21 QProcess::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qprocess.cpp:69
#22 0x00007fe824474281 in QMetaObject::activate (sender=0x2030aa0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffbddb5630) at kernel/qobject.cpp:3547
#23 0x00007fe8244c12fe in QSocketNotifier::activated (this=<optimized out>, _t1=43) at .moc/release-shared/moc_qsocketnotifier.cpp:103
#24 0x00007fe82447d60b in QSocketNotifier::event (this=0x2030aa0, e=0x7fffbddb5ca0) at kernel/qsocketnotifier.cpp:317
#25 0x00007fe823565894 in notify_helper (e=0x7fffbddb5ca0, receiver=0x2030aa0, this=0xd185d0) at kernel/qapplication.cpp:4559
#26 QApplicationPrivate::notify_helper (this=0xd185d0, receiver=0x2030aa0, e=0x7fffbddb5ca0) at kernel/qapplication.cpp:4531
#27 0x00007fe82356a713 in QApplication::notify (this=0x7fffbddb5f20, receiver=0x2030aa0, e=0x7fffbddb5ca0) at kernel/qapplication.cpp:4420
#28 0x00007fe824ebf906 in KApplication::notify (this=0x7fffbddb5f20, receiver=0x2030aa0, event=0x7fffbddb5ca0) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007fe82445fe9c in QCoreApplication::notifyInternal (this=0x7fffbddb5f20, receiver=0x2030aa0, event=0x7fffbddb5ca0) at kernel/qcoreapplication.cpp:876
#30 0x00007fe82448ea97 in sendEvent (event=0x7fffbddb5ca0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#31 socketNotifierSourceDispatch (source=0xd187a0) at kernel/qeventdispatcher_glib.cpp:110
#32 0x00007fe81f3dfc9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007fe81f3e0060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007fe81f3e0124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007fe82448f3bf in QEventDispatcherGlib::processEvents (this=0xcf44a0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#36 0x00007fe82360dd6e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#37 0x00007fe82445ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#38 0x00007fe82445eed7 in QEventLoop::exec (this=0x7fffbddb5eb0, flags=...) at kernel/qeventloop.cpp:204
#39 0x00007fe824463f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#40 0x00007fe82771745d in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_dolphin.so
#41 0x00007fe82733376d in __libc_start_main (main=0x400640, argc=1, ubp_av=0x7fffbddb6488, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffbddb6478) at libc-start.c:226
#42 0x0000000000400671 in _start ()

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-05-09 02:47:57 UTC
*** Bug 299669 has been marked as a duplicate of this bug. ***
Comment 2 NMD 2014-09-10 14:58:58 UTC
Created attachment 88643 [details]
Crash report

Hi, I had something similar, a crash whilst copying files from my computer to a samba share. See attached bug report and info.
Comment 3 Justin Zobel 2020-12-14 02:04:39 UTC
Thank you for the crash report.

As it has been a while since this was reported, can you please test and confirm if this issue is still occurring or if this bug report can be marked as resolved.

I have set the bug status to "needsinfo" pending your response, please change back to "reported" or "resolved/worksforme" when you respond, thank you.
Comment 4 Bug Janitor Service 2020-12-29 04:34:17 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Bug Janitor Service 2021-01-13 04:33:50 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!