Bug 288324 - Kontact crashing up selection of first message
Summary: Kontact crashing up selection of first message
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-06 11:06 UTC by Manuel Baptista
Modified: 2011-12-06 11:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Baptista 2011-12-06 11:06:26 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.4-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:
Reading new mail on imap gmail account
Crash happened when the first message in the list was selected
If I retry, sometimes it happens again but with a different message on the list, always after browsing quickly through different messages.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f46e4ebf840 (LWP 2434))]

Thread 3 (Thread 0x7f46da50d700 (LWP 2438)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x0000003dba1973cc in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x0000003dba1974f9 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00000031f0a07d90 in start_thread (arg=0x7f46da50d700) at pthread_create.c:309
#4  0x00000031efeeed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f46d9c0c700 (LWP 2441)):
#0  0x00000031efee6373 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00000031f2e44f88 in g_main_context_poll (n_fds=1, fds=0x7f46d40013e0, priority=<optimized out>, timeout=2774, context=0x7f46d40009a0) at gmain.c:3386
#2  g_main_context_iterate (context=0x7f46d40009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x00000031f2e4544c in g_main_context_iteration (context=0x7f46d40009a0, may_block=1) at gmain.c:3136
#4  0x00000031fa3a6896 in QEventDispatcherGlib::processEvents (this=0x7f46d40008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00000031fa376c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00000031fa376ed7 in QEventLoop::exec (this=0x7f46d9c0bd40, flags=...) at kernel/qeventloop.cpp:204
#7  0x00000031fa278ad7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00000031fa27bb1b in QThreadPrivate::start (arg=0x1b8a7c0) at thread/qthread_unix.cpp:298
#9  0x00000031f0a07d90 in start_thread (arg=0x7f46d9c0c700) at pthread_create.c:309
#10 0x00000031efeeed0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f46e4ebf840 (LWP 2434)):
[KCrash Handler]
#6  QList (l=..., this=0x7fff82c45780) at ../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7fff82c45aa0) at access/qabstractnetworkcache.cpp:240
#8  0x00000031fde6edcc in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x42032b0, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#9  0x00000031fde70564 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x42032b0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#10 0x00000031fdef4ef9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x42032b0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#11 0x00000031fa3909e6 in QObject::event (this=0x42032b0, e=<optimized out>) at kernel/qobject.cpp:1194
#12 0x0000003db15c96f4 in notify_helper (e=0x7f4674049140, receiver=0x42032b0, this=0x1a68110) at kernel/qapplication.cpp:4518
#13 QApplicationPrivate::notify_helper (this=0x1a68110, receiver=0x42032b0, e=0x7f4674049140) at kernel/qapplication.cpp:4490
#14 0x0000003db15ce573 in QApplication::notify (this=0x7fff82c46520, receiver=0x42032b0, e=0x7f4674049140) at kernel/qapplication.cpp:4379
#15 0x0000003db3050396 in KApplication::notify (this=0x7fff82c46520, receiver=0x42032b0, event=0x7f4674049140) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#16 0x00000031fa377b4c in QCoreApplication::notifyInternal (this=0x7fff82c46520, receiver=0x42032b0, event=0x7f4674049140) at kernel/qcoreapplication.cpp:876
#17 0x00000031fa37b5da in sendEvent (event=0x7f4674049140, receiver=0x42032b0) at kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1a3d050) at kernel/qcoreapplication.cpp:1500
#19 0x00000031fa3a6403 in sendPostedEvents () at kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=0x1a72070) at kernel/qeventdispatcher_glib.cpp:279
#21 0x00000031f2e44a7d in g_main_dispatch (context=0x1a710e0) at gmain.c:2425
#22 g_main_context_dispatch (context=0x1a710e0) at gmain.c:2995
#23 0x00000031f2e45278 in g_main_context_iterate (context=0x1a710e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#24 0x00000031f2e4544c in g_main_context_iteration (context=0x1a710e0, may_block=1) at gmain.c:3136
#25 0x00000031fa3a682f in QEventDispatcherGlib::processEvents (this=0x1a3e510, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#26 0x0000003db166c43e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#27 0x00000031fa376c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x00000031fa376ed7 in QEventLoop::exec (this=0x7fff82c464b0, flags=...) at kernel/qeventloop.cpp:204
#29 0x00000031fa37b8d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#30 0x00000000004037b9 in ?? ()
#31 0x00000031efe2169d in __libc_start_main (main=0x402cd0, argc=1, ubp_av=0x7fff82c46b48, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff82c46b38) at libc-start.c:226
#32 0x0000000000403d01 in _start ()

Possible duplicates by query: bug 287874.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-12-06 11:23:20 UTC

*** This bug has been marked as a duplicate of bug 286307 ***