Bug 295919 - muon crashes at the beginning
Summary: muon crashes at the beginning
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 295939 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-13 13:07 UTC by lucero
Modified: 2012-03-13 21:59 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lucero 2012-03-13 13:07:47 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: opening the program to see what software I was able to download

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb778b930 (LWP 1986))]

Thread 2 (Thread 0xb562ab70 (LWP 1990)):
#0  0x00438416 in __kernel_vsyscall ()
#1  0x00bed7ae in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0305034b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x03041896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x03041c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00a1cb37 in QEventDispatcherGlib::processEvents (this=0x9afd740, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x009ed1dd in QEventLoop::processEvents (this=0xb562a2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x009ed421 in QEventLoop::exec (this=0xb562a2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x008f090b in QThread::exec (this=0x9afb448) at thread/qthread.cpp:498
#9  0x009cde2d in QInotifyFileSystemWatcherEngine::run (this=0x9afb448) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x008f37b3 in QThreadPrivate::start (arg=0x9afb448) at thread/qthread_unix.cpp:331
#11 0x0082fd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00bfc46e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb778b930 (LWP 1986)):
[KCrash Handler]
#7  0x00947e11 in QtPrivate::QStringList_contains (that=0xbfb1b454, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfb1b454) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x99bd8e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x99bd8e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb1b674) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x009f4b7d in metacall (argv=0xbfb1b674, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x99bd8e0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x99bd8e0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfb1b674) at kernel/qmetaobject.cpp:232
#13 0x00a03a6a in QMetaObject::activate (sender=0x9a1d318, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9a1d318) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9a1d318, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb1b7b8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x009f4b7d in metacall (argv=0xbfb1b7b8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9a1d318) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9a1d318, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfb1b7b8) at kernel/qmetaobject.cpp:232
#18 0x00a03a6a in QMetaObject::activate (sender=0x99bd8e0, m=0x80950c0, local_signal_index=0, argv=0xbfb1b7b8) at kernel/qobject.cpp:3278
#19 0x001b77c5 in MuonMainWindow::backendReady (this=0x99bd8e0, _t1=0x99ac748) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x001b7933 in MuonMainWindow::initObject (this=0x99bd8e0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x99bd8e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x99bd8e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb1b8e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x009f4b7d in metacall (argv=0xbfb1b8e4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x99bd8e0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x99bd8e0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfb1b8e4) at kernel/qmetaobject.cpp:232
#25 0x00a03a6a in QMetaObject::activate (sender=0x9a024a0, m=0xb24238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00a0b375 in QSingleShotTimer::timeout (this=0x9a024a0) at .moc/release-shared/qtimer.moc:82
#27 0x00a0b42c in QSingleShotTimer::timerEvent (this=0x9a024a0) at kernel/qtimer.cpp:308
#28 0x00a06994 in QObject::event (this=0x9a024a0, e=0xbfb1bcdc) at kernel/qobject.cpp:1181
#29 0x07664d84 in notify_helper (e=0xbfb1bcdc, receiver=0x9a024a0, this=0x98e2b10) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x98e2b10, receiver=0x9a024a0, e=0xbfb1bcdc) at kernel/qapplication.cpp:4458
#31 0x0766a133 in QApplication::notify (this=0xbfb1bcdc, receiver=0x9a024a0, e=0xbfb1bcdc) at kernel/qapplication.cpp:3886
#32 0x0103e971 in KApplication::notify (this=0xbfb1bff0, receiver=0x9a024a0, event=0xbfb1bcdc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x009ee19e in QCoreApplication::notifyInternal (this=0xbfb1bff0, receiver=0x9a024a0, event=0xbfb1bcdc) at kernel/qcoreapplication.cpp:787
#34 0x00a1ec10 in sendEvent (event=0xbfb1bcdc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x98dcd84) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00a1c122 in timerSourceDispatch (source=0x98dcd50) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0304125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x03041990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x03041c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00a1cada in QEventDispatcherGlib::processEvents (this=0x98be238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0771ce7a in QGuiEventDispatcherGlib::processEvents (this=0x98be238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x009ed1dd in QEventLoop::processEvents (this=0xbfb1bf54, flags=...) at kernel/qeventloop.cpp:149
#43 0x009ed421 in QEventLoop::exec (this=0xbfb1bf54, flags=...) at kernel/qeventloop.cpp:201
#44 0x009f219d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x07662924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295895, bug 295886, bug 295885, bug 295882, bug 295855.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-03-13 13:27:12 UTC
The KDE team wants to improve the crash reporting tools for the end users. To help improving, please answer the following questions:

1. Did the Bug Reporting tool suggests this crash has already been reported?
[ ] no, I did not see any mention of the crash already been reported
[ ] unsure, I did not trust or understand the suggested duplicate reports
[ ] yes, the tool suggested this crash has already been reported

2. If "yes" in answer 1, how many duplicates did it display?
[ ] more than 10 duplicates
[ ] at least two duplicates
[ ] only a single duplicate

3. If "yes" or "unsure" in answer 1, what could be improved to help building trust in the suggested duplicate reports? (please add any comment)

Thanks for taking part in this survey,
KDE Quality Team
Comment 2 Lamarque V. Souza 2012-03-13 16:51:00 UTC
*** Bug 295939 has been marked as a duplicate of this bug. ***
Comment 3 Jekyll Wu 2012-03-13 21:59:11 UTC

*** This bug has been marked as a duplicate of bug 291262 ***