Bug 293656 - deleting emails
Summary: deleting emails
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-08 17:08 UTC by Chris
Modified: 2012-02-08 17:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris 2012-02-08 17:08:31 UTC
Application: kontact (4.7.4)
KDE Platform Version: 4.7.4 (4.7.4) "release 5"
Qt Version: 4.8.0
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
deleting emails.  A copy is in the IMAP folder and the local folder.  delete in either folder and Kmail crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f821d896760 (LWP 22078))]

Thread 5 (Thread 0x7f81ffbba700 (LWP 22081)):
#0  0x00007f8215764e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f821a0c1c12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f821a0c1c49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f8215760f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f821adb063d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f81ff2b1700 (LWP 22082)):
#0  0x00007f821ada7523 in poll () from /lib64/libc.so.6
#1  0x00007f82143eaa98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f82143eaf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f821c1f5526 in QEventDispatcherGlib::processEvents (this=0x7f81f80008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f821c1c5272 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f821c1c54c7 in QEventLoop::exec (this=0x7f81ff2b0e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f821c0c6137 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f821c0c915b in QThreadPrivate::start (arg=0x63df90) at thread/qthread_unix.cpp:298
#8  0x00007f8215760f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f821adb063d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f81b02c7700 (LWP 22085)):
#0  0x00007f82157651eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f821c0c95cf in wait (time=30000, this=0x1310e70) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x13150f8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f821c0bc9df in QThreadPoolThread::run (this=0x1307790) at concurrent/qthreadpool.cpp:141
#4  0x00007f821c0c915b in QThreadPrivate::start (arg=0x1307790) at thread/qthread_unix.cpp:298
#5  0x00007f8215760f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f821adb063d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f81ad70f700 (LWP 22093)):
#0  0x00007f82157651eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f821c0c95cf in wait (time=30000, this=0x1310e70) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x13150f8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f821c0bc9df in QThreadPoolThread::run (this=0x7f81a0009590) at concurrent/qthreadpool.cpp:141
#4  0x00007f821c0c915b in QThreadPrivate::start (arg=0x7f81a0009590) at thread/qthread_unix.cpp:298
#5  0x00007f8215760f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f821adb063d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f821d896760 (LWP 22078)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x1d3d630, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f821672afc9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x1d3d630, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f821c1df4f6 in QObject::event (this=0x1d3d630, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f821b54cd84 in notify_helper (e=0x7f81a0005230, receiver=0x1d3d630, this=0x641a50) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0x641a50, receiver=0x1d3d630, e=0x7f81a0005230) at kernel/qapplication.cpp:4522
#11 0x00007f821b551c03 in QApplication::notify (this=0x7fff873deea0, receiver=0x1d3d630, e=0x7f81a0005230) at kernel/qapplication.cpp:4411
#12 0x00007f821cc3d186 in KApplication::notify (this=0x7fff873deea0, receiver=0x1d3d630, event=0x7f81a0005230) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#13 0x00007f821c1c648c in QCoreApplication::notifyInternal (this=0x7fff873deea0, receiver=0x1d3d630, event=0x7f81a0005230) at kernel/qcoreapplication.cpp:876
#14 0x00007f821c1c9d2a in sendEvent (event=0x7f81a0005230, receiver=0x1d3d630) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60c7a0) at kernel/qcoreapplication.cpp:1500
#16 0x00007f821c1f5093 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f82143ea58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f82143ead88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f82143eaf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f821c1f54bf in QEventDispatcherGlib::processEvents (this=0x60c060, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f821b5efdee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f821c1c5272 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f821c1c54c7 in QEventLoop::exec (this=0x7fff873dee30, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f821c1ca025 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403919 in ?? ()
#27 0x00007f821acf823d in __libc_start_main () from /lib64/libc.so.6
#28 0x0000000000403e61 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 293458, bug 293261, bug 293003, bug 292815, bug 292500.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-02-08 17:23:38 UTC

*** This bug has been marked as a duplicate of bug 286307 ***