Bug 291913 - Kmail Crashes while reading emails
Summary: Kmail Crashes while reading emails
Status: RESOLVED DUPLICATE of bug 291230
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-19 00:44 UTC by kimmeade
Modified: 2012-01-19 11:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kimmeade 2012-01-19 00:44:59 UTC
Application: kmail (4.7.2)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.1.0-1.2-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

reading email messages, just scanning through different messages

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fdb72d82780 (LWP 27773))]

Thread 3 (Thread 0x7fdb55033700 (LWP 27865)):
#0  0x00007fdb6dea6e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fdb645e29dc in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007fdb645e2b09 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007fdb6dea2f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007fdb7009963d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fdb5472a700 (LWP 27866)):
#0  0x00007fdb6dea611f in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007fdb6830eb14 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fdb6830f92d in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fdb6830ff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fdb716f6956 in QEventDispatcherGlib::processEvents (this=0x7fdb4c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007fdb716c6682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fdb716c68d7 in QEventLoop::exec (this=0x7fdb54729e00, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fdb715c7537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007fdb715ca55b in QThreadPrivate::start (arg=0xb22d60) at thread/qthread_unix.cpp:298
#9  0x00007fdb6dea2f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007fdb7009963d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fdb72d82780 (LWP 27773)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x5689390, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007fdb6f0eb379 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x5689390, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007fdb716e0926 in QObject::event (this=0x5689390, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007fdb70a4ce84 in notify_helper (e=0x7fdb00037550, receiver=0x5689390, this=0x67d300) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0x67d300, receiver=0x5689390, e=0x7fdb00037550) at kernel/qapplication.cpp:4522
#11 0x00007fdb70a51d03 in QApplication::notify (this=0x7fff30da27c0, receiver=0x5689390, e=0x7fdb00037550) at kernel/qapplication.cpp:4411
#12 0x00007fdb727890f6 in KApplication::notify (this=0x7fff30da27c0, receiver=0x5689390, event=0x7fdb00037550) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#13 0x00007fdb716c789c in QCoreApplication::notifyInternal (this=0x7fff30da27c0, receiver=0x5689390, event=0x7fdb00037550) at kernel/qcoreapplication.cpp:876
#14 0x00007fdb716cb13a in sendEvent (event=0x7fdb00037550, receiver=0x5689390) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60b740) at kernel/qcoreapplication.cpp:1500
#16 0x00007fdb716f64c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007fdb6830f58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007fdb6830fd88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007fdb6830ff59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007fdb716f68ef in QEventDispatcherGlib::processEvents (this=0x60b000, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007fdb70af02de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007fdb716c6682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007fdb716c68d7 in QEventLoop::exec (this=0x7fff30da2690, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007fdb716cb435 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000402df3 in ?? ()
#27 0x00007fdb6ffe123d in __libc_start_main () from /lib64/libc.so.6
#28 0x00000000004032d5 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 291499, bug 291230, bug 289950, bug 289946, bug 289179.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-01-19 11:07:21 UTC

*** This bug has been marked as a duplicate of bug 291230 ***