Bug 295100 - Executable: muon-installer PID: 4055 Signal: Segmentation fault (11)
Summary: Executable: muon-installer PID: 4055 Signal: Segmentation fault (11)
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-29 22:16 UTC by Andrew
Modified: 2012-02-29 23:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2012-02-29 22:16:06 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Here are the developer notes
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7815930 (LWP 4055))]

Thread 2 (Thread 0xb5b2eb70 (LWP 4056)):
#0  0x00c85d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x0055c7d5 in do_gettime (frac=0xb5b2e020, sec=0xb5b2e018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x0062f4b6 in QTimerInfoList::updateCurrentTime (this=0xa086b0c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0062f80a in QTimerInfoList::timerWait (this=0xa086b0c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0062e053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb5b2e12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0062e0ed in timerSourcePrepare (source=0xa086ad8, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x01fc688c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x01fc7637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x01fc7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x0062eb37 in QEventDispatcherGlib::processEvents (this=0x9ff2ce0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x005ff1dd in QEventLoop::processEvents (this=0xb5b2e2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x005ff421 in QEventLoop::exec (this=0xb5b2e2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0050290b in QThread::exec (this=0x9fe3f40) at thread/qthread.cpp:498
#14 0x005dfe2d in QInotifyFileSystemWatcherEngine::run (this=0x9fe3f40) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x005057b3 in QThreadPrivate::start (arg=0x9fe3f40) at thread/qthread_unix.cpp:331
#16 0x01eefd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00d860ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7815930 (LWP 4055)):
[KCrash Handler]
#7  0x00559e11 in QtPrivate::QStringList_contains (that=0xbfd34354, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd34354) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9fe2670) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9fe2670, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd34574) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00606b7d in metacall (argv=0xbfd34574, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9fe2670) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9fe2670, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfd34574) at kernel/qmetaobject.cpp:232
#13 0x00615a6a in QMetaObject::activate (sender=0xa13f5d8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0xa13f5d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0xa13f5d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd346b8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00606b7d in metacall (argv=0xbfd346b8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0xa13f5d8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0xa13f5d8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfd346b8) at kernel/qmetaobject.cpp:232
#18 0x00615a6a in QMetaObject::activate (sender=0x9fe2670, m=0x80950c0, local_signal_index=0, argv=0xbfd346b8) at kernel/qobject.cpp:3278
#19 0x00e567c5 in MuonMainWindow::backendReady (this=0x9fe2670, _t1=0x9ff99c8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00e56933 in MuonMainWindow::initObject (this=0x9fe2670) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9fe2670) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9fe2670, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd347e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00606b7d in metacall (argv=0xbfd347e4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9fe2670) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9fe2670, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfd347e4) at kernel/qmetaobject.cpp:232
#25 0x00615a6a in QMetaObject::activate (sender=0xa056d68, m=0x736238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0061d375 in QSingleShotTimer::timeout (this=0xa056d68) at .moc/release-shared/qtimer.moc:82
#27 0x0061d42c in QSingleShotTimer::timerEvent (this=0xa056d68) at kernel/qtimer.cpp:308
#28 0x00618994 in QObject::event (this=0xa056d68, e=0xbfd34bdc) at kernel/qobject.cpp:1181
#29 0x08bffd84 in notify_helper (e=0xbfd34bdc, receiver=0xa056d68, this=0x9f23ed0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9f23ed0, receiver=0xa056d68, e=0xbfd34bdc) at kernel/qapplication.cpp:4458
#31 0x08c05133 in QApplication::notify (this=0xbfd34bdc, receiver=0xa056d68, e=0xbfd34bdc) at kernel/qapplication.cpp:3886
#32 0x01071971 in KApplication::notify (this=0xbfd34ef0, receiver=0xa056d68, event=0xbfd34bdc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0060019e in QCoreApplication::notifyInternal (this=0xbfd34ef0, receiver=0xa056d68, event=0xbfd34bdc) at kernel/qcoreapplication.cpp:787
#34 0x00630c10 in sendEvent (event=0xbfd34bdc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9f272c4) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0062e122 in timerSourceDispatch (source=0x9f27290) at kernel/qeventdispatcher_glib.cpp:184
#37 0x01fc725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01fc7990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01fc7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0062eada in QEventDispatcherGlib::processEvents (this=0x9f02238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x08cb7e7a in QGuiEventDispatcherGlib::processEvents (this=0x9f02238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x005ff1dd in QEventLoop::processEvents (this=0xbfd34e54, flags=...) at kernel/qeventloop.cpp:149
#43 0x005ff421 in QEventLoop::exec (this=0xbfd34e54, flags=...) at kernel/qeventloop.cpp:201
#44 0x0060419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x08bfd924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77a3930 (LWP 3822))]

Thread 2 (Thread 0xb5acbb70 (LWP 3823)):
#0  0x006fbd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x003b07d5 in do_gettime (frac=0xb5acb020, sec=0xb5acb018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x004834b6 in QTimerInfoList::updateCurrentTime (this=0x9cd7dbc) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0048380a in QTimerInfoList::timerWait (this=0x9cd7dbc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00482053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb5acb12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x004820ed in timerSourcePrepare (source=0x9cd7d88, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x04f0988c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x04f0a637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x04f0ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00482b37 in QEventDispatcherGlib::processEvents (this=0x9bd13b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x004531dd in QEventLoop::processEvents (this=0xb5acb2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00453421 in QEventLoop::exec (this=0xb5acb2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0035690b in QThread::exec (this=0x9b96308) at thread/qthread.cpp:498
#14 0x00433e2d in QInotifyFileSystemWatcherEngine::run (this=0x9b96308) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x003597b3 in QThreadPrivate::start (arg=0x9b96308) at thread/qthread_unix.cpp:331
#16 0x00848d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00a110ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77a3930 (LWP 3822)):
[KCrash Handler]
#7  0x003ade11 in QtPrivate::QStringList_contains (that=0xbff20a54, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbff20a54) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9b7e440) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9b7e440, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff20c74) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0045ab7d in metacall (argv=0xbff20c74, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9b7e440) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9b7e440, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbff20c74) at kernel/qmetaobject.cpp:232
#13 0x00469a6a in QMetaObject::activate (sender=0x9cdc640, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9cdc640) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9cdc640, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff20db8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0045ab7d in metacall (argv=0xbff20db8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9cdc640) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9cdc640, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbff20db8) at kernel/qmetaobject.cpp:232
#18 0x00469a6a in QMetaObject::activate (sender=0x9b7e440, m=0x80950c0, local_signal_index=0, argv=0xbff20db8) at kernel/qobject.cpp:3278
#19 0x00ea87c5 in MuonMainWindow::backendReady (this=0x9b7e440, _t1=0x9b94358) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00ea8933 in MuonMainWindow::initObject (this=0x9b7e440) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9b7e440) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9b7e440, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff20ee4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0045ab7d in metacall (argv=0xbff20ee4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9b7e440) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9b7e440, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbff20ee4) at kernel/qmetaobject.cpp:232
#25 0x00469a6a in QMetaObject::activate (sender=0x9bdba88, m=0x58a238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00471375 in QSingleShotTimer::timeout (this=0x9bdba88) at .moc/release-shared/qtimer.moc:82
#27 0x0047142c in QSingleShotTimer::timerEvent (this=0x9bdba88) at kernel/qtimer.cpp:308
#28 0x0046c994 in QObject::event (this=0x9bdba88, e=0xbff212dc) at kernel/qobject.cpp:1181
#29 0x01525d84 in notify_helper (e=0xbff212dc, receiver=0x9bdba88, this=0x9abded0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9abded0, receiver=0x9bdba88, e=0xbff212dc) at kernel/qapplication.cpp:4458
#31 0x0152b133 in QApplication::notify (this=0xbff212dc, receiver=0x9bdba88, e=0xbff212dc) at kernel/qapplication.cpp:3886
#32 0x010c3971 in KApplication::notify (this=0xbff215f0, receiver=0x9bdba88, event=0xbff212dc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0045419e in QCoreApplication::notifyInternal (this=0xbff215f0, receiver=0x9bdba88, event=0xbff212dc) at kernel/qcoreapplication.cpp:787
#34 0x00484c10 in sendEvent (event=0xbff212dc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9ac12c4) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00482122 in timerSourceDispatch (source=0x9ac1290) at kernel/qeventdispatcher_glib.cpp:184
#37 0x04f0a25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x04f0a990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x04f0ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00482ada in QEventDispatcherGlib::processEvents (this=0x9a9c238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x015dde7a in QGuiEventDispatcherGlib::processEvents (this=0x9a9c238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x004531dd in QEventLoop::processEvents (this=0xbff21554, flags=...) at kernel/qeventloop.cpp:149
#43 0x00453421 in QEventLoop::exec (this=0xbff21554, flags=...) at kernel/qeventloop.cpp:201
#44 0x0045819d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x01523924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295080, bug 295079, bug 295078, bug 295069, bug 295047.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-29 23:24:14 UTC

*** This bug has been marked as a duplicate of bug 291262 ***