Bug 295114 - Muon crashes immediately PID 2596 Segmentation Fault (11)
Summary: Muon crashes immediately PID 2596 Segmentation Fault (11)
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-01 05:59 UTC by Joe
Modified: 2012-03-01 09:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe 2012-03-01 05:59:56 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:  Well, after a fresh install of Kubuntu, the system updater wanted to update the software.  So i told it to update everything and it hung at 48%.  Restarted system and then I lost my ps2 mouse.  After restart I was trying to locate the system updater again, this is my first run with Kubuntu, and I tried the muon software center.  It immediately crashed.  When I was trying to install the debug tool for Muon crash reporting it said something was using the package handler yet.  It then told me to run dpkg --configure -a so I did from the terminal.  I rebooted after that and got my ps2 mouse back, but still could not run muon and this is the crash report from it.  Running fresh install of Kubuntu 11.10 and this is the 2nd system I've had the system hang when doing the updates after a fresh install.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4940930 (LWP 2613))]

Thread 2 (Thread 0xb266db70 (LWP 2614)):
#0  0xb548dd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb73697d5 in do_gettime (frac=0xb266d020, sec=0xb266d018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb743c4b6 in QTimerInfoList::updateCurrentTime (this=0xb1d0107c) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb743c80a in QTimerInfoList::timerWait (this=0xb1d0107c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb743b053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb266d12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb743b0ed in timerSourcePrepare (source=0xb1d01048, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb53d388c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb53d4637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb53d4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb743bb37 in QEventDispatcherGlib::processEvents (this=0x85cca20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb740c1dd in QEventLoop::processEvents (this=0xb266d2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb740c421 in QEventLoop::exec (this=0xb266d2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb730f90b in QThread::exec (this=0x85caa50) at thread/qthread.cpp:498
#14 0xb73ece2d in QInotifyFileSystemWatcherEngine::run (this=0x85caa50) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb73127b3 in QThreadPrivate::start (arg=0x85caa50) at thread/qthread_unix.cpp:331
#16 0xb54bad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb5f070ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb4940930 (LWP 2613)):
[KCrash Handler]
#7  0xb7366e11 in QtPrivate::QStringList_contains (that=0xbfefe894, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfefe894) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x85c8278) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x85c8278, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfefeab4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7413b7d in metacall (argv=0xbfefeab4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x85c8278) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x85c8278, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfefeab4) at kernel/qmetaobject.cpp:232
#13 0xb7422a6a in QMetaObject::activate (sender=0x8625db8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8625db8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8625db8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfefebf8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb7413b7d in metacall (argv=0xbfefebf8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8625db8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8625db8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfefebf8) at kernel/qmetaobject.cpp:232
#18 0xb7422a6a in QMetaObject::activate (sender=0x85c8278, m=0x80950c0, local_signal_index=0, argv=0xbfefebf8) at kernel/qobject.cpp:3278
#19 0xb78837c5 in MuonMainWindow::backendReady (this=0x85c8278, _t1=0x85ca318) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb7883933 in MuonMainWindow::initObject (this=0x85c8278) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x85c8278) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x85c8278, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfefed24) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb7413b7d in metacall (argv=0xbfefed24, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x85c8278) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x85c8278, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfefed24) at kernel/qmetaobject.cpp:232
#25 0xb7422a6a in QMetaObject::activate (sender=0x863cfc8, m=0xb7543238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb742a375 in QSingleShotTimer::timeout (this=0x863cfc8) at .moc/release-shared/qtimer.moc:82
#27 0xb742a42c in QSingleShotTimer::timerEvent (this=0x863cfc8) at kernel/qtimer.cpp:308
#28 0xb7425994 in QObject::event (this=0x863cfc8, e=0xbfeff11c) at kernel/qobject.cpp:1181
#29 0xb61f3d84 in notify_helper (e=0xbfeff11c, receiver=0x863cfc8, this=0x84dfc20) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x84dfc20, receiver=0x863cfc8, e=0xbfeff11c) at kernel/qapplication.cpp:4458
#31 0xb61f9133 in QApplication::notify (this=0xbfeff11c, receiver=0x863cfc8, e=0xbfeff11c) at kernel/qapplication.cpp:3886
#32 0xb7012971 in KApplication::notify (this=0xbfeff430, receiver=0x863cfc8, event=0xbfeff11c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb740d19e in QCoreApplication::notifyInternal (this=0xbfeff430, receiver=0x863cfc8, event=0xbfeff11c) at kernel/qcoreapplication.cpp:787
#34 0xb743dc10 in sendEvent (event=0xbfeff11c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x84e1db4) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb743b122 in timerSourceDispatch (source=0x84e1d80) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb53d425f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb53d4990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb53d4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb743bada in QEventDispatcherGlib::processEvents (this=0x84c2238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb62abe7a in QGuiEventDispatcherGlib::processEvents (this=0x84c2238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb740c1dd in QEventLoop::processEvents (this=0xbfeff394, flags=...) at kernel/qeventloop.cpp:149
#43 0xb740c421 in QEventLoop::exec (this=0xbfeff394, flags=...) at kernel/qeventloop.cpp:201
#44 0xb741119d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb61f1924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295100, bug 295080, bug 295079, bug 295078, bug 295069.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-01 09:45:14 UTC

*** This bug has been marked as a duplicate of bug 291262 ***