Bug 295080 - Muon plante au demarrage
Summary: Muon plante au demarrage
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-29 16:48 UTC by Nico
Modified: 2012-02-29 23:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nico 2012-02-29 16:48:10 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
je fermais firefox qui arrivait pas a ce deconnecter d'un page web.
J'ai voulu installer un logiciel de stat

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0c1443d780 (LWP 2213))]

Thread 2 (Thread 0x7f0bffa8f700 (LWP 2217)):
#0  0x00007f0c1100f773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f0c0d884f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0c0d885429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0c131ccf3e in QEventDispatcherGlib::processEvents (this=0x2748950, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f0c131a0cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f0c131a0ef7 in QEventLoop::exec (this=0x7f0bffa8edd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f0c130b827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f0c13183cbf in QInotifyFileSystemWatcherEngine::run (this=0x25ce5c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f0c130bad05 in QThreadPrivate::start (arg=0x25ce5c0) at thread/qthread_unix.cpp:331
#9  0x00007f0c0e366efc in start_thread (arg=0x7f0bffa8f700) at pthread_create.c:304
#10 0x00007f0c1101b89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0c1443d780 (LWP 2213)):
[KCrash Handler]
#6  0x00007f0c13108a5e in QtPrivate::QStringList_contains (that=0x7fffaea5e2c0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffaea5e2c0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x2582f50) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x2582f50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffaea5e890) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f0c131b4eba in QMetaObject::activate (sender=0x25a69d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x25a69d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffaea5e9f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f0c131b4eba in QMetaObject::activate (sender=0x2582f50, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffaea5e9f0) at kernel/qobject.cpp:3278
#13 0x00007f0c14027e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x25c9360) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f0c14027f8e in MuonMainWindow::initObject (this=0x2582f50) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x2582f50) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x2582f50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffaea5eac0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f0c131b4eba in QMetaObject::activate (sender=0x25ee2b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f0c131bcf7f in QSingleShotTimer::timerEvent (this=0x25ee2b0) at kernel/qtimer.cpp:308
#19 0x00007f0c131b8789 in QObject::event (this=0x25ee2b0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f0c117dc424 in notify_helper (e=0x7fffaea5f030, receiver=0x25ee2b0, this=0x240a030) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x240a030, receiver=0x25ee2b0, e=0x7fffaea5f030) at kernel/qapplication.cpp:4458
#22 0x00007f0c117e1291 in QApplication::notify (this=0x7fffaea5f330, receiver=0x25ee2b0, e=0x7fffaea5f030) at kernel/qapplication.cpp:4365
#23 0x00007f0c129c0126 in KApplication::notify (this=0x7fffaea5f330, receiver=0x25ee2b0, event=0x7fffaea5f030) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f0c131a1afc in QCoreApplication::notifyInternal (this=0x7fffaea5f330, receiver=0x25ee2b0, event=0x7fffaea5f030) at kernel/qcoreapplication.cpp:787
#25 0x00007f0c131ced62 in sendEvent (event=0x7fffaea5f030, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x240da70) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f0c131cc514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f0c0d884a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f0c0d885258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f0c0d885429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f0c131cced6 in QEventDispatcherGlib::processEvents (this=0x23e36f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f0c1188407e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f0c131a0cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f0c131a0ef7 in QEventLoop::exec (this=0x7fffaea5f2c0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f0c131a5789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fffaea5f5a8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295069, bug 295047, bug 295039, bug 295029, bug 294994.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-29 23:23:45 UTC

*** This bug has been marked as a duplicate of bug 291262 ***