Bug 295047 - Crash on Opening
Summary: Crash on Opening
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-29 05:33 UTC by James Laverack
Modified: 2012-02-29 05:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Laverack 2012-02-29 05:33:11 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

After a system update, the application crashes on startup every time.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7b38cf4780 (LWP 3590))]

Thread 2 (Thread 0x7f7b21fcd700 (LWP 3596)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f7b21fccaf0 in ?? ()
#2  0x00007fffac5d07e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f7b38cf4780 (LWP 3590)):
[KCrash Handler]
#6  0x00007f7b379b4a5e in QtPrivate::QStringList_contains (that=0x7fffac455330, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffac455330) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xbb29a0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xbb29a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffac455900) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f7b37a60eba in QMetaObject::activate (sender=0xc56090, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xc56090, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffac455a60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f7b37a60eba in QMetaObject::activate (sender=0xbb29a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffac455a60) at kernel/qobject.cpp:3278
#13 0x00007f7b388d6e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xaf50a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f7b388d6f8e in MuonMainWindow::initObject (this=0xbb29a0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xbb29a0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xbb29a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffac455b30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f7b37a60eba in QMetaObject::activate (sender=0xc563d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f7b37a68f7f in QSingleShotTimer::timerEvent (this=0xc563d0) at kernel/qtimer.cpp:308
#19 0x00007f7b37a64789 in QObject::event (this=0xc563d0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f7b36087474 in notify_helper (e=0x7fffac4560a0, receiver=0xc563d0, this=0xa76e60) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xa76e60, receiver=0xc563d0, e=0x7fffac4560a0) at kernel/qapplication.cpp:4458
#22 0x00007f7b3608c2e1 in QApplication::notify (this=0x7fffac4563a0, receiver=0xc563d0, e=0x7fffac4560a0) at kernel/qapplication.cpp:4365
#23 0x00007f7b3726c466 in KApplication::notify (this=0x7fffac4563a0, receiver=0xc563d0, event=0x7fffac4560a0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f7b37a4dafc in QCoreApplication::notifyInternal (this=0x7fffac4563a0, receiver=0xc563d0, event=0x7fffac4560a0) at kernel/qcoreapplication.cpp:787
#25 0x00007f7b37a7ad62 in sendEvent (event=0x7fffac4560a0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xa73860) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f7b37a78514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f7b3212fa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f7b32130258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f7b32130429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f7b37a78ed6 in QEventDispatcherGlib::processEvents (this=0xa4d6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f7b3612f10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f7b37a4ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f7b37a4cef7 in QEventLoop::exec (this=0x7fffac456330, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f7b37a51789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffac456618) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295039, bug 295029, bug 294994, bug 294990, bug 294981.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-29 05:43:00 UTC

*** This bug has been marked as a duplicate of bug 291262 ***