Bug 294990 - muon crashes directly at startup (fresh install)
Summary: muon crashes directly at startup (fresh install)
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-28 11:58 UTC by Joris
Modified: 2012-04-15 15:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.29 KB, text/plain)
2012-04-15 15:59 UTC, nicholas.jones
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joris 2012-02-28 11:58:32 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
just opened muon softwarecentrum and it gave directly a crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon softwarecentrum (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f45c0301780 (LWP 2137))]

Thread 2 (Thread 0x7f45ab942700 (LWP 2138)):
#0  0x00007f45ba2231fd in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x8d6be8) at pthread_mutex_unlock.c:290
#2  0x00007f45b973df9a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f45b973e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f45bf086f3e in QEventDispatcherGlib::processEvents (this=0x7f7570, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f45bf05acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f45bf05aef7 in QEventLoop::exec (this=0x7f45ab941dd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f45bef7227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007f45bf03dcbf in QInotifyFileSystemWatcherEngine::run (this=0x843c70) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f45bef74d05 in QThreadPrivate::start (arg=0x843c70) at thread/qthread_unix.cpp:331
#10 0x00007f45ba21fefc in start_thread (arg=0x7f45ab942700) at pthread_create.c:304
#11 0x00007f45bced489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f45c0301780 (LWP 2137)):
[KCrash Handler]
#6  0x00007f45befc2a5e in QtPrivate::QStringList_contains (that=0x7fff8d381870, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff8d381870) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x81b530) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x81b530, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8d381e40) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f45bf06eeba in QMetaObject::activate (sender=0x8ddc80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x8ddc80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8d381fa0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f45bf06eeba in QMetaObject::activate (sender=0x81b530, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8d381fa0) at kernel/qobject.cpp:3278
#13 0x00007f45bfee4e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x7f65f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f45bfee4f8e in MuonMainWindow::initObject (this=0x81b530) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x81b530) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x81b530, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8d382070) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f45bf06eeba in QMetaObject::activate (sender=0x89ee60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f45bf076f7f in QSingleShotTimer::timerEvent (this=0x89ee60) at kernel/qtimer.cpp:308
#19 0x00007f45bf072789 in QObject::event (this=0x89ee60, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f45bd695474 in notify_helper (e=0x7fff8d3825e0, receiver=0x89ee60, this=0x6b9730) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x6b9730, receiver=0x89ee60, e=0x7fff8d3825e0) at kernel/qapplication.cpp:4458
#22 0x00007f45bd69a2e1 in QApplication::notify (this=0x7fff8d3828e0, receiver=0x89ee60, e=0x7fff8d3825e0) at kernel/qapplication.cpp:4365
#23 0x00007f45be87a466 in KApplication::notify (this=0x7fff8d3828e0, receiver=0x89ee60, event=0x7fff8d3825e0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f45bf05bafc in QCoreApplication::notifyInternal (this=0x7fff8d3828e0, receiver=0x89ee60, event=0x7fff8d3825e0) at kernel/qcoreapplication.cpp:787
#25 0x00007f45bf088d62 in sendEvent (event=0x7fff8d3825e0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x6b50e0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f45bf086514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f45b973da5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f45b973e258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f45b973e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f45bf086ed6 in QEventDispatcherGlib::processEvents (this=0x6916f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f45bd73d10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f45bf05acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f45bf05aef7 in QEventLoop::exec (this=0x7fff8d382870, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f45bf05f789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff8d382b58) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294981, bug 294923, bug 294922, bug 294912, bug 294894.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-28 12:46:34 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 nicholas.jones 2012-04-15 15:59:22 UTC
Created attachment 70402 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:opening muon for the first time after installing it as part of upgrade to kubuntu 11.10

-- Backtrace (Reduced):
#7  0x00c42e11 in QtPrivate::QStringList_contains (that=0xbfb5d124, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfb5d124) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x93a4ed0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x93a4ed0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb5d344) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00cefb7d in metacall (argv=0xbfb5d344, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x93a4ed0) at kernel/qmetaobject.cpp:237