Bug 294981 - moun szoftverközpont minden próbálkozásra összeomlik
Summary: moun szoftverközpont minden próbálkozásra összeomlik
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-28 09:03 UTC by oliver kiss
Modified: 2012-02-28 09:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description oliver kiss 2012-02-28 09:03:18 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

frissen telepített operációs rendszeren összeomlik minden egyes indítással. próbáltam a cd-s verzióval, most megpróbáltam a dvd-s verzióval is és fenn áll még ugyanúgy a probléma, kubuntu desktop alatt

The crash can be reproduced every time.

-- Backtrace:
Application: Muon szoftverközpont (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2a3a571780 (LWP 1846))]

Thread 2 (Thread 0x7f2a258f1700 (LWP 1850)):
#0  0x00007f2a37137773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2a339acf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2a339ad429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2a392f5f3e in QEventDispatcherGlib::processEvents (this=0x18af7d0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f2a392c9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f2a392c9ef7 in QEventLoop::exec (this=0x7f2a258f0dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f2a391e127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f2a392accbf in QInotifyFileSystemWatcherEngine::run (this=0x172be30) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f2a391e3d05 in QThreadPrivate::start (arg=0x172be30) at thread/qthread_unix.cpp:331
#9  0x00007f2a3448eefc in start_thread (arg=0x7f2a258f1700) at pthread_create.c:304
#10 0x00007f2a3714389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2a3a571780 (LWP 1846)):
[KCrash Handler]
#6  0x00007f2a39231a5e in QtPrivate::QStringList_contains (that=0x7fff5919b990, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff5919b990) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x16debf0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x16debf0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5919bf60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f2a392ddeba in QMetaObject::activate (sender=0x1732e80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1732e80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5919c0c0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f2a392ddeba in QMetaObject::activate (sender=0x16debf0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff5919c0c0) at kernel/qobject.cpp:3278
#13 0x00007f2a3a153e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x176f1f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f2a3a153f8e in MuonMainWindow::initObject (this=0x16debf0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x16debf0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x16debf0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff5919c190) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f2a392ddeba in QMetaObject::activate (sender=0x1774140, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f2a392e5f7f in QSingleShotTimer::timerEvent (this=0x1774140) at kernel/qtimer.cpp:308
#19 0x00007f2a392e1789 in QObject::event (this=0x1774140, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f2a37904474 in notify_helper (e=0x7fff5919c700, receiver=0x1774140, this=0x157afe0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x157afe0, receiver=0x1774140, e=0x7fff5919c700) at kernel/qapplication.cpp:4458
#22 0x00007f2a379092e1 in QApplication::notify (this=0x7fff5919ca00, receiver=0x1774140, e=0x7fff5919c700) at kernel/qapplication.cpp:4365
#23 0x00007f2a38ae9466 in KApplication::notify (this=0x7fff5919ca00, receiver=0x1774140, event=0x7fff5919c700) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f2a392caafc in QCoreApplication::notifyInternal (this=0x7fff5919ca00, receiver=0x1774140, event=0x7fff5919c700) at kernel/qcoreapplication.cpp:787
#25 0x00007f2a392f7d62 in sendEvent (event=0x7fff5919c700, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x157eba0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f2a392f5538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007f2a339aca5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f2a339ad258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f2a339ad429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f2a392f5ed6 in QEventDispatcherGlib::processEvents (this=0x15576f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f2a379ac10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f2a392c9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f2a392c9ef7 in QEventLoop::exec (this=0x7fff5919c990, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f2a392ce789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=5, argv=0x7fff5919cc78) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294923, bug 294922, bug 294912, bug 294894, bug 294893.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-28 09:08:39 UTC

*** This bug has been marked as a duplicate of bug 291262 ***