Bug 295029 - muon software center crashes when started
Summary: muon software center crashes when started
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-28 21:26 UTC by robosicotte.debug
Modified: 2012-02-29 21:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.26 KB, text/plain)
2012-02-29 21:33 UTC, robosicotte.debug
Details

Note You need to log in before you can comment on or make changes to this bug.
Description robosicotte.debug 2012-02-28 21:26:12 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Just as the title says, the muon software center crashes when started.
I access it from the netbook panel using normal method.
Then it suddenly crashes.

Version: Kubuntu 11.10 installed from flash drive using pendrivelinux
on hp mini 110

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7761930 (LWP 2056))]

Thread 2 (Thread 0xb5884b70 (LWP 2060)):
#0  0x007ded10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00d047d5 in do_gettime (frac=0xb5884020, sec=0xb5884018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00dd74b6 in QTimerInfoList::updateCurrentTime (this=0x84e95fc) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00dd780a in QTimerInfoList::timerWait (this=0x84e95fc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00dd6053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb588412c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00dd60ed in timerSourcePrepare (source=0x84e95c8, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x015dd88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x015de637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x015dec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00dd6b37 in QEventDispatcherGlib::processEvents (this=0x84e9650, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00da71dd in QEventLoop::processEvents (this=0xb58842b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00da7421 in QEventLoop::exec (this=0xb58842b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00caa90b in QThread::exec (this=0x84df9f8) at thread/qthread.cpp:498
#14 0x00d87e2d in QInotifyFileSystemWatcherEngine::run (this=0x84df9f8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00cad7b3 in QThreadPrivate::start (arg=0x84df9f8) at thread/qthread_unix.cpp:331
#16 0x0064fd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0042d0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7761930 (LWP 2056)):
[KCrash Handler]
#7  0x00d01e11 in QtPrivate::QStringList_contains (that=0xbfe29544, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe29544) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x83875a0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x83875a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe29764) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00daeb7d in metacall (argv=0xbfe29764, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x83875a0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x83875a0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe29764) at kernel/qmetaobject.cpp:232
#13 0x00dbda6a in QMetaObject::activate (sender=0x83f2c38, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x83f2c38) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x83f2c38, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe298a8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00daeb7d in metacall (argv=0xbfe298a8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x83f2c38) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x83f2c38, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe298a8) at kernel/qmetaobject.cpp:232
#18 0x00dbda6a in QMetaObject::activate (sender=0x83875a0, m=0x80950c0, local_signal_index=0, argv=0xbfe298a8) at kernel/qobject.cpp:3278
#19 0x005977c5 in MuonMainWindow::backendReady (this=0x83875a0, _t1=0x83d0940) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00597933 in MuonMainWindow::initObject (this=0x83875a0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x83875a0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x83875a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe299d4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00daeb7d in metacall (argv=0xbfe299d4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x83875a0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x83875a0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe299d4) at kernel/qmetaobject.cpp:232
#25 0x00dbda6a in QMetaObject::activate (sender=0x83f7c48, m=0xede238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00dc5375 in QSingleShotTimer::timeout (this=0x83f7c48) at .moc/release-shared/qtimer.moc:82
#27 0x00dc542c in QSingleShotTimer::timerEvent (this=0x83f7c48) at kernel/qtimer.cpp:308
#28 0x00dc0994 in QObject::event (this=0x83f7c48, e=0xbfe29dcc) at kernel/qobject.cpp:1181
#29 0x02bb2d84 in notify_helper (e=0xbfe29dcc, receiver=0x83f7c48, this=0x82a2830) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x82a2830, receiver=0x83f7c48, e=0xbfe29dcc) at kernel/qapplication.cpp:4458
#31 0x02bb8133 in QApplication::notify (this=0xbfe29dcc, receiver=0x83f7c48, e=0xbfe29dcc) at kernel/qapplication.cpp:3886
#32 0x010ca971 in KApplication::notify (this=0xbfe2a0e0, receiver=0x83f7c48, event=0xbfe29dcc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00da819e in QCoreApplication::notifyInternal (this=0xbfe2a0e0, receiver=0x83f7c48, event=0xbfe29dcc) at kernel/qcoreapplication.cpp:787
#34 0x00dd8c10 in sendEvent (event=0xbfe29dcc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x82a3a44) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00dd6122 in timerSourceDispatch (source=0x82a3a10) at kernel/qeventdispatcher_glib.cpp:184
#37 0x015de25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x015de990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x015dec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00dd6ada in QEventDispatcherGlib::processEvents (this=0x8285238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x02c6ae7a in QGuiEventDispatcherGlib::processEvents (this=0x8285238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00da71dd in QEventLoop::processEvents (this=0xbfe2a044, flags=...) at kernel/qeventloop.cpp:149
#43 0x00da7421 in QEventLoop::exec (this=0xbfe2a044, flags=...) at kernel/qeventloop.cpp:201
#44 0x00dac19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x02bb0924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 294862, bug 294848, bug 294844, bug 294843, bug 294842.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-28 22:37:12 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 robosicotte.debug 2012-02-29 21:33:43 UTC
Created attachment 69193 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

I was simply opening muon from the netbook startup area.

-- Backtrace (Reduced):
#7  0x0066be11 in QtPrivate::QStringList_contains (that=0xbfd4f8d4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd4f8d4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x980f238) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x980f238, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd4faf4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00718b7d in metacall (argv=0xbfd4faf4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x980f238) at kernel/qmetaobject.cpp:237