Bug 294994 - muon software manager crashes while opening it
Summary: muon software manager crashes while opening it
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-28 12:39 UTC by sumit
Modified: 2012-02-28 12:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sumit 2012-02-28 12:39:12 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
i installed software source updates in muon package manager. it crashes everytime i do this . i  have reinstalled kubuntu many times and checked it

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77a4930 (LWP 2259))]

Thread 2 (Thread 0xb5962b70 (LWP 2263)):
#0  0x00d4bdbd in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00c28f14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x03bb4c13 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x00647b37 in QEventDispatcherGlib::processEvents (this=0x8ecfeb0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x006181dd in QEventLoop::processEvents (this=0xb59622b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00618421 in QEventLoop::exec (this=0xb59622b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x0051b90b in QThread::exec (this=0x8ec6990) at thread/qthread.cpp:498
#7  0x005f8e2d in QInotifyFileSystemWatcherEngine::run (this=0x8ec6990) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x0051e7b3 in QThreadPrivate::start (arg=0x8ec6990) at thread/qthread_unix.cpp:331
#9  0x00d49d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x00c1b0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77a4930 (LWP 2259)):
[KCrash Handler]
#7  0x00572e11 in QtPrivate::QStringList_contains (that=0xbfb0a3c4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfb0a3c4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8d78ed8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8d78ed8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb0a5e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0061fb7d in metacall (argv=0xbfb0a5e4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8d78ed8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8d78ed8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfb0a5e4) at kernel/qmetaobject.cpp:232
#13 0x0062ea6a in QMetaObject::activate (sender=0x8de4a58, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8de4a58) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8de4a58, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb0a728) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0061fb7d in metacall (argv=0xbfb0a728, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8de4a58) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8de4a58, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfb0a728) at kernel/qmetaobject.cpp:232
#18 0x0062ea6a in QMetaObject::activate (sender=0x8d78ed8, m=0x80950c0, local_signal_index=0, argv=0xbfb0a728) at kernel/qobject.cpp:3278
#19 0x001287c5 in MuonMainWindow::backendReady (this=0x8d78ed8, _t1=0x8dcc998) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00128933 in MuonMainWindow::initObject (this=0x8d78ed8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8d78ed8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8d78ed8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb0a854) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0061fb7d in metacall (argv=0xbfb0a854, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8d78ed8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8d78ed8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfb0a854) at kernel/qmetaobject.cpp:232
#25 0x0062ea6a in QMetaObject::activate (sender=0x8dc4290, m=0x74f238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00636375 in QSingleShotTimer::timeout (this=0x8dc4290) at .moc/release-shared/qtimer.moc:82
#27 0x0063642c in QSingleShotTimer::timerEvent (this=0x8dc4290) at kernel/qtimer.cpp:308
#28 0x00631994 in QObject::event (this=0x8dc4290, e=0xbfb0ac4c) at kernel/qobject.cpp:1181
#29 0x01382d84 in notify_helper (e=0xbfb0ac4c, receiver=0x8dc4290, this=0x8c907d8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8c907d8, receiver=0x8dc4290, e=0xbfb0ac4c) at kernel/qapplication.cpp:4458
#31 0x01388133 in QApplication::notify (this=0xbfb0ac4c, receiver=0x8dc4290, e=0xbfb0ac4c) at kernel/qapplication.cpp:3886
#32 0x00fd8971 in KApplication::notify (this=0xbfb0af60, receiver=0x8dc4290, event=0xbfb0ac4c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0061919e in QCoreApplication::notifyInternal (this=0xbfb0af60, receiver=0x8dc4290, event=0xbfb0ac4c) at kernel/qcoreapplication.cpp:787
#34 0x00649c10 in sendEvent (event=0xbfb0ac4c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8c97b04) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00647122 in timerSourceDispatch (source=0x8c97ad0) at kernel/qeventdispatcher_glib.cpp:184
#37 0x03bb425f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x03bb4990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x03bb4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00647ada in QEventDispatcherGlib::processEvents (this=0x8c73238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0143ae7a in QGuiEventDispatcherGlib::processEvents (this=0x8c73238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x006181dd in QEventLoop::processEvents (this=0xbfb0aec4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00618421 in QEventLoop::exec (this=0xbfb0aec4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0061d19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x01380924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294990, bug 294981, bug 294923, bug 294922, bug 294912.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-28 12:46:11 UTC

*** This bug has been marked as a duplicate of bug 291262 ***