Bug 294848 - Muon crashed
Summary: Muon crashed
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-26 07:58 UTC by esseci71
Modified: 2012-02-26 08:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description esseci71 2012-02-26 07:58:10 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
i'm just trying to open the application to find some other application for the pc. i'ts impossible to open Muon.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78ce930 (LWP 9115))]

Thread 2 (Thread 0xb5896b70 (LWP 9210)):
#0  0x0055adbd in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x02b3ff14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x06958723 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x06958c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x00425b37 in QEventDispatcherGlib::processEvents (this=0x8b3a310, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x003f61dd in QEventLoop::processEvents (this=0xb58962b0, flags=...) at kernel/qeventloop.cpp:149
#6  0x003f6421 in QEventLoop::exec (this=0xb58962b0, flags=...) at kernel/qeventloop.cpp:201
#7  0x002f990b in QThread::exec (this=0x8b3ab20) at thread/qthread.cpp:498
#8  0x003d6e2d in QInotifyFileSystemWatcherEngine::run (this=0x8b3ab20) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x002fc7b3 in QThreadPrivate::start (arg=0x8b3ab20) at thread/qthread_unix.cpp:331
#10 0x00558d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x02b320ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb78ce930 (LWP 9115)):
[KCrash Handler]
#7  0x00350e11 in QtPrivate::QStringList_contains (that=0xbfa3abc4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfa3abc4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8a929e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8a929e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa3ade4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x003fdb7d in metacall (argv=0xbfa3ade4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8a929e0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8a929e0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfa3ade4) at kernel/qmetaobject.cpp:232
#13 0x0040ca6a in QMetaObject::activate (sender=0x8a2eb50, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8a2eb50) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8a2eb50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa3af28) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x003fdb7d in metacall (argv=0xbfa3af28, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8a2eb50) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8a2eb50, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfa3af28) at kernel/qmetaobject.cpp:232
#18 0x0040ca6a in QMetaObject::activate (sender=0x8a929e0, m=0x80950c0, local_signal_index=0, argv=0xbfa3af28) at kernel/qobject.cpp:3278
#19 0x005927c5 in MuonMainWindow::backendReady (this=0x8a929e0, _t1=0x8a2dfa0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00592933 in MuonMainWindow::initObject (this=0x8a929e0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8a929e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8a929e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa3b054) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x003fdb7d in metacall (argv=0xbfa3b054, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8a929e0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8a929e0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfa3b054) at kernel/qmetaobject.cpp:232
#25 0x0040ca6a in QMetaObject::activate (sender=0x8b132d8, m=0x52d238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00414375 in QSingleShotTimer::timeout (this=0x8b132d8) at .moc/release-shared/qtimer.moc:82
#27 0x0041442c in QSingleShotTimer::timerEvent (this=0x8b132d8) at kernel/qtimer.cpp:308
#28 0x0040f994 in QObject::event (this=0x8b132d8, e=0xbfa3b44c) at kernel/qobject.cpp:1181
#29 0x013e2d84 in notify_helper (e=0xbfa3b44c, receiver=0x8b132d8, this=0x897a8a0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x897a8a0, receiver=0x8b132d8, e=0xbfa3b44c) at kernel/qapplication.cpp:4458
#31 0x013e8133 in QApplication::notify (this=0xbfa3b44c, receiver=0x8b132d8, e=0xbfa3b44c) at kernel/qapplication.cpp:3886
#32 0x00c64971 in KApplication::notify (this=0xbfa3b760, receiver=0x8b132d8, event=0xbfa3b44c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x003f719e in QCoreApplication::notifyInternal (this=0xbfa3b760, receiver=0x8b132d8, event=0xbfa3b44c) at kernel/qcoreapplication.cpp:787
#34 0x00427c10 in sendEvent (event=0xbfa3b44c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x89776ec) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00425122 in timerSourceDispatch (source=0x89776b8) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0695825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x06958990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x06958c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00425ada in QEventDispatcherGlib::processEvents (this=0x8954238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0149ae7a in QGuiEventDispatcherGlib::processEvents (this=0x8954238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x003f61dd in QEventLoop::processEvents (this=0xbfa3b6c4, flags=...) at kernel/qeventloop.cpp:149
#43 0x003f6421 in QEventLoop::exec (this=0xbfa3b6c4, flags=...) at kernel/qeventloop.cpp:201
#44 0x003fb19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x013e0924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294844, bug 294843, bug 294842, bug 294800, bug 294799.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-26 08:35:31 UTC

*** This bug has been marked as a duplicate of bug 291262 ***