Bug 293113 - Muon Software Manager Continuously Crashes after fresh install of Kubuntu 11
Summary: Muon Software Manager Continuously Crashes after fresh install of Kubuntu 11
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-02 04:35 UTC by Daniel L McGrew
Modified: 2012-02-02 05:53 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel L McGrew 2012-02-02 04:35:31 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I had just installed a fresh copy of Kubuntu 11.1 and tried to open Muon Software Manager. 
The software manager will not open. The dialog box appears with a little detail and then suddenly dies.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f99f271d780 (LWP 1844))]

Thread 2 (Thread 0x7f99ddcf5700 (LWP 1848)):
#0  0x00007f99ef2e7773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f99ebb5cf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f99ebb5d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f99f14a5f3e in QEventDispatcherGlib::processEvents (this=0x249e510, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f99f1479cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f99f1479ef7 in QEventLoop::exec (this=0x7f99ddcf4dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f99f139127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f99f145ccbf in QInotifyFileSystemWatcherEngine::run (this=0x231a960) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f99f1393d05 in QThreadPrivate::start (arg=0x231a960) at thread/qthread_unix.cpp:331
#9  0x00007f99ec63eefc in start_thread (arg=0x7f99ddcf5700) at pthread_create.c:304
#10 0x00007f99ef2f389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f99f271d780 (LWP 1844)):
[KCrash Handler]
#6  0x00007f99f13e1a5e in QtPrivate::QStringList_contains (that=0x7fff916a60d0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff916a60d0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x22bdf90) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x22bdf90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff916a66a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f99f148deba in QMetaObject::activate (sender=0x2326180, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x2326180, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff916a6800) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f99f148deba in QMetaObject::activate (sender=0x22bdf90, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff916a6800) at kernel/qobject.cpp:3278
#13 0x00007f99f2303e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x224b790) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f99f2303f8e in MuonMainWindow::initObject (this=0x22bdf90) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x22bdf90) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x22bdf90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff916a68d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f99f148deba in QMetaObject::activate (sender=0x236faf0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f99f1495f7f in QSingleShotTimer::timerEvent (this=0x236faf0) at kernel/qtimer.cpp:308
#19 0x00007f99f1491789 in QObject::event (this=0x236faf0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f99efab4474 in notify_helper (e=0x7fff916a6e40, receiver=0x236faf0, this=0x217d8f0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x217d8f0, receiver=0x236faf0, e=0x7fff916a6e40) at kernel/qapplication.cpp:4458
#22 0x00007f99efab92e1 in QApplication::notify (this=0x7fff916a7140, receiver=0x236faf0, e=0x7fff916a6e40) at kernel/qapplication.cpp:4365
#23 0x00007f99f0c99466 in KApplication::notify (this=0x7fff916a7140, receiver=0x236faf0, event=0x7fff916a6e40) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f99f147aafc in QCoreApplication::notifyInternal (this=0x7fff916a7140, receiver=0x236faf0, event=0x7fff916a6e40) at kernel/qcoreapplication.cpp:787
#25 0x00007f99f14a7d62 in sendEvent (event=0x7fff916a6e40, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x2179030) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f99f14a5514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f99ebb5ca5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f99ebb5d258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f99ebb5d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f99f14a5ed6 in QEventDispatcherGlib::processEvents (this=0x21556f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f99efb5c10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f99f1479cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f99f1479ef7 in QEventLoop::exec (this=0x7fff916a70d0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f99f147e789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff916a73b8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293102, bug 293080, bug 293071, bug 293037, bug 293027.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-02 05:53:58 UTC

*** This bug has been marked as a duplicate of bug 291262 ***