Bug 294862 - Muon crashed at start
Summary: Muon crashed at start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-26 13:09 UTC by pipi
Modified: 2012-02-26 13:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pipi 2012-02-26 13:09:57 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: Kubuntu was new installed. I startet Muon at the first  time.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb771a930 (LWP 2065))]

Thread 2 (Thread 0xb40e6b70 (LWP 2071)):
#0  0x0050b416 in __kernel_vsyscall ()
#1  0x06b5e40e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x08f6634b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x08f57896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x08f57c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x006c8ada in QEventDispatcherGlib::processEvents (this=0xa1799a8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#6  0x006991dd in QEventLoop::processEvents (this=0xb40e62b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00699421 in QEventLoop::exec (this=0xb40e62b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0059c90b in QThread::exec (this=0xa1688e0) at thread/qthread.cpp:498
#9  0x00679e2d in QInotifyFileSystemWatcherEngine::run (this=0xa1688e0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0059f7b3 in QThreadPrivate::start (arg=0xa1688e0) at thread/qthread_unix.cpp:331
#11 0x00ee2d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x06b6d0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb771a930 (LWP 2065)):
[KCrash Handler]
#7  0x005f3e11 in QtPrivate::QStringList_contains (that=0xbf932f54, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf932f54) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0xa11ac18) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0xa11ac18, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf933174) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x006a0b7d in metacall (argv=0xbf933174, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0xa11ac18) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0xa11ac18, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf933174) at kernel/qmetaobject.cpp:232
#13 0x006afa6a in QMetaObject::activate (sender=0xa1894d8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0xa1894d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0xa1894d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9332b8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x006a0b7d in metacall (argv=0xbf9332b8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0xa1894d8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0xa1894d8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf9332b8) at kernel/qmetaobject.cpp:232
#18 0x006afa6a in QMetaObject::activate (sender=0xa11ac18, m=0x80950c0, local_signal_index=0, argv=0xbf9332b8) at kernel/qobject.cpp:3278
#19 0x00ea87c5 in MuonMainWindow::backendReady (this=0xa11ac18, _t1=0xa170e50) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00ea8933 in MuonMainWindow::initObject (this=0xa11ac18) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0xa11ac18) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0xa11ac18, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9333e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x006a0b7d in metacall (argv=0xbf9333e4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0xa11ac18) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0xa11ac18, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf9333e4) at kernel/qmetaobject.cpp:232
#25 0x006afa6a in QMetaObject::activate (sender=0xa197338, m=0x7d0238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x006b7375 in QSingleShotTimer::timeout (this=0xa197338) at .moc/release-shared/qtimer.moc:82
#27 0x006b742c in QSingleShotTimer::timerEvent (this=0xa197338) at kernel/qtimer.cpp:308
#28 0x006b2994 in QObject::event (this=0xa197338, e=0xbf9337dc) at kernel/qobject.cpp:1181
#29 0x05cfed84 in notify_helper (e=0xbf9337dc, receiver=0xa197338, this=0xa032230) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0xa032230, receiver=0xa197338, e=0xbf9337dc) at kernel/qapplication.cpp:4458
#31 0x05d04133 in QApplication::notify (this=0xbf9337dc, receiver=0xa197338, e=0xbf9337dc) at kernel/qapplication.cpp:3886
#32 0x0118d971 in KApplication::notify (this=0xbf933af0, receiver=0xa197338, event=0xbf9337dc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0069a19e in QCoreApplication::notifyInternal (this=0xbf933af0, receiver=0xa197338, event=0xbf9337dc) at kernel/qcoreapplication.cpp:787
#34 0x006cac10 in sendEvent (event=0xbf9337dc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0xa0354fc) at kernel/qeventdispatcher_unix.cpp:603
#36 0x006c8122 in timerSourceDispatch (source=0xa0354c8) at kernel/qeventdispatcher_glib.cpp:184
#37 0x08f5725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x08f57990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x08f57c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x006c8ada in QEventDispatcherGlib::processEvents (this=0xa015238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x05db6e7a in QGuiEventDispatcherGlib::processEvents (this=0xa015238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x006991dd in QEventLoop::processEvents (this=0xbf933a54, flags=...) at kernel/qeventloop.cpp:149
#43 0x00699421 in QEventLoop::exec (this=0xbf933a54, flags=...) at kernel/qeventloop.cpp:201
#44 0x0069e19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x05cfc924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294848, bug 294844, bug 294843, bug 294842, bug 294800.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-26 13:51:59 UTC

*** This bug has been marked as a duplicate of bug 291262 ***