Bug 294696 - Muon Software Center crash on attempt to use
Summary: Muon Software Center crash on attempt to use
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-23 15:21 UTC by a.langley
Modified: 2012-02-23 15:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description a.langley 2012-02-23 15:21:58 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Nothing. I opened the Muon Software Center to download software.

- Unusual behavior I noticed:
Crashed when I opened the application.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78d2930 (LWP 8793))]

Thread 2 (Thread 0xb5c04b70 (LWP 8794)):
#0  0x0079fd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00b477d5 in do_gettime (frac=0xb5c04020, sec=0xb5c04018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00c1a4b6 in QTimerInfoList::updateCurrentTime (this=0x8489ef4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00c1a80a in QTimerInfoList::timerWait (this=0x8489ef4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00c19053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb5c0412c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00c190ed in timerSourcePrepare (source=0x8489ec0, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x00ee488c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x00ee5637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x00ee5c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00c19b37 in QEventDispatcherGlib::processEvents (this=0x8433f48, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00bea1dd in QEventLoop::processEvents (this=0xb5c042b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00bea421 in QEventLoop::exec (this=0xb5c042b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00aed90b in QThread::exec (this=0x840e9a0) at thread/qthread.cpp:498
#14 0x00bcae2d in QInotifyFileSystemWatcherEngine::run (this=0x840e9a0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00af07b3 in QThreadPrivate::start (arg=0x840e9a0) at thread/qthread_unix.cpp:331
#16 0x0077cd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00df80ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb78d2930 (LWP 8793)):
[KCrash Handler]
#7  0x00b44e11 in QtPrivate::QStringList_contains (that=0xbf923e94, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf923e94) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x83f2418) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x83f2418, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9240b4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00bf1b7d in metacall (argv=0xbf9240b4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x83f2418) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x83f2418, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf9240b4) at kernel/qmetaobject.cpp:232
#13 0x00c00a6a in QMetaObject::activate (sender=0x8465fe8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8465fe8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8465fe8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9241f8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00bf1b7d in metacall (argv=0xbf9241f8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8465fe8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8465fe8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf9241f8) at kernel/qmetaobject.cpp:232
#18 0x00c00a6a in QMetaObject::activate (sender=0x83f2418, m=0x80950c0, local_signal_index=0, argv=0xbf9241f8) at kernel/qobject.cpp:3278
#19 0x00fca7c5 in MuonMainWindow::backendReady (this=0x83f2418, _t1=0x8303900) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00fca933 in MuonMainWindow::initObject (this=0x83f2418) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x83f2418) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x83f2418, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf924324) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00bf1b7d in metacall (argv=0xbf924324, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x83f2418) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x83f2418, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf924324) at kernel/qmetaobject.cpp:232
#25 0x00c00a6a in QMetaObject::activate (sender=0x8467640, m=0xd21238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00c08375 in QSingleShotTimer::timeout (this=0x8467640) at .moc/release-shared/qtimer.moc:82
#27 0x00c0842c in QSingleShotTimer::timerEvent (this=0x8467640) at kernel/qtimer.cpp:308
#28 0x00c03994 in QObject::event (this=0x8467640, e=0xbf92471c) at kernel/qobject.cpp:1181
#29 0x0758bd84 in notify_helper (e=0xbf92471c, receiver=0x8467640, this=0x830a910) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x830a910, receiver=0x8467640, e=0xbf92471c) at kernel/qapplication.cpp:4458
#31 0x07591133 in QApplication::notify (this=0xbf92471c, receiver=0x8467640, e=0xbf92471c) at kernel/qapplication.cpp:3886
#32 0x011e5971 in KApplication::notify (this=0xbf924a30, receiver=0x8467640, event=0xbf92471c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00beb19e in QCoreApplication::notifyInternal (this=0xbf924a30, receiver=0x8467640, event=0xbf92471c) at kernel/qcoreapplication.cpp:787
#34 0x00c1bc10 in sendEvent (event=0xbf92471c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x830ba8c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00c19122 in timerSourceDispatch (source=0x830ba58) at kernel/qeventdispatcher_glib.cpp:184
#37 0x00ee525f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x00ee5990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x00ee5c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00c19ada in QEventDispatcherGlib::processEvents (this=0x82ed238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x07643e7a in QGuiEventDispatcherGlib::processEvents (this=0x82ed238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00bea1dd in QEventLoop::processEvents (this=0xbf924994, flags=...) at kernel/qeventloop.cpp:149
#43 0x00bea421 in QEventLoop::exec (this=0xbf924994, flags=...) at kernel/qeventloop.cpp:201
#44 0x00bef19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x07589924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294662, bug 294621, bug 294605, bug 294591, bug 294484.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-23 15:27:20 UTC

*** This bug has been marked as a duplicate of bug 291262 ***