Bug 294605 - Ошибки при запуске программы
Summary: Ошибки при запуске программы
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-22 11:01 UTC by German
Modified: 2012-02-22 11:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description German 2012-02-22 11:01:18 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

- Unusual behavior I noticed:

- Custom settings of the application:

Не запускается программа при запуске и и не льзя воспользоватся центром приложения.. исправте

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77de930 (LWP 2554))]

Thread 2 (Thread 0xb5702b70 (LWP 2555)):
#0  0x00e6a416 in __kernel_vsyscall ()
#1  0x008a040e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x012f734b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x012e8896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x012e8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x003a1b37 in QEventDispatcherGlib::processEvents (this=0x9525a38, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x003721dd in QEventLoop::processEvents (this=0xb57022b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00372421 in QEventLoop::exec (this=0xb57022b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0027590b in QThread::exec (this=0x961bd78) at thread/qthread.cpp:498
#9  0x00352e2d in QInotifyFileSystemWatcherEngine::run (this=0x961bd78) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x002787b3 in QThreadPrivate::start (arg=0x961bd78) at thread/qthread_unix.cpp:331
#11 0x00daed31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x008af0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77de930 (LWP 2554)):
[KCrash Handler]
#7  0x002cce11 in QtPrivate::QStringList_contains (that=0xbfab2644, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfab2644) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x95cc750) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x95cc750, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfab2864) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00379b7d in metacall (argv=0xbfab2864, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x95cc750) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x95cc750, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfab2864) at kernel/qmetaobject.cpp:232
#13 0x00388a6a in QMetaObject::activate (sender=0x96369a0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x96369a0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x96369a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfab29a8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00379b7d in metacall (argv=0xbfab29a8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x96369a0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x96369a0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfab29a8) at kernel/qmetaobject.cpp:232
#18 0x00388a6a in QMetaObject::activate (sender=0x95cc750, m=0x80950c0, local_signal_index=0, argv=0xbfab29a8) at kernel/qobject.cpp:3278
#19 0x007a97c5 in MuonMainWindow::backendReady (this=0x95cc750, _t1=0x9622af8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x007a9933 in MuonMainWindow::initObject (this=0x95cc750) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x95cc750) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x95cc750, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfab2ad4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00379b7d in metacall (argv=0xbfab2ad4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x95cc750) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x95cc750, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfab2ad4) at kernel/qmetaobject.cpp:232
#25 0x00388a6a in QMetaObject::activate (sender=0x963f938, m=0x4a9238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00390375 in QSingleShotTimer::timeout (this=0x963f938) at .moc/release-shared/qtimer.moc:82
#27 0x0039042c in QSingleShotTimer::timerEvent (this=0x963f938) at kernel/qtimer.cpp:308
#28 0x0038b994 in QObject::event (this=0x963f938, e=0xbfab2ecc) at kernel/qobject.cpp:1181
#29 0x08adbd84 in notify_helper (e=0xbfab2ecc, receiver=0x963f938, this=0x94bcc28) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x94bcc28, receiver=0x963f938, e=0xbfab2ecc) at kernel/qapplication.cpp:4458
#31 0x08ae1133 in QApplication::notify (this=0xbfab2ecc, receiver=0x963f938, e=0xbfab2ecc) at kernel/qapplication.cpp:3886
#32 0x01052971 in KApplication::notify (this=0xbfab31e0, receiver=0x963f938, event=0xbfab2ecc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0037319e in QCoreApplication::notifyInternal (this=0xbfab31e0, receiver=0x963f938, event=0xbfab2ecc) at kernel/qcoreapplication.cpp:787
#34 0x003a3c10 in sendEvent (event=0xbfab2ecc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x94c4d34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x003a1122 in timerSourceDispatch (source=0x94c4d00) at kernel/qeventdispatcher_glib.cpp:184
#37 0x012e825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x012e8990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x012e8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x003a1ada in QEventDispatcherGlib::processEvents (this=0x94a0238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x08b93e7a in QGuiEventDispatcherGlib::processEvents (this=0x94a0238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x003721dd in QEventLoop::processEvents (this=0xbfab3144, flags=...) at kernel/qeventloop.cpp:149
#43 0x00372421 in QEventLoop::exec (this=0xbfab3144, flags=...) at kernel/qeventloop.cpp:201
#44 0x0037719d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x08ad9924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294591, bug 294484, bug 294456, bug 294433, bug 294431.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-22 11:04:15 UTC

*** This bug has been marked as a duplicate of bug 291262 ***