Bug 294662 - MUON Crashed After Starting
Summary: MUON Crashed After Starting
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-23 06:53 UTC by Ed Figueroa
Modified: 2012-02-23 19:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.87 KB, text/plain)
2012-02-23 17:38 UTC, Elijah
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Figueroa 2012-02-23 06:53:37 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I was trying to use MUON it just close after starting

- Unusual behavior I noticed:
Screen stopped responding, for about 30 Sec...............

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb779d930 (LWP 5802))]

Thread 2 (Thread 0xb5b1fb70 (LWP 5807)):
#0  0x00d5fdbd in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x006e8f14 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x03107f53 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x031088f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x03108c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00a98b37 in QEventDispatcherGlib::processEvents (this=0xa2322d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00a691dd in QEventLoop::processEvents (this=0xb5b1f2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00a69421 in QEventLoop::exec (this=0xb5b1f2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0096c90b in QThread::exec (this=0xa2338a0) at thread/qthread.cpp:498
#9  0x00a49e2d in QInotifyFileSystemWatcherEngine::run (this=0xa2338a0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0096f7b3 in QThreadPrivate::start (arg=0xa2338a0) at thread/qthread_unix.cpp:331
#11 0x00d5dd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x006db0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb779d930 (LWP 5802)):
[KCrash Handler]
#7  0x009c3e11 in QtPrivate::QStringList_contains (that=0xbf958474, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf958474) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0xa19b0e8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0xa19b0e8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf958694) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00a70b7d in metacall (argv=0xbf958694, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0xa19b0e8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0xa19b0e8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf958694) at kernel/qmetaobject.cpp:232
#13 0x00a7fa6a in QMetaObject::activate (sender=0xa1878d0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0xa1878d0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0xa1878d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9587d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00a70b7d in metacall (argv=0xbf9587d8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0xa1878d0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0xa1878d0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf9587d8) at kernel/qmetaobject.cpp:232
#18 0x00a7fa6a in QMetaObject::activate (sender=0xa19b0e8, m=0x80950c0, local_signal_index=0, argv=0xbf9587d8) at kernel/qobject.cpp:3278
#19 0x008d07c5 in MuonMainWindow::backendReady (this=0xa19b0e8, _t1=0xa106cb8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x008d0933 in MuonMainWindow::initObject (this=0xa19b0e8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0xa19b0e8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0xa19b0e8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf958904) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00a70b7d in metacall (argv=0xbf958904, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0xa19b0e8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0xa19b0e8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf958904) at kernel/qmetaobject.cpp:232
#25 0x00a7fa6a in QMetaObject::activate (sender=0xa204c58, m=0xba0238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00a87375 in QSingleShotTimer::timeout (this=0xa204c58) at .moc/release-shared/qtimer.moc:82
#27 0x00a8742c in QSingleShotTimer::timerEvent (this=0xa204c58) at kernel/qtimer.cpp:308
#28 0x00a82994 in QObject::event (this=0xa204c58, e=0xbf958cfc) at kernel/qobject.cpp:1181
#29 0x08f1fd84 in notify_helper (e=0xbf958cfc, receiver=0xa204c58, this=0xa09f330) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0xa09f330, receiver=0xa204c58, e=0xbf958cfc) at kernel/qapplication.cpp:4458
#31 0x08f25133 in QApplication::notify (this=0xbf958cfc, receiver=0xa204c58, e=0xbf958cfc) at kernel/qapplication.cpp:3886
#32 0x00f99971 in KApplication::notify (this=0xbf959010, receiver=0xa204c58, event=0xbf958cfc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00a6a19e in QCoreApplication::notifyInternal (this=0xbf959010, receiver=0xa204c58, event=0xbf958cfc) at kernel/qcoreapplication.cpp:787
#34 0x00a9ac10 in sendEvent (event=0xbf958cfc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0xa0a3b74) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00a98122 in timerSourceDispatch (source=0xa0a3b40) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0310825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x03108990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x03108c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00a98ada in QEventDispatcherGlib::processEvents (this=0xa082238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x08fd7e7a in QGuiEventDispatcherGlib::processEvents (this=0xa082238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00a691dd in QEventLoop::processEvents (this=0xbf958f74, flags=...) at kernel/qeventloop.cpp:149
#43 0x00a69421 in QEventLoop::exec (this=0xbf958f74, flags=...) at kernel/qeventloop.cpp:201
#44 0x00a6e19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x08f1d924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294621, bug 294605, bug 294591, bug 294484, bug 294456.

Reported using DrKonqi
Comment 1 Elijah 2012-02-23 17:38:01 UTC
Created attachment 69042 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

I remember that a while ago I tried to install updates to Linux for the first time and updator crashed, which also prevented me from turning off my netbook. I'm not sure if that's related, but Muon Software never worked ever since.

-- Backtrace (Reduced):
#7  0x00650e11 in QtPrivate::QStringList_contains (that=0xbffb5df4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbffb5df4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9db6228) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9db6228, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffb6014) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x006fdb7d in metacall (argv=0xbffb6014, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9db6228) at kernel/qmetaobject.cpp:237
Comment 2 Christoph Feck 2012-02-23 19:16:24 UTC

*** This bug has been marked as a duplicate of bug 291262 ***