Bug 294484 - Muon Software center crash
Summary: Muon Software center crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-20 10:05 UTC by Pepijn
Modified: 2012-02-20 11:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pepijn 2012-02-20 10:05:38 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
I am unable to start the software center, it crashes every time. This is a new clean Kubuntu install.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78ae930 (LWP 1681))]

Thread 2 (Thread 0xb5a6cb70 (LWP 1685)):
#0  timerSourcePrepareHelper (src=0x8ed0c98, timeout=0xb5a6c12c) at kernel/qeventdispatcher_glib.cpp:134
#1  0x008700ed in timerSourcePrepare (source=0x8ed0c98, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#2  0x014fe88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x014ff637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x014ffc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00870b37 in QEventDispatcherGlib::processEvents (this=0x8c83a80, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x008411dd in QEventLoop::processEvents (this=0xb5a6c2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00841421 in QEventLoop::exec (this=0xb5a6c2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0074490b in QThread::exec (this=0x8e0faa0) at thread/qthread.cpp:498
#9  0x00821e2d in QInotifyFileSystemWatcherEngine::run (this=0x8e0faa0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x007477b3 in QThreadPrivate::start (arg=0x8e0faa0) at thread/qthread_unix.cpp:331
#11 0x0053bd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x004250ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb78ae930 (LWP 1681)):
[KCrash Handler]
#7  0x0079be11 in QtPrivate::QStringList_contains (that=0xbfdb5ff4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfdb5ff4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8d748c0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8d748c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdb6214) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00848b7d in metacall (argv=0xbfdb6214, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8d748c0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8d748c0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfdb6214) at kernel/qmetaobject.cpp:232
#13 0x00857a6a in QMetaObject::activate (sender=0x8de4db0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8de4db0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8de4db0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdb6358) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00848b7d in metacall (argv=0xbfdb6358, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8de4db0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8de4db0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfdb6358) at kernel/qmetaobject.cpp:232
#18 0x00857a6a in QMetaObject::activate (sender=0x8d748c0, m=0x80950c0, local_signal_index=0, argv=0xbfdb6358) at kernel/qobject.cpp:3278
#19 0x006a87c5 in MuonMainWindow::backendReady (this=0x8d748c0, _t1=0x8cee608) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x006a8933 in MuonMainWindow::initObject (this=0x8d748c0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8d748c0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8d748c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfdb6484) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00848b7d in metacall (argv=0xbfdb6484, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8d748c0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8d748c0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfdb6484) at kernel/qmetaobject.cpp:232
#25 0x00857a6a in QMetaObject::activate (sender=0x8de9db8, m=0x978238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0085f375 in QSingleShotTimer::timeout (this=0x8de9db8) at .moc/release-shared/qtimer.moc:82
#27 0x0085f42c in QSingleShotTimer::timerEvent (this=0x8de9db8) at kernel/qtimer.cpp:308
#28 0x0085a994 in QObject::event (this=0x8de9db8, e=0xbfdb687c) at kernel/qobject.cpp:1181
#29 0x0302cd84 in notify_helper (e=0xbfdb687c, receiver=0x8de9db8, this=0x8c8c8d0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8c8c8d0, receiver=0x8de9db8, e=0xbfdb687c) at kernel/qapplication.cpp:4458
#31 0x03032133 in QApplication::notify (this=0xbfdb687c, receiver=0x8de9db8, e=0xbfdb687c) at kernel/qapplication.cpp:3886
#32 0x0114f971 in KApplication::notify (this=0xbfdb6b90, receiver=0x8de9db8, event=0xbfdb687c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0084219e in QCoreApplication::notifyInternal (this=0xbfdb6b90, receiver=0x8de9db8, event=0xbfdb687c) at kernel/qcoreapplication.cpp:787
#34 0x00872c10 in sendEvent (event=0xbfdb687c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8c8f0ec) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00870122 in timerSourceDispatch (source=0x8c8f0b8) at kernel/qeventdispatcher_glib.cpp:184
#37 0x014ff25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x014ff990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x014ffc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00870ada in QEventDispatcherGlib::processEvents (this=0x8c6a238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x030e4e7a in QGuiEventDispatcherGlib::processEvents (this=0x8c6a238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x008411dd in QEventLoop::processEvents (this=0xbfdb6af4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00841421 in QEventLoop::exec (this=0xbfdb6af4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0084619d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0302a924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 294456, bug 294433, bug 294431, bug 294414, bug 294405.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-20 11:41:14 UTC

*** This bug has been marked as a duplicate of bug 291262 ***