Bug 294621 - Gestor de Paquetes
Summary: Gestor de Paquetes
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-22 16:44 UTC by claudiob58
Modified: 2012-02-22 16:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description claudiob58 2012-02-22 16:44:45 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
no se inicia el gestor de paquetes de cierra

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77d4930 (LWP 1771))]

Thread 2 (Thread 0xb42b1b70 (LWP 1777)):
#0  0x004d0d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00d8f7d5 in do_gettime (frac=0xb42b1020, sec=0xb42b1018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00e624b6 in QTimerInfoList::updateCurrentTime (this=0xa03c634) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00e6280a in QTimerInfoList::timerWait (this=0xa03c634, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00e61053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb42b112c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00e610ed in timerSourcePrepare (source=0xa03c600, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x05ab788c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x05ab8637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x05ab8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00e61b37 in QEventDispatcherGlib::processEvents (this=0x9f74300, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00e321dd in QEventLoop::processEvents (this=0xb42b12b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00e32421 in QEventLoop::exec (this=0xb42b12b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00d3590b in QThread::exec (this=0x9f2a0b0) at thread/qthread.cpp:498
#14 0x00e12e2d in QInotifyFileSystemWatcherEngine::run (this=0x9f2a0b0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00d387b3 in QThreadPrivate::start (arg=0x9f2a0b0) at thread/qthread_unix.cpp:331
#16 0x007c2d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x001e20ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77d4930 (LWP 1771)):
[KCrash Handler]
#7  0x00d8ce11 in QtPrivate::QStringList_contains (that=0xbf97faa4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf97faa4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9eef8c0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9eef8c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf97fcc4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00e39b7d in metacall (argv=0xbf97fcc4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9eef8c0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9eef8c0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf97fcc4) at kernel/qmetaobject.cpp:232
#13 0x00e48a6a in QMetaObject::activate (sender=0x9f46498, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9f46498) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9f46498, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf97fe08) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00e39b7d in metacall (argv=0xbf97fe08, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9f46498) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9f46498, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf97fe08) at kernel/qmetaobject.cpp:232
#18 0x00e48a6a in QMetaObject::activate (sender=0x9eef8c0, m=0x80950c0, local_signal_index=0, argv=0xbf97fe08) at kernel/qobject.cpp:3278
#19 0x008297c5 in MuonMainWindow::backendReady (this=0x9eef8c0, _t1=0x9f4d7b8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00829933 in MuonMainWindow::initObject (this=0x9eef8c0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9eef8c0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9eef8c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf97ff34) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00e39b7d in metacall (argv=0xbf97ff34, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9eef8c0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9eef8c0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf97ff34) at kernel/qmetaobject.cpp:232
#25 0x00e48a6a in QMetaObject::activate (sender=0x9f3fc40, m=0xf69238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00e50375 in QSingleShotTimer::timeout (this=0x9f3fc40) at .moc/release-shared/qtimer.moc:82
#27 0x00e5042c in QSingleShotTimer::timerEvent (this=0x9f3fc40) at kernel/qtimer.cpp:308
#28 0x00e4b994 in QObject::event (this=0x9f3fc40, e=0xbf98032c) at kernel/qobject.cpp:1181
#29 0x092ffd84 in notify_helper (e=0xbf98032c, receiver=0x9f3fc40, this=0x9def698) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9def698, receiver=0x9f3fc40, e=0xbf98032c) at kernel/qapplication.cpp:4458
#31 0x09305133 in QApplication::notify (this=0xbf98032c, receiver=0x9f3fc40, e=0xbf98032c) at kernel/qapplication.cpp:3886
#32 0x011b6971 in KApplication::notify (this=0xbf980640, receiver=0x9f3fc40, event=0xbf98032c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00e3319e in QCoreApplication::notifyInternal (this=0xbf980640, receiver=0x9f3fc40, event=0xbf98032c) at kernel/qcoreapplication.cpp:787
#34 0x00e63c10 in sendEvent (event=0xbf98032c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9df328c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00e61122 in timerSourceDispatch (source=0x9df3258) at kernel/qeventdispatcher_glib.cpp:184
#37 0x05ab825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x05ab8990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x05ab8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00e61ada in QEventDispatcherGlib::processEvents (this=0x9dd2238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x093b7e7a in QGuiEventDispatcherGlib::processEvents (this=0x9dd2238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00e321dd in QEventLoop::processEvents (this=0xbf9805a4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00e32421 in QEventLoop::exec (this=0xbf9805a4, flags=...) at kernel/qeventloop.cpp:201
#44 0x00e3719d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x092fd924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294605, bug 294591, bug 294484, bug 294456, bug 294433.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-22 16:59:46 UTC

*** This bug has been marked as a duplicate of bug 291262 ***