Bug 294456 - Crash when open software center
Summary: Crash when open software center
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-19 23:14 UTC by jonny amrques
Modified: 2012-02-24 15:38 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.68 KB, text/plain)
2012-02-24 15:38 UTC, burak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jonny amrques 2012-02-19 23:14:24 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: when I try open software center allways it chash. I tryed update but nothing works

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f45e61a0780 (LWP 2263))]

Thread 2 (Thread 0x7f45d1c4d700 (LWP 2264)):
#0  0x00007f45e2d68773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f45df5ddf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f45df5de429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f45e4f26f3e in QEventDispatcherGlib::processEvents (this=0x1285fd0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f45e4efacf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f45e4efaef7 in QEventLoop::exec (this=0x7f45d1c4cdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f45e4e1227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f45e4eddcbf in QInotifyFileSystemWatcherEngine::run (this=0x1405eb0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f45e4e14d05 in QThreadPrivate::start (arg=0x1405eb0) at thread/qthread_unix.cpp:331
#9  0x00007f45e00bfefc in start_thread (arg=0x7f45d1c4d700) at pthread_create.c:304
#10 0x00007f45e2d7489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f45e61a0780 (LWP 2263)):
[KCrash Handler]
#6  0x00007f45e4e62a5e in QtPrivate::QStringList_contains (that=0x7fffe4239460, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffe4239460) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x136da20) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x136da20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe4239a30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f45e4f0eeba in QMetaObject::activate (sender=0x13f7860, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x13f7860, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe4239b90) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f45e4f0eeba in QMetaObject::activate (sender=0x136da20, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffe4239b90) at kernel/qobject.cpp:3278
#13 0x00007f45e5d84e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1409cf0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f45e5d84f8e in MuonMainWindow::initObject (this=0x136da20) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x136da20) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x136da20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe4239c60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f45e4f0eeba in QMetaObject::activate (sender=0x13f0140, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f45e4f16f7f in QSingleShotTimer::timerEvent (this=0x13f0140) at kernel/qtimer.cpp:308
#19 0x00007f45e4f12789 in QObject::event (this=0x13f0140, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f45e3535474 in notify_helper (e=0x7fffe423a1d0, receiver=0x13f0140, this=0x1238dc0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1238dc0, receiver=0x13f0140, e=0x7fffe423a1d0) at kernel/qapplication.cpp:4458
#22 0x00007f45e353a2e1 in QApplication::notify (this=0x7fffe423a4d0, receiver=0x13f0140, e=0x7fffe423a1d0) at kernel/qapplication.cpp:4365
#23 0x00007f45e471a466 in KApplication::notify (this=0x7fffe423a4d0, receiver=0x13f0140, event=0x7fffe423a1d0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f45e4efbafc in QCoreApplication::notifyInternal (this=0x7fffe423a4d0, receiver=0x13f0140, event=0x7fffe423a1d0) at kernel/qcoreapplication.cpp:787
#25 0x00007f45e4f28d62 in sendEvent (event=0x7fffe423a1d0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1233950) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f45e4f26514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f45df5dda5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f45df5de258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f45df5de429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f45e4f26ed6 in QEventDispatcherGlib::processEvents (this=0x120d6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f45e35dd10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f45e4efacf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f45e4efaef7 in QEventLoop::exec (this=0x7fffe423a460, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f45e4eff789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffe423a748) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294433, bug 294431, bug 294414, bug 294405, bug 294404.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-20 09:14:01 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 burak 2012-02-24 15:38:01 UTC
Created attachment 69063 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

i just tried to open muon software center and it crashed.

-- Backtrace (Reduced):
#7  0xb72dde11 in QtPrivate::QStringList_contains (that=0xbfb3b304, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfb3b304) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x86fa800) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x86fa800, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb3b524) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb738ab7d in metacall (argv=0xbfb3b524, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x86fa800) at kernel/qmetaobject.cpp:237