Bug 294431 - Open Software Center
Summary: Open Software Center
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-19 14:08 UTC by Evert van den Berg
Modified: 2012-02-19 17:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Evert van den Berg 2012-02-19 14:08:33 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Opened Muon Software Centrum which crashed at startup. Currently running Kubuntu in virtualbox

The crash can be reproduced every time.

-- Backtrace:
Application: Muon softwarecentrum (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff06c0fe780 (LWP 2251))]

Thread 2 (Thread 0x7ff057740700 (LWP 2252)):
#0  0x00007ff068cc4773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff065539f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff06553a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff06ae82f3e in QEventDispatcherGlib::processEvents (this=0x2667540, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff06ae56cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff06ae56ef7 in QEventLoop::exec (this=0x7ff05773fdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff06ad6e27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007ff06ae39cbf in QInotifyFileSystemWatcherEngine::run (this=0x283b020) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ff06ad70d05 in QThreadPrivate::start (arg=0x283b020) at thread/qthread_unix.cpp:331
#9  0x00007ff06601befc in start_thread (arg=0x7ff057740700) at pthread_create.c:304
#10 0x00007ff068cd089d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff06c0fe780 (LWP 2251)):
[KCrash Handler]
#6  0x00007ff06adbea5e in QtPrivate::QStringList_contains (that=0x7fff8e0a87c0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff8e0a87c0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x27d1340) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x27d1340, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8e0a8d90) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007ff06ae6aeba in QMetaObject::activate (sender=0x28940b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x28940b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8e0a8ef0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007ff06ae6aeba in QMetaObject::activate (sender=0x27d1340, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8e0a8ef0) at kernel/qobject.cpp:3278
#13 0x00007ff06bce0e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x27a4bf0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007ff06bce0f8e in MuonMainWindow::initObject (this=0x27d1340) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x27d1340) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x27d1340, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8e0a8fc0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007ff06ae6aeba in QMetaObject::activate (sender=0x285e330, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007ff06ae72f7f in QSingleShotTimer::timerEvent (this=0x285e330) at kernel/qtimer.cpp:308
#19 0x00007ff06ae6e789 in QObject::event (this=0x285e330, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007ff069491474 in notify_helper (e=0x7fff8e0a9530, receiver=0x285e330, this=0x2675a40) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x2675a40, receiver=0x285e330, e=0x7fff8e0a9530) at kernel/qapplication.cpp:4458
#22 0x00007ff0694962e1 in QApplication::notify (this=0x7fff8e0a9830, receiver=0x285e330, e=0x7fff8e0a9530) at kernel/qapplication.cpp:4365
#23 0x00007ff06a676466 in KApplication::notify (this=0x7fff8e0a9830, receiver=0x285e330, event=0x7fff8e0a9530) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007ff06ae57afc in QCoreApplication::notifyInternal (this=0x7fff8e0a9830, receiver=0x285e330, event=0x7fff8e0a9530) at kernel/qcoreapplication.cpp:787
#25 0x00007ff06ae84d62 in sendEvent (event=0x7fff8e0a9530, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x2672540) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007ff06ae82514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007ff065539a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007ff06553a258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007ff06553a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007ff06ae82ed6 in QEventDispatcherGlib::processEvents (this=0x264c6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007ff06953910e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007ff06ae56cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007ff06ae56ef7 in QEventLoop::exec (this=0x7fff8e0a97c0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007ff06ae5b789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff8e0a9aa8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294414, bug 294405, bug 294404, bug 294395, bug 294394.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-19 17:57:11 UTC

*** This bug has been marked as a duplicate of bug 291262 ***