Bug 294404 - not oupen center software
Summary: not oupen center software
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-19 03:14 UTC by Jeronimo
Modified: 2012-02-19 05:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeronimo 2012-02-19 03:14:32 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
I will not have the software center, and the original is sitema

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb1879d6780 (LWP 2235))]

Thread 2 (Thread 0x7fb172c0e700 (LWP 2239)):
#0  0x00007fb18459e773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb180e13f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb180e14429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb18675cf3e in QEventDispatcherGlib::processEvents (this=0x2608dd0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fb186730cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb186730ef7 in QEventLoop::exec (this=0x7fb172c0ddd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb18664827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fb186713cbf in QInotifyFileSystemWatcherEngine::run (this=0x26618e0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fb18664ad05 in QThreadPrivate::start (arg=0x26618e0) at thread/qthread_unix.cpp:331
#9  0x00007fb1818f5efc in start_thread (arg=0x7fb172c0e700) at pthread_create.c:304
#10 0x00007fb1845aa89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb1879d6780 (LWP 2235)):
[KCrash Handler]
#6  0x00007fb186698a5e in QtPrivate::QStringList_contains (that=0x7fff833a6a50, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff833a6a50) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x2614800) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x2614800, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff833a7020) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fb186744eba in QMetaObject::activate (sender=0x26387d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x26387d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff833a7180) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fb186744eba in QMetaObject::activate (sender=0x2614800, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff833a7180) at kernel/qobject.cpp:3278
#13 0x00007fb1875bae7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x263b5a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fb1875baf8e in MuonMainWindow::initObject (this=0x2614800) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x2614800) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x2614800, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff833a7250) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fb186744eba in QMetaObject::activate (sender=0x267ebf0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fb18674cf7f in QSingleShotTimer::timerEvent (this=0x267ebf0) at kernel/qtimer.cpp:308
#19 0x00007fb186748789 in QObject::event (this=0x267ebf0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fb184d6b474 in notify_helper (e=0x7fff833a77c0, receiver=0x267ebf0, this=0x24a04e0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x24a04e0, receiver=0x267ebf0, e=0x7fff833a77c0) at kernel/qapplication.cpp:4458
#22 0x00007fb184d702e1 in QApplication::notify (this=0x7fff833a7ac0, receiver=0x267ebf0, e=0x7fff833a77c0) at kernel/qapplication.cpp:4365
#23 0x00007fb185f50466 in KApplication::notify (this=0x7fff833a7ac0, receiver=0x267ebf0, event=0x7fff833a77c0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fb186731afc in QCoreApplication::notifyInternal (this=0x7fff833a7ac0, receiver=0x267ebf0, event=0x7fff833a77c0) at kernel/qcoreapplication.cpp:787
#25 0x00007fb18675ed62 in sendEvent (event=0x7fff833a77c0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x249cb70) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fb18675c514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fb180e13a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fb180e14258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fb180e14429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fb18675ced6 in QEventDispatcherGlib::processEvents (this=0x24786f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fb184e1310e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fb186730cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fb186730ef7 in QEventLoop::exec (this=0x7fff833a7a50, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fb186735789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff833a7d38) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294202, bug 294194, bug 294193, bug 294181, bug 294180.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-19 05:54:28 UTC

*** This bug has been marked as a duplicate of bug 291202 ***
Comment 2 Jekyll Wu 2012-02-19 05:57:06 UTC
sorry for the typo

*** This bug has been marked as a duplicate of bug 291262 ***