Bug 294395 - Muon crashes
Summary: Muon crashes
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 23:06 UTC by Kate
Modified: 2012-02-18 23:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kate 2012-02-18 23:06:01 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Whenever I try to start the Muon Software Center it crashes, even immediately upon launching Kubuntu

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2b25c31780 (LWP 3228))]

Thread 2 (Thread 0x7f2b11206700 (LWP 3232)):
#0  0x00007f2b227f9773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2b1f06ef68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2b1f06f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2b249b7f3e in QEventDispatcherGlib::processEvents (this=0x239e7d0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f2b2498bcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f2b2498bef7 in QEventLoop::exec (this=0x7f2b11205dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f2b248a327f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f2b2496ecbf in QInotifyFileSystemWatcherEngine::run (this=0x221a5e0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f2b248a5d05 in QThreadPrivate::start (arg=0x221a5e0) at thread/qthread_unix.cpp:331
#9  0x00007f2b1fb50efc in start_thread (arg=0x7f2b11206700) at pthread_create.c:304
#10 0x00007f2b2280589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2b25c31780 (LWP 3228)):
[KCrash Handler]
#6  0x00007f2b248f3a5e in QtPrivate::QStringList_contains (that=0x7fff16937440, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff16937440) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x21c1aa0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x21c1aa0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff16937a10) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f2b2499feba in QMetaObject::activate (sender=0x22488a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x22488a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff16937b70) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f2b2499feba in QMetaObject::activate (sender=0x21c1aa0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff16937b70) at kernel/qobject.cpp:3278
#13 0x00007f2b25815e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x2261930) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f2b25815f8e in MuonMainWindow::initObject (this=0x21c1aa0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x21c1aa0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x21c1aa0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff16937c40) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f2b2499feba in QMetaObject::activate (sender=0x2262410, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f2b249a7f7f in QSingleShotTimer::timerEvent (this=0x2262410) at kernel/qtimer.cpp:308
#19 0x00007f2b249a3789 in QObject::event (this=0x2262410, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f2b22fc6474 in notify_helper (e=0x7fff169381b0, receiver=0x2262410, this=0x2081b60) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x2081b60, receiver=0x2262410, e=0x7fff169381b0) at kernel/qapplication.cpp:4458
#22 0x00007f2b22fcb2e1 in QApplication::notify (this=0x7fff169384b0, receiver=0x2262410, e=0x7fff169381b0) at kernel/qapplication.cpp:4365
#23 0x00007f2b241ab466 in KApplication::notify (this=0x7fff169384b0, receiver=0x2262410, event=0x7fff169381b0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f2b2498cafc in QCoreApplication::notifyInternal (this=0x7fff169384b0, receiver=0x2262410, event=0x7fff169381b0) at kernel/qcoreapplication.cpp:787
#25 0x00007f2b249b9d62 in sendEvent (event=0x7fff169381b0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x207edc0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f2b249b7514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f2b1f06ea5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f2b1f06f258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f2b1f06f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f2b249b7ed6 in QEventDispatcherGlib::processEvents (this=0x20596f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f2b2306e10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f2b2498bcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f2b2498bef7 in QEventLoop::exec (this=0x7fff16938440, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f2b24990789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff16938728) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 294202, bug 294194, bug 294193, bug 294181, bug 294180.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-18 23:44:34 UTC

*** This bug has been marked as a duplicate of bug 291262 ***