Bug 294394 - Muon software center and software update crashes at opening packages and at the start
Summary: Muon software center and software update crashes at opening packages and at t...
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 23:04 UTC by Juan Gaxiola
Modified: 2012-02-18 23:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Gaxiola 2012-02-18 23:04:54 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: 
the problem appears when i open the muon software center, and i notice that the software update doesn't work too.

- Unusual behavior I noticed:

Every time i open muon software center crashes when opening, also the software update application crashes and stop working in the middle of progress.
I have deleted and re-install the OS but the problem doesn't fix, even if download the .iso system image again, or even i use different applications to make a bootloader with a pendrive.

I'm using Kubuntu 10.11 Oneiric Ocelot on a netbook lenovo S10-3, this bug started in december 2011...

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7773930 (LWP 11161))]

Thread 2 (Thread 0xb407ab70 (LWP 11171)):
#0  0x00af5d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00f207d5 in do_gettime (frac=0xb407a020, sec=0xb407a018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00ff34b6 in QTimerInfoList::updateCurrentTime (this=0x8f1d71c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00ff380a in QTimerInfoList::timerWait (this=0x8f1d71c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00ff2053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb407a12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00ff20ed in timerSourcePrepare (source=0x8f1d6e8, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x026f288c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x026f3637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x026f3c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00ff2b37 in QEventDispatcherGlib::processEvents (this=0x8f13f30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00fc31dd in QEventLoop::processEvents (this=0xb407a2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00fc3421 in QEventLoop::exec (this=0xb407a2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00ec690b in QThread::exec (this=0x8e5b0b8) at thread/qthread.cpp:498
#14 0x00fa3e2d in QInotifyFileSystemWatcherEngine::run (this=0x8e5b0b8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00ec97b3 in QThreadPrivate::start (arg=0x8e5b0b8) at thread/qthread_unix.cpp:331
#16 0x00821d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x004dc0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7773930 (LWP 11161)):
[KCrash Handler]
#7  0x00f1de11 in QtPrivate::QStringList_contains (that=0xbfbb3b44, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfbb3b44) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8dbf818) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8dbf818, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfbb3d64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00fcab7d in metacall (argv=0xbfbb3d64, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8dbf818) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8dbf818, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfbb3d64) at kernel/qmetaobject.cpp:232
#13 0x00fd9a6a in QMetaObject::activate (sender=0x8ccfc30, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8ccfc30) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8ccfc30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfbb3ea8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00fcab7d in metacall (argv=0xbfbb3ea8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8ccfc30) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8ccfc30, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfbb3ea8) at kernel/qmetaobject.cpp:232
#18 0x00fd9a6a in QMetaObject::activate (sender=0x8dbf818, m=0x80950c0, local_signal_index=0, argv=0xbfbb3ea8) at kernel/qobject.cpp:3278
#19 0x003d67c5 in MuonMainWindow::backendReady (this=0x8dbf818, _t1=0x8dac6e8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x003d6933 in MuonMainWindow::initObject (this=0x8dbf818) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8dbf818) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8dbf818, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfbb3fd4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00fcab7d in metacall (argv=0xbfbb3fd4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8dbf818) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8dbf818, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfbb3fd4) at kernel/qmetaobject.cpp:232
#25 0x00fd9a6a in QMetaObject::activate (sender=0x8e2a5b0, m=0x10fa238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00fe1375 in QSingleShotTimer::timeout (this=0x8e2a5b0) at .moc/release-shared/qtimer.moc:82
#27 0x00fe142c in QSingleShotTimer::timerEvent (this=0x8e2a5b0) at kernel/qtimer.cpp:308
#28 0x00fdc994 in QObject::event (this=0x8e2a5b0, e=0xbfbb43cc) at kernel/qobject.cpp:1181
#29 0x058fad84 in notify_helper (e=0xbfbb43cc, receiver=0x8e2a5b0, this=0x8cda448) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8cda448, receiver=0x8e2a5b0, e=0xbfbb43cc) at kernel/qapplication.cpp:4458
#31 0x05900133 in QApplication::notify (this=0xbfbb43cc, receiver=0x8e2a5b0, e=0xbfbb43cc) at kernel/qapplication.cpp:3886
#32 0x0441d971 in KApplication::notify (this=0xbfbb46e0, receiver=0x8e2a5b0, event=0xbfbb43cc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00fc419e in QCoreApplication::notifyInternal (this=0xbfbb46e0, receiver=0x8e2a5b0, event=0xbfbb43cc) at kernel/qcoreapplication.cpp:787
#34 0x00ff4c10 in sendEvent (event=0xbfbb43cc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8cdcb8c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00ff2122 in timerSourceDispatch (source=0x8cdcb58) at kernel/qeventdispatcher_glib.cpp:184
#37 0x026f325f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x026f3990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x026f3c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00ff2ada in QEventDispatcherGlib::processEvents (this=0x8cbc238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x059b2e7a in QGuiEventDispatcherGlib::processEvents (this=0x8cbc238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00fc31dd in QEventLoop::processEvents (this=0xbfbb4644, flags=...) at kernel/qeventloop.cpp:149
#43 0x00fc3421 in QEventLoop::exec (this=0xbfbb4644, flags=...) at kernel/qeventloop.cpp:201
#44 0x00fc819d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x058f8924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294363, bug 294343, bug 294342, bug 294341, bug 294328.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-18 23:44:59 UTC

*** This bug has been marked as a duplicate of bug 291262 ***