Bug 294180 - muon crashes while being opened
Summary: muon crashes while being opened
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-15 19:33 UTC by marius.vandeventer
Modified: 2012-02-15 19:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marius.vandeventer 2012-02-15 19:33:56 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Every time Muon software centre s opened, it chrashes before the interface has finished loading. This occurs regardless of what other software is open or what other activities were being performed, in other words, it occurs in exactly the same way regardless of absolutely anything else occuring on the computer.

The accompanying program Muon Package Manager runs without error, also every single time.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb770a930 (LWP 2935))]

Thread 2 (Thread 0xb5676b70 (LWP 2940)):
#0  0x00825d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x0093c7d5 in do_gettime (frac=0xb5676020, sec=0xb5676018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00a0f4b6 in QTimerInfoList::updateCurrentTime (this=0x99bb29c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00a0f80a in QTimerInfoList::timerWait (this=0x99bb29c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00a0e053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb567612c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00a0e0ed in timerSourcePrepare (source=0x99bb268, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x07b6f88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x07b70637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x07b70c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00a0eb37 in QEventDispatcherGlib::processEvents (this=0x98f84e0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x009df1dd in QEventLoop::processEvents (this=0xb56762b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x009df421 in QEventLoop::exec (this=0xb56762b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x008e290b in QThread::exec (this=0x99b92a8) at thread/qthread.cpp:498
#14 0x009bfe2d in QInotifyFileSystemWatcherEngine::run (this=0x99b92a8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x008e57b3 in QThreadPrivate::start (arg=0x99b92a8) at thread/qthread_unix.cpp:331
#16 0x00c13d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x005100ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb770a930 (LWP 2935)):
[KCrash Handler]
#7  0x00939e11 in QtPrivate::QStringList_contains (that=0xbfc1cc74, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc1cc74) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x984ac90) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x984ac90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc1ce94) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x009e6b7d in metacall (argv=0xbfc1ce94, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x984ac90) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x984ac90, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfc1ce94) at kernel/qmetaobject.cpp:232
#13 0x009f5a6a in QMetaObject::activate (sender=0x98c6350, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x98c6350) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x98c6350, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc1cfd8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x009e6b7d in metacall (argv=0xbfc1cfd8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x98c6350) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x98c6350, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfc1cfd8) at kernel/qmetaobject.cpp:232
#18 0x009f5a6a in QMetaObject::activate (sender=0x984ac90, m=0x80950c0, local_signal_index=0, argv=0xbfc1cfd8) at kernel/qobject.cpp:3278
#19 0x008467c5 in MuonMainWindow::backendReady (this=0x984ac90, _t1=0x9875f48) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00846933 in MuonMainWindow::initObject (this=0x984ac90) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x984ac90) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x984ac90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc1d104) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x009e6b7d in metacall (argv=0xbfc1d104, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x984ac90) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x984ac90, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfc1d104) at kernel/qmetaobject.cpp:232
#25 0x009f5a6a in QMetaObject::activate (sender=0x98ca188, m=0xb16238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x009fd375 in QSingleShotTimer::timeout (this=0x98ca188) at .moc/release-shared/qtimer.moc:82
#27 0x009fd42c in QSingleShotTimer::timerEvent (this=0x98ca188) at kernel/qtimer.cpp:308
#28 0x009f8994 in QObject::event (this=0x98ca188, e=0xbfc1d4fc) at kernel/qobject.cpp:1181
#29 0x05f3ad84 in notify_helper (e=0xbfc1d4fc, receiver=0x98ca188, this=0x978b3a0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x978b3a0, receiver=0x98ca188, e=0xbfc1d4fc) at kernel/qapplication.cpp:4458
#31 0x05f40133 in QApplication::notify (this=0xbfc1d4fc, receiver=0x98ca188, e=0xbfc1d4fc) at kernel/qapplication.cpp:3886
#32 0x00ea3971 in KApplication::notify (this=0xbfc1d810, receiver=0x98ca188, event=0xbfc1d4fc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x009e019e in QCoreApplication::notifyInternal (this=0xbfc1d810, receiver=0x98ca188, event=0xbfc1d4fc) at kernel/qcoreapplication.cpp:787
#34 0x00a10c10 in sendEvent (event=0xbfc1d4fc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9788034) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00a0e122 in timerSourceDispatch (source=0x9788000) at kernel/qeventdispatcher_glib.cpp:184
#37 0x07b7025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x07b70990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x07b70c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00a0eada in QEventDispatcherGlib::processEvents (this=0x9769238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x05ff2e7a in QGuiEventDispatcherGlib::processEvents (this=0x9769238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x009df1dd in QEventLoop::processEvents (this=0xbfc1d774, flags=...) at kernel/qeventloop.cpp:149
#43 0x009df421 in QEventLoop::exec (this=0xbfc1d774, flags=...) at kernel/qeventloop.cpp:201
#44 0x009e419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x05f38924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294179, bug 294155, bug 294153, bug 294150, bug 294106.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-15 19:54:35 UTC

*** This bug has been marked as a duplicate of bug 291262 ***