Bug 294194 - Muon crashes in initialization
Summary: Muon crashes in initialization
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-15 23:29 UTC by Francisco
Modified: 2012-02-15 23:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco 2012-02-15 23:29:17 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
I just opened it through the kickoff menu and in the initialization fase it crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76fd930 (LWP 2034))]

Thread 2 (Thread 0xb5a1ab70 (LWP 2035)):
#0  0x006bb416 in __kernel_vsyscall ()
#1  0x04aa640e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x063d834b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x063c9896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x063c9c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00463b37 in QEventDispatcherGlib::processEvents (this=0xa07ea40, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x004341dd in QEventLoop::processEvents (this=0xb5a1a2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00434421 in QEventLoop::exec (this=0xb5a1a2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0033790b in QThread::exec (this=0xa112520) at thread/qthread.cpp:498
#9  0x00414e2d in QInotifyFileSystemWatcherEngine::run (this=0xa112520) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0033a7b3 in QThreadPrivate::start (arg=0xa112520) at thread/qthread_unix.cpp:331
#11 0x00576d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x04ab50ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb76fd930 (LWP 2034)):
[KCrash Handler]
#7  0x0038ee11 in QtPrivate::QStringList_contains (that=0xbfe3a414, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe3a414) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0xa112238) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0xa112238, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe3a634) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0043bb7d in metacall (argv=0xbfe3a634, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0xa112238) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0xa112238, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe3a634) at kernel/qmetaobject.cpp:232
#13 0x0044aa6a in QMetaObject::activate (sender=0xa1ace08, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0xa1ace08) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0xa1ace08, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe3a778) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0043bb7d in metacall (argv=0xbfe3a778, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0xa1ace08) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0xa1ace08, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe3a778) at kernel/qmetaobject.cpp:232
#18 0x0044aa6a in QMetaObject::activate (sender=0xa112238, m=0x80950c0, local_signal_index=0, argv=0xbfe3a778) at kernel/qobject.cpp:3278
#19 0x007337c5 in MuonMainWindow::backendReady (this=0xa112238, _t1=0xa185da8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00733933 in MuonMainWindow::initObject (this=0xa112238) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0xa112238) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0xa112238, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe3a8a4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0043bb7d in metacall (argv=0xbfe3a8a4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0xa112238) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0xa112238, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe3a8a4) at kernel/qmetaobject.cpp:232
#25 0x0044aa6a in QMetaObject::activate (sender=0xa17fd68, m=0x56b238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00452375 in QSingleShotTimer::timeout (this=0xa17fd68) at .moc/release-shared/qtimer.moc:82
#27 0x0045242c in QSingleShotTimer::timerEvent (this=0xa17fd68) at kernel/qtimer.cpp:308
#28 0x0044d994 in QObject::event (this=0xa17fd68, e=0xbfe3ac9c) at kernel/qobject.cpp:1181
#29 0x093f1d84 in notify_helper (e=0xbfe3ac9c, receiver=0xa17fd68, this=0xa024d40) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0xa024d40, receiver=0xa17fd68, e=0xbfe3ac9c) at kernel/qapplication.cpp:4458
#31 0x093f7133 in QApplication::notify (this=0xbfe3ac9c, receiver=0xa17fd68, e=0xbfe3ac9c) at kernel/qapplication.cpp:3886
#32 0x00f23971 in KApplication::notify (this=0xbfe3afb0, receiver=0xa17fd68, event=0xbfe3ac9c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0043519e in QCoreApplication::notifyInternal (this=0xbfe3afb0, receiver=0xa17fd68, event=0xbfe3ac9c) at kernel/qcoreapplication.cpp:787
#34 0x00465c10 in sendEvent (event=0xbfe3ac9c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0xa02193c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00463122 in timerSourceDispatch (source=0xa021908) at kernel/qeventdispatcher_glib.cpp:184
#37 0x063c925f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x063c9990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x063c9c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00463ada in QEventDispatcherGlib::processEvents (this=0xa003238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x094a9e7a in QGuiEventDispatcherGlib::processEvents (this=0xa003238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x004341dd in QEventLoop::processEvents (this=0xbfe3af14, flags=...) at kernel/qeventloop.cpp:149
#43 0x00434421 in QEventLoop::exec (this=0xbfe3af14, flags=...) at kernel/qeventloop.cpp:201
#44 0x0043919d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x093ef924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 294193.

Possible duplicates by query: bug 294193, bug 294181, bug 294180, bug 294179, bug 294155.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-15 23:44:22 UTC

*** This bug has been marked as a duplicate of bug 291262 ***