Bug 294193 - Muon crashes with apparently no reason
Summary: Muon crashes with apparently no reason
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-15 23:16 UTC by Fabrizio Silvestri
Modified: 2012-02-15 23:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabrizio Silvestri 2012-02-15 23:16:55 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
I was just opening Muon. I only had the browser (Chrome) and the terminal opened

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f844b3ca780 (LWP 2815))]

Thread 2 (Thread 0x7f84369a2700 (LWP 2819)):
#0  0x00007f8447f96773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f844480bf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f844480c429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f844a153f3e in QEventDispatcherGlib::processEvents (this=0x29484f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f844a127cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f844a127ef7 in QEventLoop::exec (this=0x7f84369a1dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f844a03f27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f844a10acbf in QInotifyFileSystemWatcherEngine::run (this=0x293ebc0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f844a041d05 in QThreadPrivate::start (arg=0x293ebc0) at thread/qthread_unix.cpp:331
#9  0x00007f84452edefc in start_thread (arg=0x7f84369a2700) at pthread_create.c:304
#10 0x00007f8447fa289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f844b3ca780 (LWP 2815)):
[KCrash Handler]
#6  0x00007f844a08fa5e in QtPrivate::QStringList_contains (that=0x7fff6bea1710, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff6bea1710) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x275a7e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x275a7e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6bea1ce0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f844a13beba in QMetaObject::activate (sender=0x2806210, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x2806210, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6bea1e40) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f844a13beba in QMetaObject::activate (sender=0x275a7e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6bea1e40) at kernel/qobject.cpp:3278
#13 0x00007f844afb1e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x27fa520) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f844afb1f8e in MuonMainWindow::initObject (this=0x275a7e0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x275a7e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x275a7e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6bea1f10) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f844a13beba in QMetaObject::activate (sender=0x27e4330, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f844a143f7f in QSingleShotTimer::timerEvent (this=0x27e4330) at kernel/qtimer.cpp:308
#19 0x00007f844a13f789 in QObject::event (this=0x27e4330, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f8448763424 in notify_helper (e=0x7fff6bea2480, receiver=0x27e4330, this=0x26182f0) at kernel/qapplication.cpp:4476
#21 QApplicationPrivate::notify_helper (this=0x26182f0, receiver=0x27e4330, e=0x7fff6bea2480) at kernel/qapplication.cpp:4458
#22 0x00007f8448768291 in QApplication::notify (this=0x7fff6bea2780, receiver=0x27e4330, e=0x7fff6bea2480) at kernel/qapplication.cpp:3858
#23 0x00007f8449947466 in KApplication::notify (this=0x7fff6bea2780, receiver=0x27e4330, event=0x7fff6bea2480) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f844a128afc in QCoreApplication::notifyInternal (this=0x7fff6bea2780, receiver=0x27e4330, event=0x7fff6bea2480) at kernel/qcoreapplication.cpp:787
#25 0x00007f844a155d62 in sendEvent (event=0x7fff6bea2480, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x261c9d0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f844a153514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f844480ba5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f844480c258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f844480c429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f844a153ed6 in QEventDispatcherGlib::processEvents (this=0x25f36f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f844880b07e in QGuiEventDispatcherGlib::~QGuiEventDispatcherGlib (this=0x0, __in_chrg=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:195
#33 0x0000000002807a70 in ?? ()
#34 0x00007fff6bea26d0 in ?? ()
#35 0x00007f844a127cf2 in QEventLoop::processEvents (this=<optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007f844a127ef7 in QEventLoop::exec (this=0x7fff6bea2710, flags=...) at kernel/qeventloop.cpp:201
#37 0x00007f844a12c789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#38 0x000000000041bd67 in main (argc=1, argv=0x7fff6bea29f8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294181, bug 294180, bug 294179, bug 294155, bug 294153.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-15 23:44:10 UTC

*** This bug has been marked as a duplicate of bug 291262 ***