Bug 294202 - software center crash
Summary: software center crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-16 02:05 UTC by skildude
Modified: 2012-02-16 06:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description skildude 2012-02-16 02:05:08 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: attempted startup of software center.  app started then immediately shut down.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7755665780 (LWP 11967))]

Thread 2 (Thread 0x7f7740dfd700 (LWP 11971)):
#0  0x00007f7752238773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f774eaadf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f774eaae429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f77543f6f3e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f77543cacf2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f77543caef7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f77542e227f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f77543adcbf in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007f77542e4d05 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f774f58fefc in start_thread (arg=0x7f7740dfd700) at pthread_create.c:304
#10 0x00007f775224489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7755665780 (LWP 11967)):
[KCrash Handler]
#6  0x00007f7754332a5e in QtPrivate::QStringList_contains(QStringList const*, QString const&, Qt::CaseSensitivity) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff153a5140) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x9e5880) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x9e5880, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff153a5710) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f77543deeba in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xa856d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff153a5870) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f77543deeba in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#13 0x00007f7755254e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xa70ab0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f7755254f8e in MuonMainWindow::initObject (this=0x9e5880) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x9e5880) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x9e5880, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff153a5940) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f77543deeba in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#18 0x00007f77543e6f7f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#19 0x00007f77543e2789 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#20 0x00007f7752a05474 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#21 0x00007f7752a0a2e1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#22 0x00007f7753bea466 in KApplication::notify (this=0x7fff153a61b0, receiver=0xa863a0, event=0x7fff153a5eb0) at ../../kdeui/kernel/kapplication.cpp:311
#23 0x00007f77543cbafc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#24 0x00007f77543f8d62 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#25 0x00007f77543f6514 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#26 0x00007f774eaada5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f774eaae258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f774eaae429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f77543f6ed6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#30 0x00007f7752aad10e in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#31 0x00007f77543cacf2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#32 0x00007f77543caef7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#33 0x00007f77543cf789 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#34 0x000000000041bd67 in main (argc=1, argv=0x7fff153a6428) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294194, bug 294193, bug 294181, bug 294180, bug 294179.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-16 06:22:35 UTC

*** This bug has been marked as a duplicate of bug 291262 ***