Bug 294341 - Muon (Installer) crashes while starting
Summary: Muon (Installer) crashes while starting
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 08:44 UTC by Stefan Streif
Modified: 2012-02-18 08:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Streif 2012-02-18 08:44:19 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I have started Muon (Installer). It crashes everytime while starting.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f3026724780 (LWP 9437))]

Thread 2 (Thread 0x7f301177a700 (LWP 9438)):
#0  0x00007f30232ff773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f301fb74f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f301fb75429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f30254bdf3e in QEventDispatcherGlib::processEvents (this=0x7f300c0008b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f3025491cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f3025491ef7 in QEventLoop::exec (this=0x7f3011779dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f30253a927f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f3025474cbf in QInotifyFileSystemWatcherEngine::run (this=0x2546980) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f30253abd05 in QThreadPrivate::start (arg=0x2546980) at thread/qthread_unix.cpp:331
#9  0x00007f3020656efc in start_thread (arg=0x7f301177a700) at pthread_create.c:304
#10 0x00007f302330b89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3026724780 (LWP 9437)):
[KCrash Handler]
#6  0x00007f30253f9a5e in QtPrivate::QStringList_contains (that=0x7fff90b3dd90, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff90b3dd90) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x2520730) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x2520730, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff90b3e360) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f30254a5eba in QMetaObject::activate (sender=0x25c7bd0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x25c7bd0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff90b3e4c0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f30254a5eba in QMetaObject::activate (sender=0x2520730, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff90b3e4c0) at kernel/qobject.cpp:3278
#13 0x00007f302631be7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x2584570) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f302631bf8e in MuonMainWindow::initObject (this=0x2520730) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x2520730) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x2520730, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff90b3e590) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f30254a5eba in QMetaObject::activate (sender=0x25d51f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f30254adf7f in QSingleShotTimer::timerEvent (this=0x25d51f0) at kernel/qtimer.cpp:308
#19 0x00007f30254a9789 in QObject::event (this=0x25d51f0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f3023acc474 in notify_helper (e=0x7fff90b3eb00, receiver=0x25d51f0, this=0x23a7900) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x23a7900, receiver=0x25d51f0, e=0x7fff90b3eb00) at kernel/qapplication.cpp:4458
#22 0x00007f3023ad12e1 in QApplication::notify (this=0x7fff90b3ee00, receiver=0x25d51f0, e=0x7fff90b3eb00) at kernel/qapplication.cpp:4365
#23 0x00007f3024cb1466 in KApplication::notify (this=0x7fff90b3ee00, receiver=0x25d51f0, event=0x7fff90b3eb00) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f3025492afc in QCoreApplication::notifyInternal (this=0x7fff90b3ee00, receiver=0x25d51f0, event=0x7fff90b3eb00) at kernel/qcoreapplication.cpp:787
#25 0x00007f30254bfd62 in sendEvent (event=0x7fff90b3eb00, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x23a54e0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f30254bd514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f301fb74a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f301fb75258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f301fb75429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f30254bded6 in QEventDispatcherGlib::processEvents (this=0x237e6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f3023b7410e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f3025491cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f3025491ef7 in QEventLoop::exec (this=0x7fff90b3ed90, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f3025496789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fff90b3f078) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294328, bug 294202, bug 294194, bug 294193, bug 294181.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-18 08:53:17 UTC

*** This bug has been marked as a duplicate of bug 291262 ***