Bug 294328 - Muon Software Center Crash after opening
Summary: Muon Software Center Crash after opening
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 01:05 UTC by Brian
Modified: 2012-02-18 01:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian 2012-02-18 01:05:37 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I Tried to startup Muon Software Center then saw the interface for 1 second, then it just crashed right away

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77cf930 (LWP 3947))]

Thread 2 (Thread 0xb5972b70 (LWP 3951)):
#0  0x00aced10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x0056f7d5 in do_gettime (frac=0xb5972020, sec=0xb5972018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x006424b6 in QTimerInfoList::updateCurrentTime (this=0x8deb894) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0064280a in QTimerInfoList::timerWait (this=0x8deb894, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00641053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb597212c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x006410ed in timerSourcePrepare (source=0x8deb860, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0145e88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x0145f637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x0145fc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00641b37 in QEventDispatcherGlib::processEvents (this=0x8c0b928, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x006121dd in QEventLoop::processEvents (this=0xb59722b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00612421 in QEventLoop::exec (this=0xb59722b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0051590b in QThread::exec (this=0x8d2d498) at thread/qthread.cpp:498
#14 0x005f2e2d in QInotifyFileSystemWatcherEngine::run (this=0x8d2d498) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x005187b3 in QThreadPrivate::start (arg=0x8d2d498) at thread/qthread_unix.cpp:331
#16 0x00ab0d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x04aa70ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77cf930 (LWP 3947)):
[KCrash Handler]
#7  0x0056ce11 in QtPrivate::QStringList_contains (that=0xbf89d424, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf89d424) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8c8a228) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8c8a228, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf89d644) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00619b7d in metacall (argv=0xbf89d644, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8c8a228) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8c8a228, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf89d644) at kernel/qmetaobject.cpp:232
#13 0x00628a6a in QMetaObject::activate (sender=0x8c768d0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8c768d0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8c768d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf89d788) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00619b7d in metacall (argv=0xbf89d788, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8c768d0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8c768d0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf89d788) at kernel/qmetaobject.cpp:232
#18 0x00628a6a in QMetaObject::activate (sender=0x8c8a228, m=0x80950c0, local_signal_index=0, argv=0xbf89d788) at kernel/qobject.cpp:3278
#19 0x004797c5 in MuonMainWindow::backendReady (this=0x8c8a228, _t1=0x8d03530) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00479933 in MuonMainWindow::initObject (this=0x8c8a228) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8c8a228) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8c8a228, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf89d8b4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00619b7d in metacall (argv=0xbf89d8b4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8c8a228) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8c8a228, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf89d8b4) at kernel/qmetaobject.cpp:232
#25 0x00628a6a in QMetaObject::activate (sender=0x8d03b30, m=0x749238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00630375 in QSingleShotTimer::timeout (this=0x8d03b30) at .moc/release-shared/qtimer.moc:82
#27 0x0063042c in QSingleShotTimer::timerEvent (this=0x8d03b30) at kernel/qtimer.cpp:308
#28 0x0062b994 in QObject::event (this=0x8d03b30, e=0xbf89dcac) at kernel/qobject.cpp:1181
#29 0x06ea3d84 in notify_helper (e=0xbf89dcac, receiver=0x8d03b30, this=0x8b90670) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8b90670, receiver=0x8d03b30, e=0xbf89dcac) at kernel/qapplication.cpp:4458
#31 0x06ea9133 in QApplication::notify (this=0xbf89dcac, receiver=0x8d03b30, e=0xbf89dcac) at kernel/qapplication.cpp:3886
#32 0x011c9971 in KApplication::notify (this=0xbf89dfc0, receiver=0x8d03b30, event=0xbf89dcac) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0061319e in QCoreApplication::notifyInternal (this=0xbf89dfc0, receiver=0x8d03b30, event=0xbf89dcac) at kernel/qcoreapplication.cpp:787
#34 0x00643c10 in sendEvent (event=0xbf89dcac, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8b92f04) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00641122 in timerSourceDispatch (source=0x8b92ed0) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0145f25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x0145f990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x0145fc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00641ada in QEventDispatcherGlib::processEvents (this=0x8b6e238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x06f5be7a in QGuiEventDispatcherGlib::processEvents (this=0x8b6e238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x006121dd in QEventLoop::processEvents (this=0xbf89df24, flags=...) at kernel/qeventloop.cpp:149
#43 0x00612421 in QEventLoop::exec (this=0xbf89df24, flags=...) at kernel/qeventloop.cpp:201
#44 0x0061719d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x06ea1924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294202, bug 294194, bug 294193, bug 294181, bug 294180.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-18 01:10:03 UTC

*** This bug has been marked as a duplicate of bug 291262 ***