Bug 294150 - fault Muon
Summary: fault Muon
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-15 13:52 UTC by Armando Palla
Modified: 2012-02-15 14:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Armando Palla 2012-02-15 13:52:55 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Fault Muon - Ao tentar executar deu falha e não entrou.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7727930 (LWP 3155))]

Thread 2 (Thread 0xb582eb70 (LWP 3156)):
#0  0x007d9d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00b697d5 in do_gettime (frac=0xb582e020, sec=0xb582e018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00c3c4b6 in QTimerInfoList::updateCurrentTime (this=0x82e094c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00c3c80a in QTimerInfoList::timerWait (this=0x82e094c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00c3b053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb582e12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00c3b0ed in timerSourcePrepare (source=0x82e0918, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x06cd688c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x06cd7637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x06cd7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00c3bb37 in QEventDispatcherGlib::processEvents (this=0x81e9108, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00c0c1dd in QEventLoop::processEvents (this=0xb582e2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00c0c421 in QEventLoop::exec (this=0xb582e2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00b0f90b in QThread::exec (this=0x8290850) at thread/qthread.cpp:498
#14 0x00bece2d in QInotifyFileSystemWatcherEngine::run (this=0x8290850) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00b127b3 in QThreadPrivate::start (arg=0x8290850) at thread/qthread_unix.cpp:331
#16 0x007a6d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0066f0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7727930 (LWP 3155)):
[KCrash Handler]
#7  0x00b66e11 in QtPrivate::QStringList_contains (that=0xbf94ec04, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf94ec04) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8270230) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8270230, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf94ee24) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00c13b7d in metacall (argv=0xbf94ee24, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8270230) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8270230, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf94ee24) at kernel/qmetaobject.cpp:232
#13 0x00c22a6a in QMetaObject::activate (sender=0x82ea620, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x82ea620) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x82ea620, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf94ef68) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00c13b7d in metacall (argv=0xbf94ef68, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x82ea620) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x82ea620, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf94ef68) at kernel/qmetaobject.cpp:232
#18 0x00c22a6a in QMetaObject::activate (sender=0x8270230, m=0x80950c0, local_signal_index=0, argv=0xbf94ef68) at kernel/qobject.cpp:3278
#19 0x002c37c5 in MuonMainWindow::backendReady (this=0x8270230, _t1=0x82e1c98) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x002c3933 in MuonMainWindow::initObject (this=0x8270230) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8270230) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8270230, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf94f094) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00c13b7d in metacall (argv=0xbf94f094, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8270230) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8270230, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf94f094) at kernel/qmetaobject.cpp:232
#25 0x00c22a6a in QMetaObject::activate (sender=0x82b75a0, m=0xd43238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00c2a375 in QSingleShotTimer::timeout (this=0x82b75a0) at .moc/release-shared/qtimer.moc:82
#27 0x00c2a42c in QSingleShotTimer::timerEvent (this=0x82b75a0) at kernel/qtimer.cpp:308
#28 0x00c25994 in QObject::event (this=0x82b75a0, e=0xbf94f48c) at kernel/qobject.cpp:1181
#29 0x0370bd84 in notify_helper (e=0xbf94f48c, receiver=0x82b75a0, this=0x8156478) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8156478, receiver=0x82b75a0, e=0xbf94f48c) at kernel/qapplication.cpp:4458
#31 0x03711133 in QApplication::notify (this=0xbf94f48c, receiver=0x82b75a0, e=0xbf94f48c) at kernel/qapplication.cpp:3886
#32 0x01126971 in KApplication::notify (this=0xbf94f7a0, receiver=0x82b75a0, event=0xbf94f48c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00c0d19e in QCoreApplication::notifyInternal (this=0xbf94f7a0, receiver=0x82b75a0, event=0xbf94f48c) at kernel/qcoreapplication.cpp:787
#34 0x00c3dc10 in sendEvent (event=0xbf94f48c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8157b64) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00c3b122 in timerSourceDispatch (source=0x8157b30) at kernel/qeventdispatcher_glib.cpp:184
#37 0x06cd725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x06cd7990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x06cd7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00c3bada in QEventDispatcherGlib::processEvents (this=0x8139238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x037c3e7a in QGuiEventDispatcherGlib::processEvents (this=0x8139238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00c0c1dd in QEventLoop::processEvents (this=0xbf94f704, flags=...) at kernel/qeventloop.cpp:149
#43 0x00c0c421 in QEventLoop::exec (this=0xbf94f704, flags=...) at kernel/qeventloop.cpp:201
#44 0x00c1119d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x03709924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294106, bug 294101, bug 294068, bug 294024, bug 294023.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-15 14:14:29 UTC

*** This bug has been marked as a duplicate of bug 291262 ***