Bug 294106 - muon crash
Summary: muon crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-14 21:43 UTC by jonny amrques
Modified: 2012-02-14 21:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jonny amrques 2012-02-14 21:43:59 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
when I try open aplication manager , it just crash all the time

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7873930 (LWP 5479))]

Thread 2 (Thread 0xb5958b70 (LWP 5480)):
#0  0x00abdd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x0025e7d5 in do_gettime (frac=0xb5958020, sec=0xb5958018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x003314b6 in QTimerInfoList::updateCurrentTime (this=0x8a8786c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0033180a in QTimerInfoList::timerWait (this=0x8a8786c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00330053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb595812c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x003300ed in timerSourcePrepare (source=0x8a87838, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0123888c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x01239637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x01239c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00330b37 in QEventDispatcherGlib::processEvents (this=0x897d448, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x003011dd in QEventLoop::processEvents (this=0xb59582b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00301421 in QEventLoop::exec (this=0xb59582b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0020490b in QThread::exec (this=0x8a49618) at thread/qthread.cpp:498
#14 0x002e1e2d in QInotifyFileSystemWatcherEngine::run (this=0x8a49618) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x002077b3 in QThreadPrivate::start (arg=0x8a49618) at thread/qthread_unix.cpp:331
#16 0x00be7d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00a100ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7873930 (LWP 5479)):
[KCrash Handler]
#7  0x0025be11 in QtPrivate::QStringList_contains (that=0xbfe63c14, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe63c14) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8a4b690) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8a4b690, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe63e34) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00308b7d in metacall (argv=0xbfe63e34, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8a4b690) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8a4b690, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe63e34) at kernel/qmetaobject.cpp:232
#13 0x00317a6a in QMetaObject::activate (sender=0x8a9f818, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8a9f818) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8a9f818, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe63f78) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00308b7d in metacall (argv=0xbfe63f78, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8a9f818) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8a9f818, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe63f78) at kernel/qmetaobject.cpp:232
#18 0x00317a6a in QMetaObject::activate (sender=0x8a4b690, m=0x80950c0, local_signal_index=0, argv=0xbfe63f78) at kernel/qobject.cpp:3278
#19 0x001687c5 in MuonMainWindow::backendReady (this=0x8a4b690, _t1=0x8aa6f48) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00168933 in MuonMainWindow::initObject (this=0x8a4b690) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8a4b690) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8a4b690, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe640a4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00308b7d in metacall (argv=0xbfe640a4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8a4b690) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8a4b690, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe640a4) at kernel/qmetaobject.cpp:232
#25 0x00317a6a in QMetaObject::activate (sender=0x8a898d8, m=0x438238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0031f375 in QSingleShotTimer::timeout (this=0x8a898d8) at .moc/release-shared/qtimer.moc:82
#27 0x0031f42c in QSingleShotTimer::timerEvent (this=0x8a898d8) at kernel/qtimer.cpp:308
#28 0x0031a994 in QObject::event (this=0x8a898d8, e=0xbfe6449c) at kernel/qobject.cpp:1181
#29 0x05708d84 in notify_helper (e=0xbfe6449c, receiver=0x8a898d8, this=0x8977de8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8977de8, receiver=0x8a898d8, e=0xbfe6449c) at kernel/qapplication.cpp:4458
#31 0x0570e133 in QApplication::notify (this=0xbfe6449c, receiver=0x8a898d8, e=0xbfe6449c) at kernel/qapplication.cpp:3886
#32 0x00f25971 in KApplication::notify (this=0xbfe647b0, receiver=0x8a898d8, event=0xbfe6449c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0030219e in QCoreApplication::notifyInternal (this=0xbfe647b0, receiver=0x8a898d8, event=0xbfe6449c) at kernel/qcoreapplication.cpp:787
#34 0x00332c10 in sendEvent (event=0xbfe6449c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x897a704) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00330122 in timerSourceDispatch (source=0x897a6d0) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0123925f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01239990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01239c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00330ada in QEventDispatcherGlib::processEvents (this=0x895b238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x057c0e7a in QGuiEventDispatcherGlib::processEvents (this=0x895b238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x003011dd in QEventLoop::processEvents (this=0xbfe64714, flags=...) at kernel/qeventloop.cpp:149
#43 0x00301421 in QEventLoop::exec (this=0xbfe64714, flags=...) at kernel/qeventloop.cpp:201
#44 0x0030619d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x05706924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294101, bug 294068, bug 294024, bug 294023, bug 293940.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-14 21:54:39 UTC

*** This bug has been marked as a duplicate of bug 291262 ***