Bug 294101 - error after update
Summary: error after update
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-14 21:03 UTC by david
Modified: 2012-02-14 21:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description david 2012-02-14 21:03:52 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
was opening the software center Muon
- Custom settings of the application:
Package installation flash:flashplugin-downloader_11.1.102.55ubuntu0.11.10.1_i386,flashplugin-installer_11.1.102.55ubuntu0.11.10.1_i386

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76df930 (LWP 1749))]

Thread 2 (Thread 0xb5517b70 (LWP 1750)):
#0  0x00c1ed10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x005bd7d5 in do_gettime (frac=0xb5517020, sec=0xb5517018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x006904b6 in QTimerInfoList::updateCurrentTime (this=0x9ad609c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0069080a in QTimerInfoList::timerWait (this=0x9ad609c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0068f053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb551712c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0068f0ed in timerSourcePrepare (source=0x9ad6068, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0126f88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x01270637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x01270c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x0068fb37 in QEventDispatcherGlib::processEvents (this=0x9ab5f58, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x006601dd in QEventLoop::processEvents (this=0xb55172b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00660421 in QEventLoop::exec (this=0xb55172b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0056390b in QThread::exec (this=0x9a57878) at thread/qthread.cpp:498
#14 0x00640e2d in QInotifyFileSystemWatcherEngine::run (this=0x9a57878) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x005667b3 in QThreadPrivate::start (arg=0x9a57878) at thread/qthread_unix.cpp:331
#16 0x00c06d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0179d0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb76df930 (LWP 1749)):
[KCrash Handler]
#7  0x005bae11 in QtPrivate::QStringList_contains (that=0xbfc17034, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc17034) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9a41890) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9a41890, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc17254) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00667b7d in metacall (argv=0xbfc17254, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9a41890) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9a41890, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfc17254) at kernel/qmetaobject.cpp:232
#13 0x00676a6a in QMetaObject::activate (sender=0x9adc1d0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9adc1d0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9adc1d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc17398) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00667b7d in metacall (argv=0xbfc17398, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9adc1d0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9adc1d0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfc17398) at kernel/qmetaobject.cpp:232
#18 0x00676a6a in QMetaObject::activate (sender=0x9a41890, m=0x80950c0, local_signal_index=0, argv=0xbfc17398) at kernel/qobject.cpp:3278
#19 0x00f307c5 in MuonMainWindow::backendReady (this=0x9a41890, _t1=0x9a5c868) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00f30933 in MuonMainWindow::initObject (this=0x9a41890) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9a41890) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9a41890, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc174c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00667b7d in metacall (argv=0xbfc174c4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9a41890) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9a41890, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfc174c4) at kernel/qmetaobject.cpp:232
#25 0x00676a6a in QMetaObject::activate (sender=0x9ab48a8, m=0x797238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0067e375 in QSingleShotTimer::timeout (this=0x9ab48a8) at .moc/release-shared/qtimer.moc:82
#27 0x0067e42c in QSingleShotTimer::timerEvent (this=0x9ab48a8) at kernel/qtimer.cpp:308
#28 0x00679994 in QObject::event (this=0x9ab48a8, e=0xbfc178bc) at kernel/qobject.cpp:1181
#29 0x03a0cd84 in notify_helper (e=0xbfc178bc, receiver=0x9ab48a8, this=0x9935268) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9935268, receiver=0x9ab48a8, e=0xbfc178bc) at kernel/qapplication.cpp:4458
#31 0x03a12133 in QApplication::notify (this=0xbfc178bc, receiver=0x9ab48a8, e=0xbfc178bc) at kernel/qapplication.cpp:3886
#32 0x00983971 in KApplication::notify (this=0xbfc17bd0, receiver=0x9ab48a8, event=0xbfc178bc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0066119e in QCoreApplication::notifyInternal (this=0xbfc17bd0, receiver=0x9ab48a8, event=0xbfc178bc) at kernel/qcoreapplication.cpp:787
#34 0x00691c10 in sendEvent (event=0xbfc178bc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x992fe7c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0068f122 in timerSourceDispatch (source=0x992fe48) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0127025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01270990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01270c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0068fada in QEventDispatcherGlib::processEvents (this=0x9913238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x03ac4e7a in QGuiEventDispatcherGlib::processEvents (this=0x9913238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x006601dd in QEventLoop::processEvents (this=0xbfc17b34, flags=...) at kernel/qeventloop.cpp:149
#43 0x00660421 in QEventLoop::exec (this=0xbfc17b34, flags=...) at kernel/qeventloop.cpp:201
#44 0x0066519d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x03a0a924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294068, bug 294024, bug 294023, bug 293940, bug 293938.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-14 21:08:08 UTC

*** This bug has been marked as a duplicate of bug 291262 ***