Bug 293503 - Muon Software center does not work
Summary: Muon Software center does not work
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-07 04:53 UTC by db
Modified: 2012-02-07 05:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description db 2012-02-07 04:53:36 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Just installed the system 
muon crashed during the pakages install I did the fillowing :
sudo fuser -vki /var/lib/dpkg/lock
sudo dpkg --configure -a
sudo apt-get upgrade

than tried to open the software center which no longer works

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f08d6e4c780 (LWP 1968))]

Thread 2 (Thread 0x7f08c2421700 (LWP 1972)):
#0  0x00007f08d3a12773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f08d0287f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f08d0288429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f08d5bd0f3e in QEventDispatcherGlib::processEvents (this=0x1681c30, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f08d5ba4cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f08d5ba4ef7 in QEventLoop::exec (this=0x7f08c2420dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f08d5abc27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f08d5b87cbf in QInotifyFileSystemWatcherEngine::run (this=0x1504cd0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f08d5abed05 in QThreadPrivate::start (arg=0x1504cd0) at thread/qthread_unix.cpp:331
#9  0x00007f08d0d69efc in start_thread (arg=0x7f08c2421700) at pthread_create.c:304
#10 0x00007f08d3a1e89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f08d6e4c780 (LWP 1968)):
[KCrash Handler]
#6  0x00007f08d5b0ca5e in QtPrivate::QStringList_contains (that=0x7fff4ca77290, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff4ca77290) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x14b9fa0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x14b9fa0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff4ca77860) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f08d5bb8eba in QMetaObject::activate (sender=0x154ce00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x154ce00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff4ca779c0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f08d5bb8eba in QMetaObject::activate (sender=0x14b9fa0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff4ca779c0) at kernel/qobject.cpp:3278
#13 0x00007f08d6a2ee7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1516650) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f08d6a2ef8e in MuonMainWindow::initObject (this=0x14b9fa0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x14b9fa0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x14b9fa0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff4ca77a90) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f08d5bb8eba in QMetaObject::activate (sender=0x1526cb0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f08d5bc0f7f in QSingleShotTimer::timerEvent (this=0x1526cb0) at kernel/qtimer.cpp:308
#19 0x00007f08d5bbc789 in QObject::event (this=0x1526cb0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f08d41df474 in notify_helper (e=0x7fff4ca78000, receiver=0x1526cb0, this=0x136e300) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x136e300, receiver=0x1526cb0, e=0x7fff4ca78000) at kernel/qapplication.cpp:4458
#22 0x00007f08d41e42e1 in QApplication::notify (this=0x7fff4ca78300, receiver=0x1526cb0, e=0x7fff4ca78000) at kernel/qapplication.cpp:4365
#23 0x00007f08d53c4466 in KApplication::notify (this=0x7fff4ca78300, receiver=0x1526cb0, event=0x7fff4ca78000) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f08d5ba5afc in QCoreApplication::notifyInternal (this=0x7fff4ca78300, receiver=0x1526cb0, event=0x7fff4ca78000) at kernel/qcoreapplication.cpp:787
#25 0x00007f08d5bd2d62 in sendEvent (event=0x7fff4ca78000, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x13697f0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f08d5bd0538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007f08d0287a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f08d0288258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f08d0288429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f08d5bd0ed6 in QEventDispatcherGlib::processEvents (this=0x13466f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f08d428710e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f08d5ba4cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f08d5ba4ef7 in QEventLoop::exec (this=0x7fff4ca78290, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f08d5ba9789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=5, argv=0x7fff4ca78578) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 293451, bug 293422, bug 293401, bug 293400, bug 293373.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-07 05:58:59 UTC

*** This bug has been marked as a duplicate of bug 291262 ***