Bug 293451 - muon software center crash
Summary: muon software center crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-06 14:35 UTC by suhas
Modified: 2012-02-06 14:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description suhas 2012-02-06 14:35:05 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

nothing else
i just opened the muon software centre and it crashed

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7719930 (LWP 1699))]

Thread 2 (Thread 0xb589cb70 (LWP 1703)):
#0  0x00e51ef1 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#1  0x0838470b in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x08385637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x08385c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0054ab37 in QEventDispatcherGlib::processEvents (this=0x8d9ccb8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x0051b1dd in QEventLoop::processEvents (this=0xb589c2b0, flags=...) at kernel/qeventloop.cpp:149
#6  0x0051b421 in QEventLoop::exec (this=0xb589c2b0, flags=...) at kernel/qeventloop.cpp:201
#7  0x0041e90b in QThread::exec (this=0x8ec6ee8) at thread/qthread.cpp:498
#8  0x004fbe2d in QInotifyFileSystemWatcherEngine::run (this=0x8ec6ee8) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x004217b3 in QThreadPrivate::start (arg=0x8ec6ee8) at thread/qthread_unix.cpp:331
#10 0x00b69d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x00e440ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7719930 (LWP 1699)):
[KCrash Handler]
#7  0x00475e11 in QtPrivate::QStringList_contains (that=0xbfa135f4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfa135f4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8df2178) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8df2178, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa13814) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00522b7d in metacall (argv=0xbfa13814, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8df2178) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8df2178, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfa13814) at kernel/qmetaobject.cpp:232
#13 0x00531a6a in QMetaObject::activate (sender=0x8e75d88, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8e75d88) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8e75d88, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa13958) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00522b7d in metacall (argv=0xbfa13958, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8e75d88) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8e75d88, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfa13958) at kernel/qmetaobject.cpp:232
#18 0x00531a6a in QMetaObject::activate (sender=0x8df2178, m=0x80950c0, local_signal_index=0, argv=0xbfa13958) at kernel/qobject.cpp:3278
#19 0x008667c5 in MuonMainWindow::backendReady (this=0x8df2178, _t1=0x8df00e0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00866933 in MuonMainWindow::initObject (this=0x8df2178) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8df2178) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8df2178, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa13a84) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00522b7d in metacall (argv=0xbfa13a84, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8df2178) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8df2178, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfa13a84) at kernel/qmetaobject.cpp:232
#25 0x00531a6a in QMetaObject::activate (sender=0x8e8f8d0, m=0x652238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00539375 in QSingleShotTimer::timeout (this=0x8e8f8d0) at .moc/release-shared/qtimer.moc:82
#27 0x0053942c in QSingleShotTimer::timerEvent (this=0x8e8f8d0) at kernel/qtimer.cpp:308
#28 0x00534994 in QObject::event (this=0x8e8f8d0, e=0xbfa13e7c) at kernel/qobject.cpp:1181
#29 0x0156ad84 in notify_helper (e=0xbfa13e7c, receiver=0x8e8f8d0, this=0x8d55ab0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8d55ab0, receiver=0x8e8f8d0, e=0xbfa13e7c) at kernel/qapplication.cpp:4458
#31 0x01570133 in QApplication::notify (this=0xbfa13e7c, receiver=0x8e8f8d0, e=0xbfa13e7c) at kernel/qapplication.cpp:3886
#32 0x011c0971 in KApplication::notify (this=0xbfa14190, receiver=0x8e8f8d0, event=0xbfa13e7c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0051c19e in QCoreApplication::notifyInternal (this=0xbfa14190, receiver=0x8e8f8d0, event=0xbfa13e7c) at kernel/qcoreapplication.cpp:787
#34 0x0054cc10 in sendEvent (event=0xbfa13e7c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8d53134) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0054a122 in timerSourceDispatch (source=0x8d53100) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0838525f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x08385990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x08385c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0054aada in QEventDispatcherGlib::processEvents (this=0x8d33238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x01622e7a in QGuiEventDispatcherGlib::processEvents (this=0x8d33238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0051b1dd in QEventLoop::processEvents (this=0xbfa140f4, flags=...) at kernel/qeventloop.cpp:149
#43 0x0051b421 in QEventLoop::exec (this=0xbfa140f4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0052019d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x01568924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 293422, bug 293401, bug 293400, bug 293373, bug 293372.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-06 14:40:35 UTC

*** This bug has been marked as a duplicate of bug 291262 ***