Bug 293118 - muon software centre crash
Summary: muon software centre crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-02 07:14 UTC by Albert Solernou
Modified: 2012-02-02 07:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Solernou 2012-02-02 07:14:03 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I had VMWare player (version 7, 64 bit) up and running windows 7. K3B, firefox, and dolphin were also open. Finally, I was connected to a VPN network through CISCO VPN.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc09fe48780 (LWP 3320))]

Thread 2 (Thread 0x7fc088eef700 (LWP 3326)):
#0  0x00007fc09ca20773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fc099295f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc099296429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc09ebdef3e in QEventDispatcherGlib::processEvents (this=0x2728520, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fc09ebb2cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc09ebb2ef7 in QEventLoop::exec (this=0x7fc088eeedd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fc09eaca27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fc09eb95cbf in QInotifyFileSystemWatcherEngine::run (this=0x2541b90) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fc09eaccd05 in QThreadPrivate::start (arg=0x2541b90) at thread/qthread_unix.cpp:331
#9  0x00007fc099d77efc in start_thread (arg=0x7fc088eef700) at pthread_create.c:304
#10 0x00007fc09ca2c89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc09fe48780 (LWP 3320)):
[KCrash Handler]
#6  0x00007fc09eb1aa5e in QtPrivate::QStringList_contains (that=0x7fff056763e0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff056763e0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x2698c70) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x2698c70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff056769b0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fc09ebc6eba in QMetaObject::activate (sender=0x2670aa0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x2670aa0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff05676b10) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fc09ebc6eba in QMetaObject::activate (sender=0x2698c70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff05676b10) at kernel/qobject.cpp:3278
#13 0x00007fc09fa3ce7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x26ef290) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fc09fa3cf8e in MuonMainWindow::initObject (this=0x2698c70) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x2698c70) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x2698c70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff05676be0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fc09ebc6eba in QMetaObject::activate (sender=0x27557b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fc09ebcef7f in QSingleShotTimer::timerEvent (this=0x27557b0) at kernel/qtimer.cpp:308
#19 0x00007fc09ebca789 in QObject::event (this=0x27557b0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fc09d1ed474 in notify_helper (e=0x7fff05677150, receiver=0x27557b0, this=0x2500130) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x2500130, receiver=0x27557b0, e=0x7fff05677150) at kernel/qapplication.cpp:4458
#22 0x00007fc09d1f22e1 in QApplication::notify (this=0x7fff05677450, receiver=0x27557b0, e=0x7fff05677150) at kernel/qapplication.cpp:4365
#23 0x00007fc09e3d2466 in KApplication::notify (this=0x7fff05677450, receiver=0x27557b0, event=0x7fff05677150) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fc09ebb3afc in QCoreApplication::notifyInternal (this=0x7fff05677450, receiver=0x27557b0, event=0x7fff05677150) at kernel/qcoreapplication.cpp:787
#25 0x00007fc09ebe0d62 in sendEvent (event=0x7fff05677150, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x24fc560) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fc09ebde514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fc099295a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fc099296258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fc099296429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fc09ebdeed6 in QEventDispatcherGlib::processEvents (this=0x24d66f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fc09d29510e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fc09ebb2cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fc09ebb2ef7 in QEventLoop::exec (this=0x7fff056773e0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fc09ebb7789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff056776c8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293113, bug 293102, bug 293080, bug 293071, bug 293037.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-02 07:37:53 UTC

*** This bug has been marked as a duplicate of bug 291262 ***