Bug 293102 - Muon Software Center crash on startup - window visible for fraction of second only.
Summary: Muon Software Center crash on startup - window visible for fraction of second...
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-02 00:05 UTC by Scott Wade
Modified: 2012-02-02 06:05 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.36 KB, text/plain)
2012-02-02 02:32 UTC, zaca
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Wade 2012-02-02 00:05:20 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:starting muon software center to check for package problems.  (Probably unrelated: firefox left-mouse button behavior is inconsistent on webpages)

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76fc710 (LWP 2000))]

Thread 2 (Thread 0xb44abb70 (LWP 2009)):
#0  0x06e73cca in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x06e748f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x06e74c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x006a8b37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#4  0x006791dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#5  0x00679421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#6  0x0057c90b in QThread::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#7  0x00659e2d in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#8  0x0057f7b3 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#9  0x008a6d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x03e740ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb76fc710 (LWP 2000)):
[KCrash Handler]
#7  0x005d3e11 in QtPrivate::QStringList_contains(QStringList const*, QString const&, Qt::CaseSensitivity) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf9678d4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x83d03f8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x83d03f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf967af4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00680b7d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#12 0x0068fa6a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#13 0x0805de57 in ApplicationBackend::appBackendReady (this=0x84294f8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#14 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x84294f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf967c38) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#15 0x00680b7d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#16 0x0068fa6a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#17 0x00d3d7c5 in MuonMainWindow::backendReady (this=0x83d03f8, _t1=0x8453048) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#18 0x00d3d933 in MuonMainWindow::initObject (this=0x83d03f8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#19 0x080654fc in ApplicationWindow::initObject (this=0x83d03f8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#20 0x0806a09f in ApplicationWindow::qt_metacall (this=0x83d03f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf967d64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#21 0x00680b7d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#22 0x0068fa6a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#23 0x00697375 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#24 0x0069742c in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#25 0x00692994 in QObject::event(QEvent*) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#26 0x0621ad54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#27 0x06220103 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#28 0x00ffc721 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#29 0x0067a19e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#30 0x006aac10 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#31 0x006a8122 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#32 0x06e7425f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0x06e74990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0x06e74c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#35 0x006a8ada in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#36 0x062d2e3a in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#37 0x006791dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#38 0x00679421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#39 0x0067e19d in QCoreApplication::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#40 0x062188f4 in QApplication::exec() () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#41 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293080, bug 293071, bug 293037, bug 293027, bug 293021.

Reported using DrKonqi
Comment 1 zaca 2012-02-02 02:32:03 UTC
Created attachment 68419 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

Desde la instalaciòn de kubuntu en mi ordenador cuando ejecuto el centro de software de muon intenta abrir y tras permanecer unos instantes en la pantalla se cierra y aparece este gestor de errores

-- Backtrace (Reduced):
#7  0x00808e11 in QtPrivate::QStringList_contains (that=0xbfc44114, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfc44114) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8fc3f70) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8fc3f70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfc44334) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x008b5b7d in metacall (argv=0xbfc44334, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8fc3f70) at kernel/qmetaobject.cpp:237
Comment 2 Jekyll Wu 2012-02-02 06:05:59 UTC

*** This bug has been marked as a duplicate of bug 291262 ***