Bug 293080 - muon szoftvercenter megnyitáskor összeeeomlik
Summary: muon szoftvercenter megnyitáskor összeeeomlik
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-01 20:28 UTC by fiszis
Modified: 2012-02-02 05:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fiszis 2012-02-01 20:28:45 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Feltelepitése alkalmával ( összes öszetevö ) intitás alkamával összeömlik , hiába inditom ujra.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon szoftverközpont (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7744930 (LWP 5770))]

Thread 2 (Thread 0xb5578b70 (LWP 5774)):
#0  0x00cfc40e in poll () from /lib/i386-linux-gnu/libc.so.6
#1  0x0948b34b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x0947c896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0947cc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x00a2eb37 in QEventDispatcherGlib::processEvents (this=0x9f34448, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x009ff1dd in QEventLoop::processEvents (this=0xb55782b0, flags=...) at kernel/qeventloop.cpp:149
#6  0x009ff421 in QEventLoop::exec (this=0xb55782b0, flags=...) at kernel/qeventloop.cpp:201
#7  0x0090290b in QThread::exec (this=0xa02a8e8) at thread/qthread.cpp:498
#8  0x009dfe2d in QInotifyFileSystemWatcherEngine::run (this=0xa02a8e8) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x009057b3 in QThreadPrivate::start (arg=0xa02a8e8) at thread/qthread_unix.cpp:331
#10 0x00bbfd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x00d0b0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7744930 (LWP 5770)):
[KCrash Handler]
#7  0x00959e11 in QtPrivate::QStringList_contains (that=0xbf8d5014, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf8d5014) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9ed0d78) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9ed0d78, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8d5234) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00a06b7d in metacall (argv=0xbf8d5234, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9ed0d78) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9ed0d78, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf8d5234) at kernel/qmetaobject.cpp:232
#13 0x00a15a6a in QMetaObject::activate (sender=0x9f45c98, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9f45c98) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9f45c98, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8d5378) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00a06b7d in metacall (argv=0xbf8d5378, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9f45c98) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9f45c98, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf8d5378) at kernel/qmetaobject.cpp:232
#18 0x00a15a6a in QMetaObject::activate (sender=0x9ed0d78, m=0x80950c0, local_signal_index=0, argv=0xbf8d5378) at kernel/qobject.cpp:3278
#19 0x003af7c5 in MuonMainWindow::backendReady (this=0x9ed0d78, _t1=0x9ed88c8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x003af933 in MuonMainWindow::initObject (this=0x9ed0d78) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9ed0d78) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9ed0d78, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8d54a4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00a06b7d in metacall (argv=0xbf8d54a4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9ed0d78) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9ed0d78, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf8d54a4) at kernel/qmetaobject.cpp:232
#25 0x00a15a6a in QMetaObject::activate (sender=0x9f2fd78, m=0xb36238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00a1d375 in QSingleShotTimer::timeout (this=0x9f2fd78) at .moc/release-shared/qtimer.moc:82
#27 0x00a1d42c in QSingleShotTimer::timerEvent (this=0x9f2fd78) at kernel/qtimer.cpp:308
#28 0x00a18994 in QObject::event (this=0x9f2fd78, e=0xbf8d589c) at kernel/qobject.cpp:1181
#29 0x013e2d84 in notify_helper (e=0xbf8d589c, receiver=0x9f2fd78, this=0x9dce990) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9dce990, receiver=0x9f2fd78, e=0xbf8d589c) at kernel/qapplication.cpp:4458
#31 0x013e8133 in QApplication::notify (this=0xbf8d589c, receiver=0x9f2fd78, e=0xbf8d589c) at kernel/qapplication.cpp:3886
#32 0x01038971 in KApplication::notify (this=0xbf8d5bb0, receiver=0x9f2fd78, event=0xbf8d589c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00a0019e in QCoreApplication::notifyInternal (this=0xbf8d5bb0, receiver=0x9f2fd78, event=0xbf8d589c) at kernel/qcoreapplication.cpp:787
#34 0x00a30c10 in sendEvent (event=0xbf8d589c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9dca234) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00a2e122 in timerSourceDispatch (source=0x9dca200) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0947c25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x0947c990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x0947cc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00a2eada in QEventDispatcherGlib::processEvents (this=0x9dac238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0149ae7a in QGuiEventDispatcherGlib::processEvents (this=0x9dac238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x009ff1dd in QEventLoop::processEvents (this=0xbf8d5b14, flags=...) at kernel/qeventloop.cpp:149
#43 0x009ff421 in QEventLoop::exec (this=0xbf8d5b14, flags=...) at kernel/qeventloop.cpp:201
#44 0x00a0419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x013e0924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293071, bug 293037, bug 293027, bug 293021, bug 293015.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-02 05:52:36 UTC

*** This bug has been marked as a duplicate of bug 291262 ***