Bug 293037 - Muon-Programmverwaltung won't open
Summary: Muon-Programmverwaltung won't open
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-01 12:04 UTC by ott
Modified: 2012-02-01 12:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ott 2012-02-01 12:04:28 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I opend Muon Programmverwalung,  but it never opend. It allways crashed.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb482e930 (LWP 3003))]

Thread 2 (Thread 0xb0b91b70 (LWP 3009)):
#0  0xb537ad10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb72557d5 in do_gettime (frac=0xb0b91020, sec=0xb0b91018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb73284b6 in QTimerInfoList::updateCurrentTime (this=0x88009b4) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb732880a in QTimerInfoList::timerWait (this=0x88009b4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb7327053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb0b9112c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb73270ed in timerSourcePrepare (source=0x8800980, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb52c088c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb52c1637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb52c1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb7327b37 in QEventDispatcherGlib::processEvents (this=0x87131e0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb72f81dd in QEventLoop::processEvents (this=0xb0b912b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb72f8421 in QEventLoop::exec (this=0xb0b912b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb71fb90b in QThread::exec (this=0x86e2718) at thread/qthread.cpp:498
#14 0xb72d8e2d in QInotifyFileSystemWatcherEngine::run (this=0x86e2718) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb71fe7b3 in QThreadPrivate::start (arg=0x86e2718) at thread/qthread_unix.cpp:331
#16 0xb53a7d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb5df40ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb482e930 (LWP 3003)):
[KCrash Handler]
#7  0xb7252e11 in QtPrivate::QStringList_contains (that=0xbf9f03a4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf9f03a4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8696428) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8696428, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9f05c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb72ffb7d in metacall (argv=0xbf9f05c4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8696428) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8696428, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf9f05c4) at kernel/qmetaobject.cpp:232
#13 0xb730ea6a in QMetaObject::activate (sender=0x870ebb8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x870ebb8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x870ebb8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9f0708) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb72ffb7d in metacall (argv=0xbf9f0708, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x870ebb8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x870ebb8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf9f0708) at kernel/qmetaobject.cpp:232
#18 0xb730ea6a in QMetaObject::activate (sender=0x8696428, m=0x80950c0, local_signal_index=0, argv=0xbf9f0708) at kernel/qobject.cpp:3278
#19 0xb776d7c5 in MuonMainWindow::backendReady (this=0x8696428, _t1=0x86a8040) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb776d933 in MuonMainWindow::initObject (this=0x8696428) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8696428) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8696428, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9f0834) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb72ffb7d in metacall (argv=0xbf9f0834, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8696428) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8696428, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf9f0834) at kernel/qmetaobject.cpp:232
#25 0xb730ea6a in QMetaObject::activate (sender=0x8703918, m=0xb742f238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb7316375 in QSingleShotTimer::timeout (this=0x8703918) at .moc/release-shared/qtimer.moc:82
#27 0xb731642c in QSingleShotTimer::timerEvent (this=0x8703918) at kernel/qtimer.cpp:308
#28 0xb7311994 in QObject::event (this=0x8703918, e=0xbf9f0c2c) at kernel/qobject.cpp:1181
#29 0xb60e0d54 in notify_helper (e=0xbf9f0c2c, receiver=0x8703918, this=0x859f210) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x859f210, receiver=0x8703918, e=0xbf9f0c2c) at kernel/qapplication.cpp:4458
#31 0xb60e6103 in QApplication::notify (this=0xbf9f0c2c, receiver=0x8703918, e=0xbf9f0c2c) at kernel/qapplication.cpp:3886
#32 0xb6eff681 in KApplication::notify (this=0xbf9f0f40, receiver=0x8703918, event=0xbf9f0c2c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb72f919e in QCoreApplication::notifyInternal (this=0xbf9f0f40, receiver=0x8703918, event=0xbf9f0c2c) at kernel/qcoreapplication.cpp:787
#34 0xb7329c10 in sendEvent (event=0xbf9f0c2c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x859a164) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb7327122 in timerSourceDispatch (source=0x859a130) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb52c125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb52c1990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb52c1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb7327ada in QEventDispatcherGlib::processEvents (this=0x857c238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb6198e3a in QGuiEventDispatcherGlib::processEvents (this=0x857c238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb72f81dd in QEventLoop::processEvents (this=0xbf9f0ea4, flags=...) at kernel/qeventloop.cpp:149
#43 0xb72f8421 in QEventLoop::exec (this=0xbf9f0ea4, flags=...) at kernel/qeventloop.cpp:201
#44 0xb72fd19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb60de8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293027, bug 293021, bug 293015, bug 292987, bug 292984.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-01 12:24:59 UTC

*** This bug has been marked as a duplicate of bug 291262 ***