Bug 292865 - Error Muon
Summary: Error Muon
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-30 12:23 UTC by hacker
Modified: 2012-01-30 12:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hacker 2012-01-30 12:23:17 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
It is necessary to x64 architecture, when we go in the Muon, immediately flies out error. Please fix this problem.

The crash can be reproduced every time.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f66bcf02780 (LWP 2182))]

Thread 2 (Thread 0x7f66a81d3700 (LWP 2186)):
#0  0x00007f66b9ad6773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f66b634bf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f66b634c429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f66bbc94f3e in QEventDispatcherGlib::processEvents (this=0x1426450, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f66bbc68cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f66bbc68ef7 in QEventLoop::exec (this=0x7f66a81d2dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f66bbb8027f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f66bbc4bcbf in QInotifyFileSystemWatcherEngine::run (this=0x143c1e0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f66bbb82d05 in QThreadPrivate::start (arg=0x143c1e0) at thread/qthread_unix.cpp:331
#9  0x00007f66b6e2defc in start_thread (arg=0x7f66a81d3700) at pthread_create.c:304
#10 0x00007f66b9ae289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f66bcf02780 (LWP 2182)):
[KCrash Handler]
#6  0x00007f66bbbd0a5e in QtPrivate::QStringList_contains (that=0x7fffa1c6fa60, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffa1c6fa60) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x13a4e00) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x13a4e00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa1c70030) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f66bbc7ceba in QMetaObject::activate (sender=0x1417710, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1417710, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa1c70190) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f66bbc7ceba in QMetaObject::activate (sender=0x13a4e00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffa1c70190) at kernel/qobject.cpp:3278
#13 0x00007f66bcaf2e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x12bde80) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f66bcaf2f8e in MuonMainWindow::initObject (this=0x13a4e00) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x13a4e00) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x13a4e00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa1c70260) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f66bbc7ceba in QMetaObject::activate (sender=0x143f0f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f66bbc84f7f in QSingleShotTimer::timerEvent (this=0x143f0f0) at kernel/qtimer.cpp:308
#19 0x00007f66bbc80789 in QObject::event (this=0x143f0f0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f66ba2a3474 in notify_helper (e=0x7fffa1c707d0, receiver=0x143f0f0, this=0x122f030) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x122f030, receiver=0x143f0f0, e=0x7fffa1c707d0) at kernel/qapplication.cpp:4458
#22 0x00007f66ba2a82e1 in QApplication::notify (this=0x7fffa1c70ad0, receiver=0x143f0f0, e=0x7fffa1c707d0) at kernel/qapplication.cpp:4365
#23 0x00007f66bb488466 in KApplication::notify (this=0x7fffa1c70ad0, receiver=0x143f0f0, event=0x7fffa1c707d0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f66bbc69afc in QCoreApplication::notifyInternal (this=0x7fffa1c70ad0, receiver=0x143f0f0, event=0x7fffa1c707d0) at kernel/qcoreapplication.cpp:787
#25 0x00007f66bbc96d62 in sendEvent (event=0x7fffa1c707d0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x12344f0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f66bbc94514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f66b634ba5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f66b634c258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f66b634c429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f66bbc94ed6 in QEventDispatcherGlib::processEvents (this=0x120a6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f66ba34b10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f66bbc68cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f66bbc68ef7 in QEventLoop::exec (this=0x7fffa1c70a60, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f66bbc6d789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fffa1c70d48) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292823, bug 292818, bug 292793, bug 292769, bug 292748.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-30 12:30:34 UTC

*** This bug has been marked as a duplicate of bug 291262 ***