Bug 292123 - muon not working
Summary: muon not working
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-21 16:45 UTC by erni83
Modified: 2012-01-21 16:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description erni83 2012-01-21 16:45:03 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
when I tray open muon, muon not working and windows off. I dont no whats doing i cant install eny programs. Pleas help

The crash can be reproduced every time.

-- Backtrace:
Application: Centrum oprogramowania Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f777ed66780 (LWP 1892))]

Thread 2 (Thread 0x7f776a285700 (LWP 1893)):
#0  0x00007f777b940773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f77781b5f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f77781b6429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f777dafdf3e in QEventDispatcherGlib::processEvents (this=0x1e77a50, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f777dad1cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f777dad1ef7 in QEventLoop::exec (this=0x7f776a284dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f777d9e927f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f777dab4cbf in QInotifyFileSystemWatcherEngine::run (this=0x1dbba70) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f777d9ebd05 in QThreadPrivate::start (arg=0x1dbba70) at thread/qthread_unix.cpp:331
#9  0x00007f7778c97efc in start_thread (arg=0x7f776a285700) at pthread_create.c:304
#10 0x00007f777b94c89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f777ed66780 (LWP 1892)):
[KCrash Handler]
#6  0x00007f777da39a5e in QtPrivate::QStringList_contains (that=0x7fffc87fd760, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffc87fd760) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1f5b4f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1f5b4f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc87fdd30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f777dae5eba in QMetaObject::activate (sender=0x211b560, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x211b560, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc87fde90) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f777dae5eba in QMetaObject::activate (sender=0x1f5b4f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc87fde90) at kernel/qobject.cpp:3278
#13 0x00007f777e958e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1fa7750) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f777e958f8e in MuonMainWindow::initObject (this=0x1f5b4f0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1f5b4f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1f5b4f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc87fdf60) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f777dae5eba in QMetaObject::activate (sender=0x1fc2a30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f777daedf7f in QSingleShotTimer::timerEvent (this=0x1fc2a30) at kernel/qtimer.cpp:308
#19 0x00007f777dae9789 in QObject::event (this=0x1fc2a30, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f777c10d424 in notify_helper (e=0x7fffc87fe4d0, receiver=0x1fc2a30, this=0x1dde370) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1dde370, receiver=0x1fc2a30, e=0x7fffc87fe4d0) at kernel/qapplication.cpp:4458
#22 0x00007f777c112291 in QApplication::notify (this=0x7fffc87fe7d0, receiver=0x1fc2a30, e=0x7fffc87fe4d0) at kernel/qapplication.cpp:4365
#23 0x00007f777d2f1126 in KApplication::notify (this=0x7fffc87fe7d0, receiver=0x1fc2a30, event=0x7fffc87fe4d0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f777dad2afc in QCoreApplication::notifyInternal (this=0x7fffc87fe7d0, receiver=0x1fc2a30, event=0x7fffc87fe4d0) at kernel/qcoreapplication.cpp:787
#25 0x00007f777daffd62 in sendEvent (event=0x7fffc87fe4d0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1ddca90) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f777dafd514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f77781b5a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f77781b6258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f77781b6429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f777dafded6 in QEventDispatcherGlib::processEvents (this=0x1db66f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f777c1b507e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f777dad1cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f777dad1ef7 in QEventLoop::exec (this=0x7fffc87fe760, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f777dad6789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffc87fea48) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 292116, bug 292093, bug 292087, bug 292078, bug 292074.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-21 16:52:38 UTC

*** This bug has been marked as a duplicate of bug 291262 ***