Bug 292116 - Crash
Summary: Crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-21 15:58 UTC by lorenzo.zanna
Modified: 2012-01-21 16:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lorenzo.zanna 2012-01-21 15:58:23 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

When I open the software centrer this crash.
I don't know why!
I repeate open the Muon Software Center but every opening
this crash!

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f518dba3780 (LWP 20478))]

Thread 2 (Thread 0x7f51791e4700 (LWP 20479)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f51791e3af0 in ?? ()
#2  0x00007fffd7bff7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f518dba3780 (LWP 20478)):
[KCrash Handler]
#6  0x00007f518c86ba5e in QtPrivate::QStringList_contains (that=0x7fffd7ba77d0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffd7ba77d0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x119fc00) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x119fc00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd7ba7da0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f518c917eba in QMetaObject::activate (sender=0x135e7c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x135e7c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd7ba7f00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f518c917eba in QMetaObject::activate (sender=0x119fc00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffd7ba7f00) at kernel/qobject.cpp:3278
#13 0x00007f518d78ae7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1199d30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f518d78af8e in MuonMainWindow::initObject (this=0x119fc00) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x119fc00) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x119fc00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd7ba7fd0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f518c917eba in QMetaObject::activate (sender=0x1227ee0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f518c91ff7f in QSingleShotTimer::timerEvent (this=0x1227ee0) at kernel/qtimer.cpp:308
#19 0x00007f518c91b789 in QObject::event (this=0x1227ee0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f518af3f424 in notify_helper (e=0x7fffd7ba8540, receiver=0x1227ee0, this=0x1020c60) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1020c60, receiver=0x1227ee0, e=0x7fffd7ba8540) at kernel/qapplication.cpp:4458
#22 0x00007f518af44291 in QApplication::notify (this=0x7fffd7ba8840, receiver=0x1227ee0, e=0x7fffd7ba8540) at kernel/qapplication.cpp:4365
#23 0x00007f518c123126 in KApplication::notify (this=0x7fffd7ba8840, receiver=0x1227ee0, event=0x7fffd7ba8540) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f518c904afc in QCoreApplication::notifyInternal (this=0x7fffd7ba8840, receiver=0x1227ee0, event=0x7fffd7ba8540) at kernel/qcoreapplication.cpp:787
#25 0x00007f518c931d62 in sendEvent (event=0x7fffd7ba8540, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x101e290) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f518c92f514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f5186fe7a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f5186fe8258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f5186fe8429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f518c92fed6 in QEventDispatcherGlib::processEvents (this=0xff96f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f518afe707e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f518c903cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f518c903ef7 in QEventLoop::exec (this=0x7fffd7ba87d0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f518c908789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffd7ba8ab8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 292093, bug 292087, bug 292078, bug 292074, bug 292054.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-21 16:10:39 UTC

*** This bug has been marked as a duplicate of bug 291262 ***